Mailbox configuration routing

Discussion in 'Installation/Configuration' started by xfxchilde, Jun 7, 2012.

  1. xfxchilde

    xfxchilde New Member

    I have multiple domains hosted on a box dedicated for email with ISPConfig 3.

    I'm noticed that some servers are giving me bounce backs for bad rDNS (didnt think it was going to be an issue)

    So i have multiple static ips setup with the proper rDNS for each domain. How can i configure postfix to send from there respected IPs per [email protected] for
    [email protected] for
    [email protected] for

    Is this possible with a single server? Server is behind a VPN/Firewall that has All ips routed to the same internal address. (might be an issue not sure)

    Any input would be awesome. At least something to get me on the right path. Might be possible to push the ips to the server itself if needed for solution. If not ill just have to do some type of VMs inside of a single server might be my only choice. i suppose i could assign mutiple internal IPs to the single ethernet card and bind the ips at the device that way as well.

    Thanks guys, I 99.9% of i always found an answer by searching the forum. I just didnt see something like this posted. I've been using ispconfig for a few months and its AWESOME!
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    It is not nescessary to setup postfix in that way to prevent the rdns problem. Just ensure that the reverse dns records for all IP addresses point to the hostname of your server and not to a customer domain as postfix identifies itself at the other servers with the server hostname, the domain of the sender in the email does not matter here.
  3. xfxchilde

    xfxchilde New Member

    I was just using the admin profile for this since its all personal use. i just love the ispconfig layout and functions. Should i create separate accounts for each domain for the email?

    Also everytime i do that for my mail records mx toolbox comes back and says the RDNS matches but for the ip assigned to that main domain... so email servers seeing @domain and sending from is the issue.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    No. Clients are just access restrictions to records in the ispconfig interface, they have no influence on your email setup. What I referred to was the setup of your rdns records, change them so that the rdns for the IP addresses points to hostname of the server and not to a email domain.

    So if the hostname is e.g. server1.somedomain.tld and you host the email domains domain1.tld, domain2.tld and domain3.tld, then the rdns record of the IP address of your server should point back to server1.somedomain.tld. The next thisng that you should check is that the hostname of your server and the "mydomain" setting in postfix main.xf is really a subdomain like server1.somedomain.tld and not domain1.tld, domain2.tld or domain3.tld and the hostname server1.somedomain.tld has to exist in DNS as A-Record and this A-Record must point to the IP address of your server. So when you test the hsotanme of your server with:

    dig server1.somedomain.tld

    then it should return the IP address of the server and when your run dig on the IP address of your server, then it should return the hostname as reverse dns record.
  5. xfxchilde

    xfxchilde New Member

    I think i understand now, so the mix up is with the DNS and not postfix. I'm going to double check some settings and test in about an hour or two. all my servers are behind a Prosafe firewall and i have all the external ips forwarded to the internal ip of the server to allow inbound connections. So im going to give this another shot and see what happens :)

    Thanks alot for the quick replies!
  6. xfxchilde

    xfxchilde New Member

    220 mail.(serverboxname).com ESMTP Postfix (Debian/GNU)
    Status Result
    OK - resolves to
    Warning - Reverse DNS does not match SMTP Banner
    OK - Supports TLS.
    0 seconds - Good on Connection time
    OK - Not an open relay.
    0.546 seconds - Good on Transaction Time
    Session Transcript:
  7. xfxchilde

    xfxchilde New Member

    Here is the issue at hand.

    -Queue ID- --Size-- ----Arrival Time---- -Sender/Recipient-------
    1C3A2F7DC5 4560 Thu Jun 7 01:57:36 [email protected]
    (host[] refused to talk to me: 554 [95E4FED2-6BDB-41FB-8A02-611B756562E7] [] Please setup matching DNS and rDNS records:
    [email protected] points to is pointed to the same system with confirmed different rDNS settings.
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok your revserse record is wrong as it does not use the hostname like I explained above. Your hostname is mail.(serverboxname).com and thats the name were the reverse record has to point to. Change the reverse record so that it poinst to the hostname.
  9. xfxchilde

    xfxchilde New Member

    I'll contact my ISP to have the ip rDNS changed to

    i just dont understand how that is going to change the error from sending. because the error is coming back from the ip address on and not

    There isnt a configuration where

    domain-1 sends from ip ending in 120
    systemdomain sends from ip ending in 126?

    its the sending IP address not matching the domain im emailing from is the problem.

    i dont have a problem with that server when i send from [email protected]

    just any other domain i have linked on that box for emai.
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    No. Postfix uses just one of the domains of your server for sending, there is no connection between sender email address that you choose in your email client for a email to the IP address that postfix uses to send this email and thats absolutely ok as it does not matter for this problem.

    No, thats not the problem. The problem is that your reverse dns of the IP address(es) do not match with the server hostname. The error is clear that you posted:

    OK - resolves to

    or in other words, the IP address has a reverse record which points to instead of mail.(serverboxname).com.

    A postfix mail system identifies itself to other server always with the hostname of the server (mail.(serverboxname).com), the domain that is used as sender address does not matter here.

Share This Page