1. Hello,
    I'm mostly using ISPConfig because it makes it easy to manage multiple domains for mailman and e-mail, plus squirrelmail is an added bonus.
    In a previous iteration, I was able to create mail users pretty easily. Now Apache2 is outputting this error:
    Code:
    [Fri Sep 11 15:47:11.443308 2015] [:error] [pid 3628] [client -snip-:59043] script '/usr/share/squirrelmail/mail_domain_list.php' not found or unable to stat, referer: https://fre.erepublic.party:8080/
    [Fri Sep 11 15:47:14.996254 2015] [:error] [pid 3628] [client -snip-:59043] script '/usr/share/squirrelmail/mail_user_list.php' not found or unable to stat, referer: https://fre.erepublic.party:8080/
    [Fri Sep 11 15:47:18.321143 2015] [:error] [pid 3628] [client -snip-:59043] script '/usr/share/squirrelmail/mail_domain_catchall_list.php' not found or unable to stat, referer: https://fre.erepublic.party:8080/
    [Fri Sep 11 15:47:35.153587 2015] [:error] [pid 3649] [client -snip-:59058] script '/usr/share/squirrelmail/mail_domain_list.php' not found or unable to stat, referer: https://fre.erepublic.party:8080/index.php
    [Fri Sep 11 15:47:36.905945 2015] [:error] [pid 3649] [client -snip-:59058] script '/usr/share/squirrelmail/mail_user_list.php' not found or unable to stat, referer: https://fre.erepublic.party:8080/index.php
    [Fri Sep 11 15:47:38.405610 2015] [:error] [pid 3649] [client -snip-:59058] script '/usr/share/squirrelmail/mail_user_list.php' not found or unable to stat, referer: https://fre.erepublic.party:8080/index.php
    [Fri Sep 11 15:47:38.878691 2015] [:error] [pid 3649] [client -snip-:59058] script '/usr/share/squirrelmail/mail_user_list.php' not found or unable to stat, referer: https://fre.erepublic.party:8080/index.php
    [Fri Sep 11 15:47:38.957863 2015] [:error] [pid 3649] [client -snip-:59058] script '/usr/share/squirrelmail/mail_user_list.php' not found or unable to stat, referer: https://fre.erepublic.party:8080/index.php
    [Fri Sep 11 15:47:39.033604 2015] [:error] [pid 3649] [client -snip-:59058] script '/usr/share/squirrelmail/mail_user_list.php' not found or unable to stat, referer: https://fre.erepublic.party:8080/index.php
    [Fri Sep 11 15:47:39.107017 2015] [:error] [pid 3649] [client -snip-:59058] script '/usr/share/squirrelmail/mail_user_list.php' not found or unable to stat, referer: https://fre.erepublic.party:8080/index.php
    [Fri Sep 11 15:47:39.176151 2015] [:error] [pid 3649] [client -snip-:59058] script '/usr/share/squirrelmail/mail_user_list.php' not found or unable to stat, referer: https://fre.erepublic.party:8080/index.php
    [Fri Sep 11 15:47:39.257845 2015] [:error] [pid 3649] [client -snip-:59058] script '/usr/share/squirrelmail/mail_user_list.php' not found or unable to stat, referer: https://fre.erepublic.party:8080/index.php
    [Fri Sep 11 16:00:39.353050 2015] [:error] [pid 3653] [client -snip-:59395] script '/usr/share/squirrelmail/mail_domain_list.php' not found or unable to stat, referer: https://fre.erepublic.party:8080/
    [Fri Sep 11 16:00:40.973324 2015] [:error] [pid 3653] [client -snip-:59395] script '/usr/share/squirrelmail/mail_user_list.php' not found or unable to stat, referer: https://fre.erepublic.party:8080/
    [Fri Sep 11 16:01:41.574996 2015] [:error] [pid 3628] [client -snip-:59399] script '/usr/share/squirrelmail/mail_domain_list.php' not found or unable to stat, referer: https://fre.erepublic.party:8080/
    [Fri Sep 11 16:01:45.005987 2015] [:error] [pid 3628] [client -snip-:59399] script '/usr/share/squirrelmail/mail_domain_list.php' not found or unable to stat, referer: https://fre.erepublic.party:8080/
    [Fri Sep 11 16:01:47.093275 2015] [:error] [pid 3628] [client -snip-:59399] script '/usr/share/squirrelmail/mail_domain_list.php' not found or unable to stat, referer: https://fre.erepublic.party:8080/
    [Fri Sep 11 16:01:49.202430 2015] [:error] [pid 3628] [client -snip-:59399] script '/usr/share/squirrelmail/mail_domain_list.php' not found or unable to stat, referer: https://fre.erepublic.party:8080/
    
    This is a 64bit Debian 8.1 server running the latest version of ISPConfig. I even tried reconfiguring.

    Here is the text of the configuration test I was instructed to run when reading the forum sticky:

    Code:
    ##### SERVER #####
    IP-address (as per hostname): ***.***.***.***
    IP-address(es) (as per ifconfig): ***.***.***.***
    [WARN] ip addresses from hostname differ from ifconfig output. Please check your ip settings.
    [INFO] ISPConfig is installed.
    
    ##### ISPCONFIG #####
    ISPConfig version is 3.0.5.4p8
    
    
    ##### VERSION CHECK #####
    
    [INFO] php (cli) version is 5.6.12-0+deb8u1
    [INFO] php-cgi (used for cgi php in default vhost!) is version 5.6.12-0+deb8u1
    
    ##### PORT CHECK #####
    
    
    ##### MAIL SERVER CHECK #####
    
    
    ##### RUNNING SERVER PROCESSES #####
    
    [INFO] I found the following web server(s):
       Apache 2 (PID 3526)
    [INFO] I found the following mail server(s):
       Postfix (PID 3374)
    [INFO] I found the following pop3 server(s):
       Dovecot (PID 3455)
    [INFO] I found the following imap server(s):
       Unknown process (init) (PID 1)
    [INFO] I found the following ftp server(s):
       PureFTP (PID 3579)
    
    ##### LISTENING PORTS #####
    (only     ()
    Local     (Address)
    [anywhere]:110     (3455/dovecot)
    [anywhere]:143     (1/init)
    [anywhere]:111     (473/rpcbind)
    [anywhere]:465     (3374/master)
    ***.***.***.***:53     (3588/named)
    [localhost]:53     (3588/named)
    [anywhere]:21     (3579/pure-ftpd)
    [anywhere]:22     (1669/sshd)
    [localhost]:953     (3588/named)
    [anywhere]:25     (3374/master)
    [localhost]:6010     (1799/0)
    [localhost]:6011     (3916/1)
    [localhost]:6012     (4270/2)
    [anywhere]:993     (1/init)
    [anywhere]:51457     (492/rpc.statd)
    [anywhere]:995     (3455/dovecot)
    [localhost]:10024     (3447/amavisd-new)
    [localhost]:10025     (3374/master)
    [anywhere]:3306     (2994/mysqld)
    [anywhere]:587     (3374/master)
    [localhost]:11211     (574/memcached)
    [localhost]10     (3455/dovecot)
    [localhost]43     (1/init)
    *:*:*:*::*:58799     (492/rpc.statd)
    [localhost]11     (473/rpcbind)
    *:*:*:*::*:8080     (3526/apache2)
    *:*:*:*::*:80     (3526/apache2)
    *:*:*:*::*:8081     (3526/apache2)
    *:*:*:*::*:465     (3374/master)
    *:*:*:*::*:53     (3588/named)
    *:*:*:*::*:21     (3579/pure-ftpd)
    *:*:*:*::*:22     (1669/sshd)
    *:*:*:*::*:953     (3588/named)
    *:*:*:*::*:25     (3374/master)
    *:*:*:*::*:6010     (1799/0)
    *:*:*:*::*:6011     (3916/1)
    *:*:*:*::*:443     (3526/apache2)
    *:*:*:*::*:6012     (4270/2)
    *:*:*:*::*:993     (1/init)
    *:*:*:*::*:995     (3455/dovecot)
    *:*:*:*::*:10024     (3447/amavisd-new)
    *:*:*:*::*:587     (3374/master)
    
    ##### IPTABLES #####
    Chain INPUT (policy ACCEPT)
    target  prot opt source  destination   
    fail2ban-postfix-sasl  tcp  --  [anywhere]/0  [anywhere]/0  multiport dports 25
    fail2ban-dovecot-pop3imap  tcp  --  [anywhere]/0  [anywhere]/0  multiport dports
     110,995,143,993
    fail2ban-pureftpd  tcp  --  [anywhere]/0  [anywhere]/0  multiport dports 21
    fail2ban-ssh  tcp  --  [anywhere]/0  [anywhere]/0  multiport dports 22
    
    Chain FORWARD (policy ACCEPT)
    target  prot opt source  destination   
    
    Chain OUTPUT (policy ACCEPT)
    target  prot opt source  destination   
    
    Chain fail2ban-dovecot-pop3imap (1 references)
    target  prot opt source  destination   
    RETURN  all  --  [anywhere]/0  [anywhere]/0   
    
    Chain fail2ban-postfix-sasl (1 references)
    target  prot opt source  destination   
    RETURN  all  --  [anywhere]/0  [anywhere]/0   
    
    Chain fail2ban-pureftpd (1 references)
    target  prot opt source  destination   
    RETURN  all  --  [anywhere]/0  [anywhere]/0
    
    Chain fail2ban-ssh (1 references)
    target  prot opt source  destination   
    RETURN  all  --  [anywhere]/0  [anywhere]/0 
    
    Any clues on where I screwed up and how to fix it? I've been trying for about 5 days to get this working, largely stumbling in the dark. I have no problems running a regular Apache2 setup, but this mailserver business has really tested my patience and abilities!

    Thank you in advance!
     

Share This Page