mail_access table empty?

Discussion in 'ISPConfig 3 Priority Support' started by ledoktre, May 15, 2014.

  1. ledoktre

    ledoktre Member

    Hey,

    Just setup a dedicated box for some email, and added it to the party. I have just a basic squirrelmail installed on it, and I am able to login just fine. I can see I am receiving mails. When I try to send out, postfix complains :

    May 15 01:20:50 a3 postfix/smtpd[4635]: warning: table "mysql:/etc/postfix/mysql-virtual_client.cf": empty query string -- ignored
    May 15 01:20:50 a3 postfix/smtpd[4635]: NOQUEUE: reject: RCPT from localhost[::1]: 554 5.7.1 <localhost[::1]>: Client host rejected: Access denied; from=<*****> to=<*****> proto=ESMTP helo=<*****>

    So I look at the pertaining mysql file, and I see what its checking :

    dbname = dbispconfig
    table = mail_access
    select_field = access
    where_field = source
    additional_conditions = and type = 'client' and active = 'y'
    hosts = 127.0.0.1

    The part that bestumples me is that that table is 100% empty, when I look via phpMyAdmin. I added a mail domain. I added an email account. They are enabled. I'm not using any spam filtering on this box -- filtering before it arrives.

    So where did I go wrong?

    Thanks,
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats ok. The mail accesstable should be empty, it is used only for transports, not local email domains and accounts.
     
  3. ledoktre

    ledoktre Member

    Then Ive got another issue. I cannot send out any email. Im logged in on squirrelmail, it is using the username/password for imap to send out on smtp. But it fails :

    554 5.7.1 <localhost[::1]>: Client host rejected: Access denied

    I was focusing on the wrong line in the post before. I am going to do some searching but any feedback is welcomed.

    May 15 01:20:50 a3 postfix/smtpd[4635]: NOQUEUE: reject: RCPT from localhost[::1]: 554 5.7.1 <localhost[::1]>: Client host rejected: Access denied; from=<*****> to=<*****> proto=ESMTP helo=<*****>

    Thanks,
     
  4. ledoktre

    ledoktre Member

    I did on a whim try setting postfix to ipv4. Still get :

    Transaction failed
    554 5.7.1 <localhost[127.0.0.1]>: Client host rejected: Access denied

    So I'm going to keep digging.
     
  5. Try adding ::1 to the host line:

    user = ispconfig
    password = <long string of characters>
    dbname = dbispconfig
    table = mail_access
    select_field = access
    where_field = source
    additional_conditions = and type = 'client' and active = 'y'
    hosts = 127.0.0.1 ::1

    I was getting

    warning: table "mysql:/etc/postfix/mysql-virtual_client.cf": empty query string -- ignored]

    until I added the ipv6 loopback.
     

Share This Page