Mail wont send correctly

Discussion in 'Installation/Configuration' started by tijn_tux, Sep 4, 2006.

  1. tijn_tux

    tijn_tux New Member

    Hi all,

    Recently installed ISPconfig on a new server, everyhing works fine, exept for the mail.

    When i try to send, i get this in my syslog

    Code:
    Sep  4 13:03:49 blackangel imapd: LOGOUT, user=martijn, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=792, sent=1540, time=1
    Sep  4 13:03:49 blackangel postfix/smtp[10149]: connect to blackangel.linux-docs.org[82.173.215.232]: Connection refused (port 25)
    Sep  4 13:03:49 blackangel postfix/smtpd[10144]: disconnect from localhost.localdomain[127.0.0.1]
    Sep  4 13:03:49 blackangel postfix/smtp[10149]: E08FF4F84C: to=<info@blackangel.linux-docs.org>, orig_to=<info@linux-docs.org>, relay=none, delay=1, status=deferred (connect to blackangel.linux-docs.org[82.173.215.232]: Connection refused)
    
    strange thing is, in my /etc/hosts i have defined blackangel.linux-docs.org as 10.0.0.10..

    I must have missed something...

    Thnx in advance

    tijn
     
  2. tijn_tux

    tijn_tux New Member

    Ok, wierd

    Well, i was looking into files and stuff, and in the file /etc/postfix/local-host-names i saw that my server url was like: blackangel.linux-docs-org :S made some manual changes, and now it works!

    Only thing, how can this be wrong? what setting defines the local-host-names file?

    Thnx in advance

    tijn
     
  3. falko

    falko Super Moderator ISPConfig Developer

    I guess that the output of
    Code:
    hostname
    and/or
    Code:
    hostname -f
    contains linux-docs-org...
    I hope you added the correct FQDN at the bottom of /etc/postfix/local-host-names so that it won't be overwritten in the future. :)
     

Share This Page