Mail User Interface - RoundCube

Discussion in 'Developers' Forum' started by moglia, Jan 17, 2012.

  1. moglia

    moglia New Member

    On Latest update to stable version.

    All Functions The Same Error:

    Soap Error: There is no sysuser account for this client ID. (See Attached File)
    ISPConfig Version: 3.0.4.2

    Checked functions on remote user table:

    Code:
    mail_domain_get,mail_domain_add,mail_domain_update,mail_domain_delete;mail_user_get,mail_user_add,mail_user_update,mail_user_delete;mail_alias_get,mail_alias_add,mail_alias_update,mail_alias_delete;mail_forward_get,mail_forward_add,mail_forward_update,mail_forward_delete;mail_spamfilter_whitelist_get,mail_spamfilter_whitelist_add,mail_spamfilter_whitelist_update,mail_spamfilter_whitelist_delete;mail_spamfilter_blacklist_get,mail_spamfilter_blacklist_add,mail_spamfilter_blacklist_update,mail_spamfilter_blacklist_delete;mail_spamfilter_user_get,mail_spamfilter_user_add,mail_spamfilter_user_update,mail_spamfilter_user_delete;mail_policy_get,mail_policy_add,mail_policy_update,mail_policy_delete;mail_fetchmail_get,mail_fetchmail_add,mail_fetchmail_update,mail_fetchmail_delete;mail_user_filter_get,mail_user_filter_add,mail_user_filter_update,mail_user_filter_delete;client_get,client_get_id,client_add,client_update,client_delete;server_get
    I belive something is changed.
     

    Attached Files:

  2. till

    till Super Moderator

    I installed the roundcube plugin for a customer last friday and it works fine. So either you dont use the latest version of the roundcube plugin or not all required functions are enabled for the remote user. Please see here for ltaest roundcube plugin version and soap user permissions:

    http://bugs.web-wack.at/projects/isp3-roundcube
     
  3. moglia

    moglia New Member

    Hi

    I´m using revision 117 i try get new code all functions i´m using on code post above.
     
  4. moglia

    moglia New Member

    Now i´m using revision 122

    Same menssage and RC 0.7
     
  5. moglia

    moglia New Member

    Note:

    I have another server running 3.0.4.1 version everyting works fine before upgrade to 3.0.4.2 something stops working. I will check database functions and permitions i don´t no if before upgrade someting is updated.
     
  6. Horfic

    Horfic Member

    I have looked at his setup, looks fine. But calling

    $mail_user = $this->soap->mail_user_get($session_id, array('email' => $this->rcmail_inst->user->data['username']));

    this in roundcube results to a empty return.

    We tried it even with the email as string instead of the variable.

    No Luck
     
  7. moglia

    moglia New Member

    yeah Horfic spend some time with me on skype to try find any solution for that. Don´t see anyting possible solution.
     

Share This Page