mail server

Discussion in 'HOWTO-Related Questions' started by tommytomato, Sep 15, 2006.

  1. tommytomato

    tommytomato New Member

    Hi all

    can some one point me to a good mail server tutorial, I see there are a few to chose from, but I only want a simple mail server that can block the spam and virus, can any one point me the right way please.

    I have pre install Debian

    TT
     
  2. sjau

    sjau Local Meanie Moderator

  3. tommytomato

    tommytomato New Member

    Ok I went for this one.

    first install I came across a problem on page 2
    http://www.howtoforge.com/virtual_postfix_mysql_quota_courier_p2

    /etc/postfix/mysql-virtual_domains.cf:

    /etc/postfix/mysql-virtual_forwardings.cf:

    /etc/postfix/mysql-virtual_mailboxes.cf:

    /etc/postfix/mysql-virtual_email2email.cf:

    /etc/postfix/mysql-virtual_transports.cf:

    /etc/postfix/mysql-virtual_mailbox_limit_maps.cf:


    I dont have the above file's so where did I go wrong, is there a way to check to see if I've install every thing ok up to the stage 4 Configure Postfix

    TT
     
  4. tommytomato

    tommytomato New Member

    O is this telling me to create the 6 files needed.:confused:

    TT
     
  5. tommytomato

    tommytomato New Member

    I got as far as

    restart Postfix
    http://www.howtoforge.com/virtual_postfix_mysql_quota_courier_p3

    I get the error

    Code:
    Stopping mail transport agent: Postfix.
    Starting mail transport agent: Postfixpostconf: fatal: /etc/postfix/main.cf, lin                                              e 50: missing '=' after attribute name: "amavis unix - - - - 2 smtp        -o sm                                              tp_data_done_timeout=1200        -o smtp_send_xforward_command=yes"
    postconf: fatal: /etc/postfix/main.cf, line 50: missing '=' after attribute name                                              : "amavis unix - - - - 2 smtp        -o smtp_data_done_timeout=1200        -o sm                                              tp_send_xforward_command=yes"
    
    before this I have this message come up after clamav-daemon restart

    Code:
    Stopping ClamAV daemon: clamd
    Starting ClamAV daemon: LibClamAV Warning: *************************************                                              *******************
    LibClamAV Warning: ***  This version of the ClamAV engine is outdated.  ***
    LibClamAV Warning: *** DON'T PANIC! Read http://www.clamav.net/faq.html ***
    LibClamAV Warning: ********************************************************
    LibClamAV Warning: ********************************************************
    LibClamAV Warning: ***  This version of the ClamAV engine is outdated.  ***
    LibClamAV Warning: *** DON'T PANIC! Read http://www.clamav.net/faq.html ***
    LibClamAV Warning: ********************************************************
    clamd
    rgwmail:/etc/postfix# postconf -e 'content_filter = amavis:[127.0.0.1]:10024'
    rgwmail:/etc/postfix#  postconf -e 'receive_override_options = no_address_mappin                                              gs'

    can any one tell me what I have done wrong please, is this normal :confused:

    TT
     
  6. sjau

    sjau Local Meanie Moderator

    well, posting the config could help :)
     
  7. tommytomato

    tommytomato New Member

    I've still got the error

    Also telnet hang's

    when I run the command telnet localhost 25

    do you need to allow ports 25 and 110 to be open :confused:

    TT
     
  8. tommytomato

    tommytomato New Member

    which config file do you mean, I'm trying to back track to see where I went wrong, sorry for the delay

    TT
     
  9. tommytomato

    tommytomato New Member

    Here is my error log

    TT
     
    Last edited: Sep 25, 2006
  10. k1piee

    k1piee New Member

    the last lines in main.cf
    should be in master.cf
     
  11. tommytomato

    tommytomato New Member

    thanks for picking that up

    I've started again

    one question please

    Then edit /etc/courier/authmysqlrc. It should look like this (again, make sure to fill in the correct database details):

    Code:
    MYSQL_SERVER localhost
    MYSQL_USERNAME mail_admin
    MYSQL_PASSWORD mail_admin_password
    MYSQL_PORT 0
    MYSQL_DATABASE mail
    MYSQL_USER_TABLE users
    MYSQL_CRYPT_PWFIELD password
    #MYSQL_CLEAR_PWFIELD password
    MYSQL_UID_FIELD 5000
    MYSQL_GID_FIELD 5000
    MYSQL_LOGIN_FIELD email
    MYSQL_HOME_FIELD "/home/vmail"
    MYSQL_MAILDIR_FIELD CONCAT(SUBSTRING_INDEX(email,'@',-1),'/',SUBSTRING_INDEX(email,'@',1),'/')
    #MYSQL_NAME_FIELD
    MYSQL_QUOTA_FIELD quota
    Do I have to have my password in etc etc :confused: if you get what I mean

    One thing I wasn't sure of was to add my details to this as well and so on, by editing the correct lines user and password

    /etc/postfix/mysql-virtual_domains.cf:

    TT
     
    Last edited: Sep 25, 2006
  12. tommytomato

    tommytomato New Member

    I filled out the lines needed, hoping it was the right thing to do.

    but now i come across other error

    my apt-get doesn't have mirror-select :confused:

    Code:
    apt-get install amavisd-new spamassassin clamav clamav-daemon zoo unzip unarj bzip2
    Reading Package Lists... Done
    Building Dependency Tree... Done
    spamassassin is already the newest version.
    The following extra packages will be installed:
      arj clamav-base clamav-freshclam libarchive-tar-perl libarchive-zip-perl libclamav1 libcompress-zlib-perl
      libconvert-binhex-perl libconvert-tnef-perl libconvert-uulib-perl libcurl3 libgmp3 libio-multiplex-perl libio-string-perl
      libio-stringy-perl libio-zlib-perl libmailtools-perl libmime-perl libnet-perl libnet-server-perl libtimedate-perl
      libunix-syslog-perl
    Suggested packages:
      lha unrar nomarch lzop apt-listchanges clamav-docs daemon libcurl3-gssapi ca-certificates libmail-audit-perl
      libio-socket-ssl-perl zip
    Recommended packages:
      unzoo libnet-ph-perl libnet-snpp-perl libnet-telnet-perl
    The following NEW packages will be installed:
      amavisd-new arj bzip2 clamav clamav-base clamav-daemon clamav-freshclam libarchive-tar-perl libarchive-zip-perl libclamav1
      libcompress-zlib-perl libconvert-binhex-perl libconvert-tnef-perl libconvert-uulib-perl libcurl3 libgmp3
      libio-multiplex-perl libio-string-perl libio-stringy-perl libio-zlib-perl libmailtools-perl libmime-perl libnet-perl
      libnet-server-perl libtimedate-perl libunix-syslog-perl unarj unzip zoo
    0 upgraded, 29 newly installed, 0 to remove and 7 not upgraded.
    Need to get 32.8kB/5461kB of archives.
    After unpacking 11.2MB of additional disk space will be used.
    Do you want to continue? [Y/n] y
    Err http://ftp.iinet.net.au stable/main libtimedate-perl 1.1600-4
      404 Not Found
    Failed to fetch http://ftp.iinet.net.au/debian/debian/pool/main/t/timedate/libtimedate-perl_1.1600-4_all.deb  404 Not Found
    E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
    
    TT
     
    Last edited: Sep 25, 2006
  13. tommytomato

    tommytomato New Member

    I think I fix it by typing in the below command, :confused:

    Code:
    apt-get install amavisd-new spamassassin clamav clamav-daemon zoo unzip unarj bzip2 --fix-missing
    No it didn't work, I'm missing the file amavisd.conf

    TT
     
    Last edited: Sep 25, 2006
  14. tommytomato

    tommytomato New Member

    This time I went for a fresh install double checking every thing a picking a good mirror.

    This time I think I got it going.

    I'm able to use hotmail to send to server and able to send from server to hotmail ok, I can even send mail localy.

    I think I fluked it.

    Question
    when adding a new user to the system is the mail box created :confused: or do you have to send mail to the new user for it to create the mail box.

    TT
     
  15. tommytomato

    tommytomato New Member

    yep that worked ok, COOL

    Is there a GUI web interface for users to log into there email account via browser that will install to this config I've jsut gone though

    O any one read the mail via Outlook express

    TT
     
    Last edited: Sep 25, 2006
  16. sjau

    sjau Local Meanie Moderator

    You could install Squireelmail (quite easy I think) or Horde/IMP (never achieved that to get run) or some other webmail :)
     
  17. tommytomato

    tommytomato New Member

    See what I was doing was installing another server, so I shut one down and restarted the tutorial again, I have every thing running again with the same problem, I'm not able to use XP Outlook Express or Mozilla client from my FC5 OS to conntect to read mail I have sent using Outlook and Mozilla.

    I have my ports open 25, 110

    only way I can use the mail is log in via shell and use MUTT

    I added a user using the command adduser newuser, is that the correct way
    I sent an email to that user using Outlook Express, mail arrives for that user ok.

    I was wondering if a web mail would work, so I could check the users account I created.

    So you think Squireemail would work with out mucking up what I've done so far :confused:

    TT
     
  18. sjau

    sjau Local Meanie Moderator

    Yes, Squirellmail won't mess up anything... at least it shouldn't :)
     
  19. tommytomato

    tommytomato New Member

  20. tommytomato

    tommytomato New Member

    I was able to install SqWebMail ok

    I run the address or URL is says to, enter my user name with full address and password only to get

    this is what I put into the MySQL database users

    Code:
    INSERT INTO `domains` (`domain`) VALUES ('rockinghamgateway.com');
    INSERT INTO `users` (`email`, `password`, `quota`) VALUES ([email protected]', ENCRYPT('my_password'), 10485760);
    
    
    INSERT INTO `forwardings` (`source`, `destination`) VALUES ([email protected]', [email protected]');
    INSERT INTO `transport` (`domain`, `transport`) VALUES ('rockinghamgateway.com', 'smtp:mail.rockinghamgateway.com');
    does this look right :confused:

    TT
     

Share This Page