Mail server, Yahoo, Gmail as Spam

Discussion in 'Server Operation' started by erosbk, Jan 17, 2012.

  1. erosbk

    erosbk New Member

    Hello all,

    Please I need a little help with a little problem...

    Aside of hotmail, every mail sent by my mail server was arriving ok to inbox in gmail and yahoo. A client used our servers to send spam for two days... we kick it from our hosting, but right now, every mail send by my server is going directly to spam...

    Do you know how can I give advise to yahoo and gmail about the situation, clarify that it has been fixed, and get all mails again to inbox?

    If there is no solution to this, maybe I will have to use a different IP...

    Thanks in advance
     
  2. bassie

    bassie New Member

    You are probably blacklisted. You can check here

    Changing you IP is a bit extreme...
    You could change your IP, keep in mind also to change reverse DNS record.
     
  3. erosbk

    erosbk New Member

    Thanks, but I am not blacklisted in any place. The problem is that my mails are marked by google as spam, this was not happening before this user activity. I want to know where can I check my rep with google, or where can I send a form giving advise that the situation has been stoped.

    Thanks!
     
  4. falko

    falko Super Moderator

    Please check your mail log. The big companies send back a URL in the error code that gets logged in the mail log, and when oyu visit this URL you can normally fill out a form and request to be removed from their internal blacklist.
     
  5. emdok

    emdok New Member

    Pretty sure you're blacklisted somewhere :)
    Be sure you're entering the right IP or FQDN from your mail server.

    You'll need to do as falko has posted.
     
  6. erosbk

    erosbk New Member

    Thanks both of you, I checked everywhere (aside of mxtoolbox) for blacklists and all my IPs are clean.

    A client was using email server to send mails to google groups and others list, with a LOT of rejected mailboxs (I received lots of rejected address, really lots, 2000+ per hour)... I didn't find any message in logs, and with yahoo right now mails are starting to arrive at inbox... cannot say the same for gmail, I still arrive to spam after this, before I was arriving always to inbox...

    But well, I think that in a while it will be fixed without intervention of my side... if someone has more ideas please post here.

    Regards and thanks again for your help and future advises!
     
  7. bassie

    bassie New Member

    Did your check your SPF record?
     
  8. ServerBite

    ServerBite New Member

  9. mylifenp

    mylifenp New Member

    You need to set relay host

    You need to relay the mails you are sending using your ISPs smtp. Add these two lines in your main.cf in /etc/postfix

    broken_sasl_auth_clients = yes
    smtp_sasl_security_options =
    smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd <------
    smtp_always_send_ehlo = yes
    relayhost = smtp.yourisp.tld
    smtpd_sasl_authenticated_header = yes
    smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, check_recipient_access mysql:/etc/postfix/mysql-virtual_recipient.cf, reject_unauth_destination


    Then 'create /etc/postfix/sasl_passwd' and add these lines
    smtp.yourisp.tld user@yourisp.tld:password

    If your ISPs SMTP server doesn't require authentification than you won't need to add 'smtp_sasl_password_maps .....' line and won't have to create 'sasl_passwd' file.

    Hope this helps you.
     
  10. sabrina89543

    sabrina89543 New Member

    This seems very professional! I think OP should try right now!
     
  11. webguyz

    webguyz HowtoForge Supporter

    The only problem is if you do this then your ISP will get totally ticked off at you when his IP's get blacklisted and then you really have a problem. :D

    Is there any mechanism in ispConfig mail system that can activiated if its sees more then x emails per minute it then shoots an email to admin to warm them to take a closer look?
     
  12. recin

    recin New Member

    I have exactly the same problem.

    Mails sended from my mail server were arriving OK to gmail inbox (even with no SPF nor DKIM records).

    One account was sending spam for 2 days. We solved it but since then (1 month ago) our mails always arrive at gmail spam folder.
    My senderscore was about 90, it go down to 50 and now is 75.

    • According to mxtoolbox im not on any blacklist
    • Reverse DNS are OK
    • SPF record OK (now, I didn't have it before)
    • DKIM record OK (now, I didn't have it before)
    • DMARC record OK (now, I didn't have it before)
    • I fill this form to gmail but i have no response
    This is the header of a mail that goes to gmail spam (I changed mail accounts and IP for privacy reasons). It seems everything is OK:
    What else can i do?
     
  13. recin

    recin New Member

    Finally gmail stop marking my mails as spam.
    This happened exactly 1 month after the spam attack, when my senderscore goes from 80 to 99 (as it was before).

    Here is a screenshot:
    [​IMG]

    So in this case the only solution seems to be wait.

    Meanwhile I tried postmark. They give you the option to send 25000 mails from they servers for free. You can configure your mail client (outlook, thunderbird...) to do that (there are other options but I didn't try them)
     
    Last edited: Oct 14, 2014
  14. recin

    recin New Member

    Finally gmail stop marking my mails as spam.
    This happened exactly 1 month after the spam attack, when my senderscore goes from 80 to 99 (as it was before).

    Here is a screenshot:
    [​IMG]
    So in this case the only solution seems to be wait.

    Meanwhile I tried postmark. They give you the option to send 25000 mails from they servers for free. You can configure your mail client (outlook, thunderbird...) to do that (there are other options but I didn't try them)
     

Share This Page