Mail Server Setup With Exim & Cyrus-Imapd

Discussion in 'HOWTO-Related Questions' started by techmen8080, Nov 29, 2008.

  1. techmen8080

    techmen8080 New Member

    I am a newbie really appreciating HowtoForge. So thanks in advance to all the moderators and others who post information. I get this error when trying to install the cyrus-Imapd rpms for the Exim mail server set up.

    error: Failed dependencies:
    make is needed by cyrus-imapd-utils-2.3.11-3.i386

    How can I correct this and complete the install. I tried using the centos rpms 2.3.7-2.el5 but ran into the same problem. Perl will install but utils will not. I am trying the install on a bare bones VZ centos 5.2 template that I have updated with Yum. However, it seems I am missing something?
  2. falko

    falko Super Moderator ISPConfig Developer

    Try this:
    yum localinstall cyrus-imapd-utils-2.3.11-3.i386.rpm
    This should take care of the dependencies.
  3. techmen8080

    techmen8080 New Member

    how do I sign?

    Total download size: 781 k
    Is this ok [y/N]: y
    Downloading Packages:
    (1/1): make-3.81-3.el5.i3 100% |=========================| 466 kB 00:00

    Package cyrus-imapd-utils-2.3.11-3.i386.rpm is not signed
  4. topdog

    topdog Active Member HowtoForge Supporter

    yum --nogpgcheck localinstall cyrus-imapd-utils-2.3.11-3.i386.rpm
  5. techmen8080

    techmen8080 New Member

    it worked! with (--noplugins added)

    yum --noplugins --nogpgcheck localinstall cyrus-imapd-utils-2.3.11-3.i386.rpm

    For some reason my openvz server seems to cause a thread break in YUM when the fastmirror plugin is used.

    Thank you so much!

    I can now continue with your Exim Mail Server Setup.

Share This Page