mail server setup question

Discussion in 'Installation/Configuration' started by paulley, Jun 6, 2006.

  1. paulley

    paulley New Member

    hi all

    i have followed the prefect fedora 4 setup and its work fine, what my question is say you have ispconfig installed how does this create the emall accounts because postfix is the only one used to serve both incoming and outgoing mail has i have installed it once.

    i know ispconfig creates the unix account to match the username you enter with the password, but what file does the url of the users mailbox go

    unix account: user been created then . . .

    eg: user@domain.com user

    thanks

    paul
     
  2. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    ISPConfig changes /etc/postfix/local-host-names and /etc/postfix/virtusertable to create the email addresses.
     
  3. paulley

    paulley New Member

    them files aint in the postfix folder, i known i can create them but what do i put into the main.cf to link to them
     
    Last edited: Jun 6, 2006
  4. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    These lines where normally added to your main.cf by the ISPConfig installer automatically. Did you get any errors during installation or twaeked the installer manually?

    The lines are:

    virtual_maps = hash:/etc/postfix/virtusertable
    mydestination = /etc/postfix/local-host-names
     
  5. paulley

    paulley New Member

    nah i am manualy setting up the account then making my own script to add more email account

    thanks
     
  6. paulley

    paulley New Member

    problem: it wont recevice mail and when i send a email it says that the recipients was rejected by the server

    the files i have are
    ----------------------------------------
    /etc/postfix/local-host-names

    saying

    mail.domain.com
    --------------------------------------
    /etc/postfix/virtusertable

    saying

    user@domain.com user
    --------------------------------------------
    i have done the postmap virtusertable
    ------------------------------------------------
    the dnx xm records says:

    domain.com. IN MX 100 mail.domain.com.
    -------------------------------------------------

    when i do telnet mail.domain.com 110 it connects

    then i enter:

    user user
    say ok
    pass password
    say mailbox open 0 messages

    also i just email from another email account of mind and it come back saying:


    SMTP error from remote mail server after RCPT TO:<user@domain.com>:
    host nethostdomain.com [xx.xx.xxx.xx]: 554 <user@domain.com>:
    Relay access denied

    any help will be great

    thanks
     
    Last edited: Jun 7, 2006
  7. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Do you use ISPConfig to manage your server? Then you shall not edit these files manually.
     
  8. paulley

    paulley New Member

    no i dont use ispconfig, i think i put this post in the wrong forum!
     
    Last edited: Jun 7, 2006
  9. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

  10. paulley

    paulley New Member

    still not getting any mail i send
     
  11. paulley

    paulley New Member

    right i am receving mail now in /home/user/Maildir

    but when i login i think its taking me to a differnet user path because its say no email but there are.

    Also...

    if i email from one of my other domains it send the mail but when using my hotmail account it doesnt

    any idea why this could be, or is it the spam filter(a guess)

    thanks
     
  12. paulley

    paulley New Member

    sorry i have solved the problem where it wasnt receving the mail its work fine now , but still having a problem with recevicing mail from my hotmail account.

    there was something that happening, when it sent it a message come up saying:

    the server you are connected to is using a secuirty certificate the could not be verified

    a certificate chain proccessed, but terminated in a root certificate which is not trusted by the trust provider.

    Do you want to continue using this server.

    could this be why the hotmail account wont work because it doesnt say nothing about it when i send the mail from there only if i do it from my other domain.

    thanks
     
    Last edited: Jun 8, 2006
  13. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    It does not matter, if you get this error message in your mailclient.
     
  14. paulley

    paulley New Member

    ok , any idea why its not recevicing from a hotmail account:confused:
     
  15. paulley

    paulley New Member

    this is weird i cant see why its not send from hotmail?
     
    Last edited: Jun 9, 2006
  16. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Have you tried any oher external email provider too, or only hotmail?
    Have you configured the DNS MX-Record in DNS for your domain?
     
  17. paulley

    paulley New Member

    yeh i have tried yahoo, that works fine, its just hotmail. Dns records are set to:

    domain.com IN MX 10 Mail.domain.com


    thanks
     
  18. paulley

    paulley New Member

    i have check my mail and 3 of them i have recevied but then on the rest error comes up on the hotmail indox, some messages are saying failed and some saying delay

    so sometime it send it and sometimes it aint either saying its delayed of failed :confused:


    thanks
     
  19. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    I'd contact the Hotmail support and ask them if that happens because of some special spam policy or the like.
     
  20. paulley

    paulley New Member

    finaly i have solved the problem it must of been something i done , i install the os again and setup postfix again and its send them fine now. The only problem is how do a disable the sercuity certifiate on postfix, becuase the error i was getting before is doing my head in where its coming up saying "

    the server you are connected to is using a secuirty certificate the could not be verified

    a certificate chain proccessed, but terminated in a root certificate which is not trusted by the trust provider.

    Do you want to continue using this server. " when i send a message from a proper domain not hotmail.

    thanks
     
    Last edited: Jun 13, 2006

Share This Page