Mail server settings / SOA issues

Discussion in 'Installation/Configuration' started by tonytroy, Apr 7, 2022.

  1. tonytroy

    tonytroy Member

    Hey there,

    I have installed ISPconfig following the perfect server debian (apache) and all works fine except for 1 thing. But first, this is where i am :

    I take my domains names at (with .com and .fr extensions), and for every DN i change the DNS settings with the nameservers of my server ( as primary and as dnssec, 'cause my server is hosted at dedibox/scaleway). This works for .com extensions but not with .fr extensions (as, according to me, doesn't really exist, sd-xxxxxxx being the name given to my server).
    For .com extensions eveything's OK, websites and mails.
    For .fr extensions, as i'm not able to change nameservers, i have to add A record in the DNS settings putting the IP address manually.
    Websites with .fr added this way work, even with the SSL with let's encrypt. I also can create mailboxes, working with the webmail (roundcube) but i can't make it work with outlook or any other application. With my phone, when I try to add the account I have an SSL error "unvalid certificate".

    Does someone know how I can make it work ? Or any leads to have the right settings ? I'm totally lost.

    Thx and feel free to ask for any further informations.

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You probably missed giving your system a good hostname before you installed it. The hostname should be a subdomain of a domain you own like server1.yourdomain.tld and this subdomain must point with a DNS A-Record to the IP address of your server and your server's IP address must return this hostname as reverse record. Then you should fix that now by assigning it a correct hostname and setting that in /etc/hostname, /etc/hosts, /etc/mailname and then reboot the server and finally do an ispconfig update and choose to recreate the SSL cert of the system for the new hostname.
  3. tonytroy

    tonytroy Member

    Hey till,

    Thanks a lot for those informations. I did it all and before testing the mail settings i had a new problem : all website with a failover IP Address (a different IP Address than the server's) are down, even the one's with .com TLD :'(

    All those IP Addresses have a reverse given by the provider (looking like

    All website with the same IP Address than the server's are up.

    I think the problem now come from the DNS settings on's side. My actual settings are :
    - as primary DNS
    - as secondary DNS

    Do you know how I can fix this ?
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    When websites are down then this is not related to reverse DNS records. Reverse DNS records are only required for better mail deliverability. Are you able to reach the server over this additional IP e.g. by entering it into a browser? if not, then you have an issue with the configuration of that IP and not a DNS problem.
  5. tonytroy

    tonytroy Member

    After rebooting the server I had to "ifup" all the failover IP Addresses, now all websites are UP, thx again till.

    So I was able to change the DNS of the website with .fr TLD in with and the website works fine, but I have the same problem of SSL certificate when I try to add the email account in outlook or mail (mac os app).
    I choose IMAP and put "" in the settings for sending server and receiving server (maybe I did something wrong).
    The SSL certificate was generated by let's encrypt (in ISPconfig settings) and the website works fine with https.

    How can I avoid the "unsecure connection" ?
  6. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    My signature has link to e-mail setup on ISPConfig. And DNS setup with troubleshooting instructions, if you suspect you still have DNS problems.
    Check with ceritificate checker websites your certificate is OK. You can also in browser click the lock icon on address bar to get more info on the certificate, for example what additional domain names are included.
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    That's the wrong domain name. You must use the hostname of the server as smtp and imap server in your mail client and not any subdomains of client domains.
  8. tonytroy

    tonytroy Member

    @Taleman thx for your answer and those great tutorials :)

    @till your solution works perfectly, you're the best, thx a lot

Share This Page