Mail Server Records not right

Discussion in 'Installation/Configuration' started by rbartz, Oct 17, 2006.

  1. rbartz

    rbartz Member

    We are having a problem with our DNS configuration.

    All of the MX records generated by ispconfig have www and the server is always ""....


    The mail works, but when we test the DNS records for each domain we always get "There is no MX record for..." whatever domain...

    What are we doing wrong?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Do not put www in the hostname field of the MX records. Just leave the hostanme field for MX records empty.
  3. rbartz

    rbartz Member

    Thanks for answering so soon Till...

    Should the domain name be the same as the server or the hosted domain?

    For example the domain name for the above illustration is but the MX record uses the server host name

    Then, finally, is our setup of ispconfig wrong in that it puts the server name in the DNS mail record for the mail server instead of the domain we are hosting? Shouldn't it create the DNS record with the hosted domain name?

  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats up to you. You may use any domain that points to your server. Except localhost ;)

    Your setup is fine as both domains are fine.
  5. rbartz

    rbartz Member

    Thank you Till.

    Can ispconfig be configured to automatically NOT have the www in the DNS record when it is created, and to insert the domain name instead of the server name? Maybe part by UN-checking the "Default MX" in the management->server settings->DNS screen????

    Last edited: Oct 18, 2006
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Does your websites have a co-domain (with empty host field)? Is Cretae MX checked with this co-domains?
  7. rbartz

    rbartz Member

    All of our sites use co-domains with the IP and domain name with the hostname blank, but none of them have DNS or MX checked.

    So maybe when we create the site we should NOT check to create MX in the Basis screen, but DO check it on the co-domain before we save... We will try that next time we put in a new site.

    Thanks Till,


Share This Page