mail server not working

Discussion in 'Server Operation' started by cbelote, Mar 1, 2010.

  1. cbelote

    cbelote New Member

    Hi,
    I followed the tutorial: The Perfect Server - Ubuntu 9.10 [ISPConfig 3]. I have setup a mail account in ISPConfig, forwarded IMAP, POP3, and SMTP ports to my server, white listed email addresses, ensured my ISP is not blocking any of my ports and ensured my MX records point to my server. I am not receiving emails to or from the new email address and have not received any non-delivery messages! ISPConfig is showing no traffic on the new account either.

    :confused:

    I am not sure what to do next as I have exhausted my technical knowledge here :( any help is much appreciated in advance!
     
  2. cbelote

    cbelote New Member

    Ok, to update on my issue: I have gotten a delivery fail message from my mail server saying "unknown user: admin" My domain is cpb3.com by the way. Now for the wierd part: I am getting every other email message (2 out of 4) sent to this admin account in my /var/mail/ directory.
     
  3. falko

    falko Super Moderator

    Any errors in your mail log? What's in /etc/postfix/main.cf?
     
  4. cbelote

    cbelote New Member

    First, thank's falko for the help. You're a genius when it comes to this stuff :)
    Here are the errors I see in my mail warn log:

    Code:
    Mar 2 17:44:23 cpb3 postfix/smtpd[19551]: warning: 209.191.85.12: hostname smtp125 verification failed: Name or service not known
    Mar 2 17:44:24 cpb3 postfix/trivial-rewrite[19554]: warning: do not list domain cpb3.com in BOTH mydestination and virtual_mailbox_domains
    Here is what seems to be repeated every few minuites in my mail log:

    Code:
    Mar 2 20:05:01 cpb3 pop3d: Connection, ip=[::ffff:127.0.0.1]
    Mar 2 20:05:01 cpb3 pop3d: Disconnected, ip=[::ffff:127.0.0.1]
    Mar 2 20:05:01 cpb3 imapd: Connection, ip=[::ffff:127.0.0.1]
    Mar 2 20:05:01 cpb3 imapd: Disconnected, ip=[::ffff:127.0.0.1], time=0
    Mar 2 20:05:01 cpb3 postfix/smtpd[21183]: connect from localhost.localdomain[127.0.0.1]
    Mar 2 20:05:01 cpb3 postfix/smtpd[21183]: lost connection after CONNECT from localhost.localdomain[127.0.0.1]
    Mar 2 20:05:01 cpb3 postfix/smtpd[21183]: disconnect from localhost.localdomain[127.0.0.1]
    Here's my main.cf:

    Code:
    # See /usr/share/postfix/main.cf.dist for a commented, more complete version
    
    
    # Debian specific:  Specifying a file name will cause the first
    # line of that file to be used as the name.  The Debian default
    # is /etc/mailname.
    #myorigin = /etc/mailname
    
    smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
    biff = no
    
    # appending .domain is the MUA's job.
    append_dot_mydomain = no
    
    # Uncomment the next line to generate "delayed mail" warnings
    #delay_warning_time = 4h
    
    readme_directory = /usr/share/doc/postfix
    
    # TLS parameters
    smtpd_tls_cert_file = /etc/postfix/smtpd.cert
    smtpd_tls_key_file = /etc/postfix/smtpd.key
    smtpd_use_tls = yes
    smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
    smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
    
    # See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
    # information on enabling SSL in the smtp client.
    
    myhostname = cpb3.com
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    myorigin = /etc/mailname
    mydestination = cpb3.com, localhost, localhost.localdomain
    relayhost =
    mynetworks = 127.0.0.0/8 [::1]/128
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    html_directory = /usr/share/doc/postfix/html
    virtual_alias_domains =
    virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf, mysql:/etc/postfix/mysql-virtual_email2email.cf
    virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
    virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf
    virtual_mailbox_base = /var/vmail
    virtual_uid_maps = static:5000
    virtual_gid_maps = static:5000
    smtpd_sasl_auth_enable = yes
    broken_sasl_auth_clients = yes
    smtpd_sasl_authenticated_header = yes
    smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, check_recipient_access mysql:/etc/postfix/mysql-virtual_recipient.cf, reject_unauth_destination
    smtpd_tls_security_level = may
    transport_maps = proxy:mysql:/etc/postfix/mysql-virtual_transports.cf
    relay_domains = mysql:/etc/postfix/mysql-virtual_relaydomains.cf
    virtual_create_maildirsize = yes
    virtual_maildir_extended = yes
    virtual_mailbox_limit_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailbox_limit_maps.cf
    virtual_mailbox_limit_override = yes
    virtual_maildir_limit_message = "The user you are trying to reach is over quota."
    virtual_overquota_bounce = yes
    proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks $virtual_mailbox_limit_maps
    smtpd_sender_restrictions = check_sender_access mysql:/etc/postfix/mysql-virtual_sender.cf
    smtpd_client_restrictions = check_client_access mysql:/etc/postfix/mysql-virtual_client.cf
    maildrop_destination_concurrency_limit = 1
    maildrop_destination_recipient_limit = 1
    virtual_transport = maildrop
    header_checks = regexp:/etc/postfix/header_checks
    mime_header_checks = regexp:/etc/postfix/mime_header_checks
    nested_header_checks = regexp:/etc/postfix/nested_header_checks
    body_checks = regexp:/etc/postfix/body_checks
    content_filter = amavis:[127.0.0.1]:10024
    receive_override_options = no_address_mappings
    message_size_limit = 0
    
     
  5. cbelote

    cbelote New Member

    I might have resolved my issue:

    #1. My IP was, for some strange reason, on a Spamhaus black list. I had it removed (which is ironic because I run a spam bot honey pot on my site lol)

    #2. I solved the duplicate domain name issue in mydestination and virtual_mailbox_domain by removing it from the mydestination line in /etc/postfix/main.cf and restarting Postfix.

    Thanks falko for the guidance! I'll subscribe once I get the money to do so :)
     

Share This Page