mail server not working

Discussion in 'Installation/Configuration' started by nzimas, Sep 10, 2007.

  1. nzimas

    nzimas Member

    The mail servers, both inbound and outbound, at one of my ISPConfig instances are not working at all, though they are apparently up and running and the MX records remain as either Til or Falko left them.

    Here's an error message:
    However,

    [[email protected] ~]$ telnet 82.103.138.77 25
    Trying 82.103.138.77...
    Connected to e82-103-138-77s.easyspeedy.com (82.103.138.77).
    Escape character is '^]'.
    220 e82-103-138-77s.easyspeedy.com ESMTP Postfix (Debian/GNU)
    quit
    221 2.0.0 Bye
    Connection closed by foreign host.


    and


    [[email protected] ~]$ telnet 82.103.138.77 110
    Trying 82.103.138.77...
    Connected to e82-103-138-77s.easyspeedy.com (82.103.138.77).
    Escape character is '^]'.
    +OK Hello there.
    quit
    +OK Better luck next time.
    Connection closed by foreign host.


    Thanks,
    Nuno.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please make sure that the server name e82-103-138-77s.easyspeedy.com is registered properly in DNS.
     
  3. nzimas

    nzimas Member

    Actually the DNS server records in that machine are set to NS2.MUSMAPDNS.COM
    NS1.MUSMAPDNS.COM

    Shall any new MX record for any domain on that machine be set to MUSMAPDNS.COM?

    Nuno.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    This has nothing to do with DNS server records for the server or the MX records.

    The main domain as the server was installed was e82-103-138-77s.easyspeedy.com, if this domain does not resolve anymore to your server, you will have to change it in the email configuration. Replace all occurences of e82-103-138-77s.easyspeedy.com in your /etc/postfix/main.cf and /etc/mailname (if the file exists) with your new main server hostname. Be aware that the main server hostname should be a technical domain, it can not be used for email accounts later.
     
  5. nzimas

    nzimas Member

    Then something is terribly wrong in the way things have been setup.

    e82-103-138-77s:~# hostname
    e82-103-138-77s.easyspeedy.com

    I still have the invoice and the mail you sent me when this box was setup.
    Will contact you soon :)

    Thanks,
    Nuno.
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    We never change the hostname when we setup the server. The hostname is set when the basic linux is installed on the server, so the wrong hostname was setup by you and not by us :)
     
  7. nzimas

    nzimas Member

    For the record, i did not touch that setting either.
    It is now as it was assigned by the hosting provider.

    Nuno.
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok, thats explains it. Thats a typical setting if your server is rented and not setup by yourself and the setting is OK because the provider should take care to connect the hostname correctly when they initially setup the server. The settings in your server do not have to be changed, please ask your provider to set the domain e82-103-138-77s.easyspeedy.com to resolve correctly to your server IP address. They seem to have forgot to setup this on their DNS server as they setup your server.
     
  9. nzimas

    nzimas Member

    The hosting provider staff seems to be far from skillful.

    Their answer #1:
    Answer #2:

    That is to say, i am suppose to point an MX record to a non existing reverse DNS entry.
    The fabulous world of cheap unmanaged central european dedicated hosting :)

    Question:

    If i change the hostname to one of the domain names pointed to and running on that box, will it solve anything?

    I thought about changing the public hostanme from
    e82-103-138-77s.easyspeedy.com to musmap.com, a domain which actually solves at 82.103.138.77.

    I feel like tied up in some kafkian net...

    Thanks for reading my crying baby duck post :)

    Nuno.
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, this will help a bit, even if its not fully perfect without the reverse dns. Let's hope that they are able to repair their control center so you can set the domain name for the reverse dns.

    I recommend that you create a subdomain for one of your domains in the form of: mail.yourdomain.com or server1.yourdomain.com and use this subdomain as public server hostname.
     
  11. nzimas

    nzimas Member

    After changing the public hostname of the server, i believe it has be added in several files.
    So far i have committed changes to /etc/postfix/main.cf

    However, the DNS server sttings might need tunning too.

    Where exactly do i have to replace the former hostname with the new one?

    Another question, for the MX record to be valid, shall i include a dot at the end of the public hostname?

    Thanks,
    Nuno.
     
  12. falko

    falko Super Moderator ISPConfig Developer

    Depends on your distribution. On Debian/Ubuntu, you can put the new hostname into /etc/hostname and run
    Code:
    /etc/init.d/hostname.sh start
    If it's a FQDN, then yes. If it's just the subdomain, then no.
    For example,
    Code:
      MX 10 mail.example.com.
    or

    Code:
      MX 10 mail
    would be ok.
     
  13. nzimas

    nzimas Member

    I am trimmed :/

    According to http://loookup.com/musmap.com , the hostname remains the same, though i have added the mmserver.musmap.com to /etc/hostname, rebooted the machine and it caught it.

    This is driving me nuts.

    Can i use the IP as MX record?

    Nuno.
     
  14. nzimas

    nzimas Member

    Please look here:
    http://loookup.com/musmap.com

    What is the actual difference between Hostname and Hostname IP?
    Why is Hostname IP kept as e82-103-138-77s.easyspeedy.com if i have set the server hostname to mmserver.musmap.com?

    Thanks,
    Nuno.
     
  15. falko

    falko Super Moderator ISPConfig Developer

    No.

    I guess that's the reverse record of your IP address. You can test that by running
    Code:
    dig -x your.ip.add.ress
     

Share This Page