Mail Server not giving messages

Discussion in 'Installation/Configuration' started by champloo_otaku, Jan 30, 2014.

  1. champloo_otaku

    champloo_otaku New Member

    Hi. Pls help for my problem.
    I am installing ispconfig on my webserver and having problems to good working mail-server.
    Postifx server
    My error log.

    Jan 30 15:35:01 site dovecot: imap-login: Disconnected (no auth attempts in 0 secs): user=<>, rip=::1, lip=::1, secured, session=<845DSS/xsgAAAAAAAAAAAAAAAAAAAAAB>
    Jan 30 15:35:01 site dovecot: pop3-login: Disconnected (no auth attempts in 0 secs): user=<>, rip=::1, lip=::1, secured, session=<i5lDSS/x4gAAAAAAAAAAAAAAAAAAAAAB>
    Jan 30 15:35:21 site dovecot: pop3-login: Disconnected (no auth attempts in 0 secs): user=<>, rip=93.125.*.*, lip=93.125.*.*, session=<l5FvSi/xeQBdfQEa>
    Jan 30 15:18:15 site postfix/error[23025]: A9AB72C2640: to=<[email protected]>, relay=none, delay=317, delays=315/1.2/0/0, dsn=4.3.0, status=deferred (unknown mail transport $
    My main.cfg
    #myorigin = /etc/mailname
    biff = no
    append_dot_mydomain = no
    delay_warning_time = 4h
    readme_directory = /usr/share/doc/postfix
    # TLS parameters
    smtpd_tls_cert_file = /etc/postfix/smtpd.cert
    smtpd_tls_key_file = /etc/postfix/smtpd.key
    smtpd_use_tls = yes
    smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
    smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
    myhostname =
    alias_maps = hash:/etc/aliases, hash:/var/lib/mailman/data/aliases
    alias_database = hash:/etc/aliases, hash:/var/lib/mailman/data/aliases
    myorigin = /etc/mailname
    mydestination =,,, localhost, 
    mynetworks = [::1]/128
    mailbox_command = procmail -a "$EXTENSION"
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    html_directory = /usr/share/doc/postfix/html
    virtual_alias_domains = 
    virtual_alias_maps = proxy:mysql:/etc/postfix/, proxy:mysql:/etc/postfix/, hash:/var/lib/mailman/data/virtual-mailman
    virtual_mailbox_domains = proxy:mysql:/etc/postfix/
    virtual_mailbox_maps = proxy:mysql:/etc/postfix/
    virtual_mailbox_base = /var/vmail
    virtual_uid_maps = static:5000
    virtual_gid_maps = static:5000
    inet_protocols = all
    smtpd_sasl_auth_enable = yes
    broken_sasl_auth_clients = yes
    smtpd_sasl_authenticated_header = yes
    smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, check_recipient_access mysql:/etc/postfix/, reject_unauth_destination
    smtpd_tls_security_level = may
    transport_maps = hash:/var/lib/mailman/data/transport-mailman, proxy:mysql:/etc/postfix/
    relay_domains = mysql:/etc/postfix/
    relay_recipient_maps = mysql:/etc/postfix/
    proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks $virtual_mailbox_limit_maps
    smtpd_sender_restrictions = check_sender_access mysql:/etc/postfix/
    smtpd_client_restrictions = check_client_access mysql:/etc/postfix/
    smtpd_client_message_rate_limit = 100
    maildrop_destination_concurrency_limit = 1
    maildrop_destination_recipient_limit = 1
    virtual_transport = dovecot
    header_checks = regexp:/etc/postfix/header_checks
    mime_header_checks = regexp:/etc/postfix/mime_header_checks
    nested_header_checks = regexp:/etc/postfix/nested_header_checks
    body_checks = regexp:/etc/postfix/body_checks
    owner_request_special = no
    dovecot_destination_recipient_limit = 1
    smtpd_sasl_type = dovecot
    smtpd_sasl_path = private/auth
    telnet localhost 25
    [email protected]:~# telnet localhost 25
    Trying ::1...
    Connected to localhost.
    Escape character is '^]'.
    220 ESMTP Postfix
    mail from: [email][email protected][/email]
    530 5.7.0 Must issue a STARTTLS command first
    220 2.0.0 Ready to start TLS
    mail from [email][email protected][/email]
    Connection closed by foreign host.
    [email protected]:~#
  2. webguyz

    webguyz Member HowtoForge Supporter

    Go to System -> Server Config -> Click on your mail server and check the IP address, Netmask , and Gateway and may sure none of them is, it has to be your actual IP address.
  3. champloo_otaku

    champloo_otaku New Member

    I not use
    I have really ip.
  4. webguyz

    webguyz Member HowtoForge Supporter

    I know, but what your seeing is what I had gotten once. I also have public IP's but for some reason those settings had changed to and even though my mail server was pingable, it would not receive or send any email until I checked that setting and darned if it wasn't set to and also my default gateway was empty.

    Just check it and make sure the setting is your valid public IP.

    Good Luck!
  5. champloo_otaku

    champloo_otaku New Member

    I will check this in futere.

    Now i have problem in how isp config network configuration disable...
    My website offline.
    How whitch hands remove function in isp server 1 network configuration?

Share This Page