Mail Server Assistance and Help

Discussion in 'Installation/Configuration' started by astewart, Feb 19, 2007.

  1. astewart

    astewart ISPConfig Developer ISPConfig Developer

    I have a few questions here and a couple of issues.

    Postfix 2.3.3
    Courier POP / IMAP
    ISPCONFIG 2.2.9

    Question 1.
    Do I have to maunally create the "maildir" for every new Site I add? And is the Location of the Maildir in "var/www/web1" or in the Users home directory, "/var/www/web1/user/web1_user1/"?

    I have no problems setting up the POP, which everything is working fine, no problems receiving...

    I can create IMAP accounts, no problems authenticating, but they do not receive E-mails, in Webmail and in OE....
    The E-mails sent to the to the pop account do NOT show up either in webmail.

    I get this message when Telnetting into the IMAP Server:
    telnet> open 192.168.2.9 143
    Trying 192.168.2.9...
    Connected to 192.168.2.9.
    Escape character is '^]'.
    * OK [CAPABILITY IMAP4rev1 UIDPLUS CHILDREN NAMESPACE THREAD=ORDEREDSUBJECT THREAD=REFERENCES SORT QUOTA IDLE ACL ACL2=UNION STARTTLS] Courier-IMAP ready. Copyright 1998-2005 Double Precision, Inc. See COPYING for distribution information.


    I've made sure that I have opened Port 143 on the IPCONFIG firewall and My Router but still no difference.

    My output from netstat -tap:

    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 localhost:2208 *:* LISTEN 3 879/hpiod
    tcp 0 0 localhost:51524 *:* LISTEN 3 888/python
    tcp 0 0 *:mysql *:* LISTEN 4 014/mysqld
    tcp 0 0 *:10000 *:* LISTEN 5 100/perl
    tcp 0 0 *:81 *:* LISTEN 4 689/ispconfig_http
    tcp 0 0 localhost:ipp *:* LISTEN 1 5414/cupsd
    tcp 0 0 *:smtp *:* LISTEN 4 93/master
    tcp6 0 0 *:imaps *:* LISTEN 4 147/couriertcpd
    tcp6 0 0 *:pop3s *:* LISTEN 4 186/couriertcpd
    tcp6 0 0 *:pop3 *:* LISTEN 4 162/couriertcpd
    tcp6 0 0 *:imap2 *:* LISTEN 4 125/couriertcpd
    tcp6 0 0 *:www *:* LISTEN 1 5381/apache2
    tcp6 0 0 *:ftp *:* LISTEN 3 72/proftpd: (accep
    tcp6 0 0 *:ssh *:* LISTEN 4 434/sshd
    tcp6 0 0 *:smtp *:* LISTEN 4 93/master
    tcp6 0 0 *:https *:* LISTEN 1 5381/apache2
    ESTABLISHED2 0097/0


    Here are my postconf -n stats:

    alias_database = hash:/etc/aliases
    alias_maps = hash:/etc/aliases
    append_dot_mydomain = no
    biff = no
    broken_sasl_auth_clients = yes
    config_directory = /etc/postfix
    home_mailbox = Maildir/
    inet_interfaces = all
    inet_protocols = all
    mailbox_command =
    mailbox_size_limit = 0
    mydestination = /etc/postfix/local-host-names
    mynetworks = 127.0.0.0/8,192.168.2.0/24,24.215.88.2/32
    myorigin = /etc/mailname
    recipient_delimiter = +
    relayhost = smtp.eastlink.ca
    smtp_tls_note_starttls_offer = yes
    smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache
    smtp_use_tls = yes
    smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
    smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_local_domain =
    smtpd_sasl_security_options = noanonymous
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_auth_only = no
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
    smtpd_tls_session_cache_timeout = 3600s
    smtpd_use_tls = yes
    tls_random_source = dev:/dev/urandom


    Can anyone help me out here?
    Thanks!
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Have you enabled the Maildir checkbox in ISPConfig under management > server > settings on the mail tab?
     
  3. astewart

    astewart ISPConfig Developer ISPConfig Developer

    Thanks for the replay, actually right after posting I checked the "Maildir" option which solved my first question.
    I still can't figure out whats wrong with the IMAP Server. :(
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Have you configured courier to authenticate against PAM or shadow?
     

Share This Page