Mail scanmail and defanged style problem

Discussion in 'Installation/Configuration' started by hmfireball, Jan 5, 2009.

  1. hmfireball

    hmfireball New Member

    Hi,

    I have this problem:

    I use my own server with ISPConfig to host my website
    let's call it www.mysite.com
    From ISPConfig, I have declared a admin user for that site with a dummy email address [email protected], as ISPConfig requires that users always have email addresses.
    I need this user, so that I can use FTP, but I don't need an email address for it. But ISPconfig doesn't let this choice.

    Actually, real email addresses linked to the mysite.com site are handled by a different server.
    One of these addresses is [email protected]

    My problem is:
    When I try to send a email to [email protected] from my server with ISPConfig (from a PHP script for instance)
    It returns: SMTP Error: Recipient not accepted. Verify your relay rules

    But what's strange is that when I check inside the admin user configuration:
    Email collector
    Scanmail
    It works!

    I really don't understand what's going on as there's no relation between
    mysite.com admin user configuration and the email address [email protected]

    Another problem is that when I check scanmail, outgoing messages get defanged styles

    Can you help me to fix that.
    Thanks

    Hmfireball
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post the error messages that appear in the mail log when a message is rejected.
     
  3. hmfireball

    hmfireball New Member

    Thanks for your answer Till.

    Here's the test I carried from my server running ISPConfig:

    The name of my server running ISPConfig is: myserver
    Its domain is : myserver.com

    I login to the webmail of an user web9_anothersite whose site's domain is anothersite.com.
    His email address is [email protected]

    From this webmail, I attempt to send an email to:
    [email protected]
    www.mysite.com is a site hosted on myserver (its admin user is web2_admin)
    but [email protected] is not hosted on myserver but on a different one.

    I use the DNS server of my domain name registrar :
    mysite.com points to myserver
    but MX points to a server different from myserver

    here's what strange:
    when i set in web2_admin configuration scanmail and email collector on, mail is sent and log displays:

    Code:
    Jan  5 17:46:18 myserver postfix/smtpd[13129]: connect from localhost.localdomain[127.0.0.1]
    Jan  5 17:46:18 myserver postfix/smtpd[13129]: 3933523D806F: client=localhost.localdomain[127.0.0.1]
    Jan  5 17:46:18 myserver postfix/cleanup[13132]: 3933523D806F: message-id=<[email protected]>
    Jan  5 17:46:18 myserver postfix/qmgr[32701]: 3933523D806F: from=<[email protected]>, size=746, nrcpt=1 (queue active)
    Jan  5 17:46:18 myserver postfix/smtpd[13129]: disconnect from localhost.localdomain[127.0.0.1]
    Jan  5 17:46:18 myserver dovecot: pop3-login: Login: user=<web9_anothersite>, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, secured
    Jan  5 17:46:18 myserver dovecot: POP3(web9_anothersite): Disconnected: Logged out top=0/0, retr=0/0, del=0/0, size=0
    Jan  5 17:46:18 myserver sendmail[13145]: n05GkIil013145: from=web2_admin, size=116, class=0, nrcpts=1, msgid=<[email protected]>, [email protected]
    Jan  5 17:46:18 myserver postfix/smtpd[13129]: connect from localhost.localdomain[127.0.0.1]
    Jan  5 17:46:18 myserver postfix/smtpd[13129]: setting up TLS connection from localhost.localdomain[127.0.0.1]
    Jan  5 17:46:18 myserver postfix/smtpd[13129]: Anonymous TLS connection established from localhost.localdomain[127.0.0.1]: TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits)
    Jan  5 17:46:18 myserver sendmail[13145]: STARTTLS=client, relay=[127.0.0.1], version=TLSv1/SSLv3, verify=FAIL, cipher=DHE-RSA-AES256-SHA, bits=256/256
    Jan  5 17:46:18 myserver postfix/smtpd[13129]: 4C7A523D8073: client=localhost.localdomain[127.0.0.1], [email protected]
    Jan  5 17:46:18 myserver postfix/cleanup[13132]: 4C7A523D8073: message-id=<[email protected]>
    Jan  5 17:46:18 myserver postfix/qmgr[32701]: 4C7A523D8073: from=<[email protected]>, size=743, nrcpt=1 (queue active)
    Jan  5 17:46:18 myserver sendmail[13145]: n05GkIil013145: [email protected], ctladdr=web2_admin (10003/10002), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=30116, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (Ok: queued as 4C7A523D8073)
    Jan  5 17:46:18 myserver postfix/local[13147]: 4C7A523D8073: to=<[email protected]>, relay=local, delay=0.06, delays=0.05/0/0/0.01, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)
    Jan  5 17:46:18 myserver postfix/qmgr[32701]: 4C7A523D8073: removed
    Jan  5 17:46:18 myserver postfix/smtpd[13129]: disconnect from localhost.localdomain[127.0.0.1]
    Jan  5 17:46:18 myserver postfix/local[13133]: 3933523D806F: to=<[email protected]>, orig_to=<[email protected]>, relay=local, delay=0.15, delays=0.03/0.01/0/0.11, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)
    Jan  5 17:46:18 myserver postfix/qmgr[32701]: 3933523D806F: removed
    
    But when i set them off, email is not sent and I get:

    Code:
    Jan  5 17:54:56 myserver postfix/smtpd[14131]: connect from localhost.localdomain[127.0.0.1]
    Jan  5 17:54:56 myserver postfix/smtpd[14131]: NOQUEUE: reject: RCPT from localhost.localdomain[127.0.0.1]: 550 5.1.1 <[email protected]>: Recipient address rejected: User unknown in local recipient table; from=<[email protected]> to=<[email protected]> proto=SMTP helo=<UebiMiau>
    Jan  5 17:54:56 myserver postfix/smtpd[14131]: lost connection after RCPT from localhost.localdomain[127.0.0.1]
    Jan  5 17:54:56 myserver postfix/smtpd[14131]: disconnect from localhost.localdomain[127.0.0.1]
    
    Can you understand what happens?
    Thanks!
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

  5. hmfireball

    hmfireball New Member

  6. falko

    falko Super Moderator ISPConfig Developer

    Please select "External Mailserver" for www.mysite.com (it's on the Options tab of that web site in ISPConfig) and also for the Co-Domain mysite.com (go to Co-Domains, select that domain, and then go to the Options tab of that Co-Domain and select "External Mailserver").
     
  7. hmfireball

    hmfireball New Member

    It works!
    Thank you so much for your help!

    Hmfireball
     

Share This Page