mail refusing connections

Discussion in 'General' started by jcombs_31, Nov 17, 2009.

  1. jcombs_31

    jcombs_31 New Member

    Just noticed my mail server is refusing connections, but I don't see how the logs really point me in the right direction. Here is a snip from mail.log on an email I just tried to send

    Code:
    
    Nov 17 04:05:19 mmt1 postfix/smtpd[24278]: connect from p3plsmtpa01-08.prod.phx3.secureserver.net[72.167.82.88]
    Nov 17 04:05:19 mmt1 postfix/smtpd[24278]: 5CF9D4949197: client=p3plsmtpa01-08.prod.phx3.secureserver.net[72.167.82.88]
    Nov 17 04:05:19 mmt1 postfix/cleanup[25629]: 5CF9D4949197: message-id=<[email protected]>
    Nov 17 04:05:19 mmt1 postfix/qmgr[19514]: 5CF9D4949197: from=<[email protected]>, size=3335, nrcpt=1 (queue active)
    Nov 17 04:05:19 mmt1 postfix/smtp[25630]: connect to 127.0.0.1[127.0.0.1]: Connection refused (port 10024)
    Nov 17 04:05:19 mmt1 postfix/smtp[25630]: 5CF9D4949197: to=<[email protected]>, relay=none, delay=0.46, delays=0.45/0.01/0/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]: Connection refused)
    Nov 17 04:05:19 mmt1 postfix/smtpd[24278]: disconnect from p3plsmtpa01-08.prod.phx3.secureserver.net[72.167.82.88]
    
    Really not sure where to start.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please restart amavisd and check again.
     
  3. jcombs_31

    jcombs_31 New Member

    I think my server was choking on resources. I ended up increasing memory and restarting the machine which seems to have worked. I noticed some other errors related to memory unable to prefork certain processes.

    My startup scripts show amavis, not amavisd, I'm assuming it is the same yes? When I first tried restarting amavis I did get some locale warnings. perl: warning: Falling back to the standard locale ("C") perl: warning: Setting locale failed"
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    The start script is named amavi but the name of the service itself is amavisd or amvisd-new. So yes, its the same.

    You can ignore the locale warnings.
     
  5. jcombs_31

    jcombs_31 New Member

    OK. Thanks for your quick replies, I really appreciate the time and effort you put in.
     

Share This Page