Mail Queue

Discussion in 'Installation/Configuration' started by Tripple, Dec 15, 2007.

  1. Tripple

    Tripple New Member

    After a transfer my new client is floating my mail queue. Some users are using mail forward, but it looks like the target address is refusing this spam mail. This is the error:
    Sender address rejected: Domain not found (in reply to MAIL FROM command)

    This mail can't be returned to the spammer and stays on my server for a while. How can I fix this so that this mail doesn't take up all my disk space?
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Please check if that domain exists in DNS:
    Code:
    dig domain.com
     
  3. Tripple

    Tripple New Member

    It does exist:

    # postqueue -p
    -Queue ID- --Size-- ----Arrival Time---- -Sender/Recipient-------
    1A2776F0802 30628 Mon Dec 17 02:33:13 MAILER-DAEMON
    (connect to myfirstmail.com[68.178.232.100]: Connection timed out)
    [email protected]
    ...

    # dig mx myfirstmail.com

    ; <<>> DiG 9.3.4 <<>> mx myfirstmail.com
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 29063
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 2, ADDITIONAL: 3

    ;; QUESTION SECTION:
    ;myfirstmail.com. IN MX

    ;; ANSWER SECTION:
    myfirstmail.com. 3496 IN MX 0 68.178.232.100.
    myfirstmail.com. 3496 IN MX 10 myfirstmail.com.
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Maybe there's no mail server running on myfirstmail.com, or it's listening only on localhost, or it's blocking certain hosts...
     
  5. Tripple

    Tripple New Member

    Maybe. But there are other domains as well. This was just the first in the queue. I delete the queue by hand every day until I find a better solution.
     

Share This Page