Mail Problems Suse10 x86_64

Discussion in 'Installation/Configuration' started by Praude, Feb 23, 2006.

  1. Praude

    Praude New Member

    I'm setting up my new server using Suse10 perfect setup and the server can send but won't receive emails. I installed webmail b4 i tested sending or receiving any email.

    postfix identifies itself as SERVIDOR.moretohelicopteros.com.br and maybe thats one of the problems. bcause the domain moretohelicopteros.com.br is one of the domains i plan to move to this host later but it still somewhere else. how do I fix this?

    SERVIDOR:~ # telnet localhost 25
    Trying 127.0.0.1...
    Connected to localhost.
    Escape character is '^]'.
    220 SERVIDOR.moretohelicopteros.com.br ESMTP Postfix

    a more complete description of my instalation can b found on
    http://www.howtoforge.com/forums/showthread.php?t=2691

    I guess this will help too:
    I cut & pasted only the part that matters for mail

    SERVIDOR:~ # netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 *:smtp *:* LISTEN 13528/master
    tcp 0 0 *:pop3 *:* LISTEN 6359/couriertcpd
    tcp 0 0 *:imap *:* LISTEN 6292/couriertcpd
    tcp 0 0 *:smtp *:* LISTEN 13528/master

    really weird too is that i'm sending the same email with a copy to a second adress
    to ig.com.br and with copy to netscape.net
    I only get the email in the ig.com.br account it never gets properly delivered to netscape and i'm not receiveing any error messages saying it couldn't be delivered or anything like that.

    below is the mail header of the email that gets deliverd to ig.com.br

    Received: (qmail 19235 invoked from network); 23 Feb 2006 02:34:15 -0000
    Received: from unknown ([10.20.1.84]) (envelope-sender <>) by mailserver-70.ig.com.br (qmail-ldap-1.03) with QMQP for <>; 23 Feb 2006 02:34:15 -0000
    Delivered-To: CLUSTERHOST email-84.ig.com.br praude@ig.com.br
    Received: (qmail 30496 invoked from network); 23 Feb 2006 02:34:14 -0000
    Received: from 200.175.156.250.static.gvt.net.br (HELO SERVIDOR.moretohelicopteros.com.br) (none@[200.175.156.250]) (envelope-sender <webmaster@praude.eti.br>) by email-84.ig.com.br (qmail-ldap-1.03) with SMTP for <praude@ig.com.br>; 23 Feb 2006 02:34:14 -0000
    Received-SPF: none (email-84.ig.com.br: domain at praude.eti.br does not designate permitted sender hosts)
    Received: from w2k (201-3-19-109.gnace701.dsl.brasiltelecom.net.br [201.3.19.109]) by SERVIDOR.moretohelicopteros.com.br (Postfix) with ESMTP id 33A4B2CAA23; Wed, 22 Feb 2006 23:27:44 -0300 (BRT)

    Message-ID: <003501c63821$b501d430$c8c8a8c0@w2k>
     
    Last edited: Feb 23, 2006
  2. falko

    falko Super Moderator

    Did you enable Maildir in ISPConfig (Management -> Server -> Settings -> Email)?
    Also, what's in the mail log?
    Is your server on a DSL line with dynamic IP addresses? It is possible that Netscape blocks emails from dynamic IP addresses, maybe also from IP addresses without a proper PTR or SPF record.
     
  3. Praude

    Praude New Member

    Hi Falko !

    mail dir is enabled.
    The server is on a DSL line with a static IP.
    I think a good thing to start with would be a valid HELO form postfix how can I fix this ?

    I was checkin the mail log and it has many itens in the queue and seems like postfix still didn't give up...
    and about netscape, I fond this in the log http://postmaster.info.aol.com/errors/554rtrdu.html
    Now that I know that I can't send mail some isp, I will see what I can do about it.
    how can I remove the messages from the queue?

    But most important my ISPConfig mail accounts still don't receive any e-mail and I'm not getting and error message back.

    part of the mail log after a restart las night:

    Feb 22 23:09:11 SERVIDOR postfix/qmgr[16225]: 54A092CAA05: from=<webmaster@praude.eti.br>, size=822, nrcpt=2 (queue active)
    Feb 22 23:09:11 SERVIDOR postfix/qmgr[16225]: 9F2E52CAA0F: from=<webmaster@praude.eti.br>, size=792, nrcpt=2 (queue active)
    Feb 22 23:09:11 SERVIDOR postfix/qmgr[16225]: 1DC3D2CAA15: from=<>, size=4153, nrcpt=1 (queue active)
    Feb 22 23:09:11 SERVIDOR postfix/qmgr[16225]: 1AB8B2CAA19: from=<webmaster@praude.eti.br>, size=1434, nrcpt=1 (queue active)
    Feb 22 23:09:11 SERVIDOR postfix/qmgr[16225]: E62D02CAA1B: from=<webmaster@praude.eti.br>, size=1503, nrcpt=2 (queue active)
    Feb 22 23:09:11 SERVIDOR postfix/smtp[16246]: warning: connect to private/tlsmgr: No such file or directory
    Feb 22 23:09:12 SERVIDOR postfix/smtp[16246]: warning: connect to private/tlsmgr: No such file or directory
    Feb 22 23:09:12 SERVIDOR postfix/smtp[16246]: warning: problem talking to server private/tlsmgr: No such file or directory
    Feb 22 23:09:12 SERVIDOR postfix/smtp[16246]: warning: no entropy for TLS key generation: disabling TLS support
    Feb 22 23:09:12 SERVIDOR postfix/smtp[16265]: warning: connect to private/tlsmgr: No such file or directory
    Feb 22 23:09:12 SERVIDOR postfix/smtp[16246]: connect to mailin-02.mx.netscape.net[205.188.158.57]: server refused to talk to me: 554- (RTR:DU) http://postmaster.info.aol.com/errors/554rtrdu.html (port 25)
    Feb 22 23:09:13 SERVIDOR postfix/smtp[16265]: warning: connect to private/tlsmgr: No such file or directory
    Feb 22 23:09:13 SERVIDOR postfix/smtp[16265]: warning: problem talking to server private/tlsmgr: No such file or directory
    Feb 22 23:09:13 SERVIDOR postfix/smtp[16265]: warning: no entropy for TLS key generation: disabling TLS support
    Feb 22 23:09:13 SERVIDOR postfix/smtp[16266]: warning: connect to private/tlsmgr: No such file or directory
    Feb 22 23:09:13 SERVIDOR postfix/smtp[16246]: connect to mailin-01.mx.netscape.net[205.188.158.25]: server refused to talk to me: 554- (RTR:DU) http://postmaster.info.aol.com/errors/554rtrdu.html (port 25)

    the log is really full maybe I shoud clean it up after i get things straight.
    after hudreds of lines of the same warnings and server refused to talk to me
    some other activities in the log:

    Feb 22 23:12:35 SERVIDOR postfix/scache[16269]: statistics: start interval Feb 22 23:09:14
    Feb 22 23:12:35 SERVIDOR postfix/scache[16269]: statistics: domain lookup hits=0 miss=3 success=0%
    Feb 22 23:12:35 SERVIDOR postfix/scache[16269]: statistics: address lookup hits=0 miss=12 success=0%
    Feb 22 23:22:10 SERVIDOR imapd: Connection, ip=[::ffff:201.3.19.109]
    Feb 22 23:22:10 SERVIDOR imapd: LOGIN, user=web3_master, ip=[::ffff:201.3.19.109], protocol=IMAP
    Feb 22 23:22:14 SERVIDOR imapd: Connection, ip=[::ffff:201.3.19.109]
    Feb 22 23:22:14 SERVIDOR imapd: LOGIN, user=web3_master, ip=[::ffff:201.3.19.109], protocol=IMAP
    Feb 22 23:25:00 SERVIDOR pop3d: Connection, ip=[::ffff:127.0.0.1]
    Feb 22 23:25:00 SERVIDOR pop3d: LOGIN, user=web3_master, ip=[::ffff:127.0.0.1]
    Feb 22 23:25:00 SERVIDOR pop3d: LOGOUT, user=web3_master, ip=[::ffff:127.0.0.1], top=0, retr=0, time=0
    Feb 22 23:25:44 SERVIDOR pop3d: Connection, ip=[::ffff:127.0.0.1]
    Feb 22 23:25:44 SERVIDOR pop3d: LOGIN, user=web3_master, ip=[::ffff:127.0.0.1]
    Feb 22 23:25:44 SERVIDOR pop3d: LOGOUT, user=web3_master, ip=[::ffff:127.0.0.1], top=0, retr=0, time=0
    Feb 22 23:25:46 SERVIDOR postfix/smtp[17073]: 6050D2CAA1F: to=<praude@ig.com.br>, relay=mx.ig.com.br[200.226.132.20], delay=2, status=sent (250 ok 1140661933 qp 27345 by email-85.ig.com.br)
    Feb 22 23:26:51 SERVIDOR imapd: Connection, ip=[::ffff:201.3.19.109]
    Feb 22 23:26:52 SERVIDOR imapd: LOGIN, user=web3_master, ip=[::ffff:201.3.19.109], protocol=IMAP
    Feb 22 23:26:52 SERVIDOR imapd: DISCONNECTED, user=web3_master, ip=[::ffff:201.3.19.109], headers=0, body=0, time=0
    Feb 22 23:26:52 SERVIDOR imapd: Connection, ip=[::ffff:201.3.19.109]
    Feb 22 23:26:53 SERVIDOR imapd: LOGIN, user=web3_master, ip=[::ffff:201.3.19.109], protocol=IMAP
    Feb 22 23:26:54 SERVIDOR imapd: DISCONNECTED, user=web3_master, ip=[::ffff:201.3.19.109], headers=0, body=0, time=1
    Feb 22 23:27:46 SERVIDOR postfix/smtp[17109]: warning: connect to private/tlsmgr: No such file or directory
    Feb 22 23:27:46 SERVIDOR postfix/smtp[17109]: warning: problem talking to server private/tlsmgr: No such file or directory
    Feb 22 23:27:46 SERVIDOR postfix/smtp[17109]: warning: no entropy for TLS key generation: disabling TLS support
    Feb 22 23:27:46 SERVIDOR postfix/smtp[17110]: warning: connect to private/tlsmgr: No such file or directory
    Feb 22 23:27:47 SERVIDOR postfix/smtp[17109]: 33A4B2CAA23: to=<praude@ig.com.br>, relay=mx.ig.com.br[200.226.132.20], delay=3, status=sent (250 ok 1140662054 qp 30486 by email-84.ig.com.br)
    Feb 22 23:27:47 SERVIDOR postfix/smtp[17110]: warning: connect to private/tlsmgr: No such file or directory
    Feb 22 23:27:47 SERVIDOR postfix/smtp[17110]: warning: problem talking to server private/tlsmgr: No such file or directory
    Feb 22 23:27:47 SERVIDOR postfix/smtp[17110]: warning: no entropy for TLS key generation: disabling TLS support
    Feb 22 23:27:55 SERVIDOR imapd: Connection, ip=[::ffff:201.3.19.109]
    Feb 22 23:27:55 SERVIDOR imapd: LOGIN, user=web3_master, ip=[::ffff:201.3.19.109], protocol=IMAP
    Feb 22 23:27:56 SERVIDOR imapd: DISCONNECTED, user=web3_master, ip=[::ffff:201.3.19.109], headers=0, body=0, time=1
    Feb 22 23:27:56 SERVIDOR imapd: Connection, ip=[::ffff:201.3.19.109]
    Feb 22 23:27:57 SERVIDOR imapd: LOGIN, user=web3_master, ip=[::ffff:201.3.19.109], protocol=IMAP
    Feb 22 23:27:57 SERVIDOR imapd: DISCONNECTED, user=web3_master, ip=[::ffff:201.3.19.109], headers=0, body=0, time=0
    Feb 22 23:31:05 SERVIDOR postfix/anvil[17105]: statistics: max connection rate 1/60s for (smtp:201.3.19.109) at Feb 22 23:27:41
    Feb 22 23:31:05 SERVIDOR postfix/anvil[17105]: statistics: max connection count 1 for (smtp:201.3.19.109) at Feb 22 23:27:41
    Feb 22 23:31:05 SERVIDOR postfix/anvil[17105]: statistics: max cache size 1 at Feb 22 23:27:41
    Feb 22 23:35:06 SERVIDOR pop3d: Connection, ip=[::ffff:127.0.0.1]
    Feb 22 23:35:06 SERVIDOR pop3d: LOGIN, user=web3_master, ip=[::ffff:127.0.0.1]
    Feb 22 23:35:06 SERVIDOR pop3d: LOGOUT, user=web3_master, ip=[::ffff:127.0.0.1], top=0, retr=0, time=0
     
    Last edited: Feb 23, 2006
  4. till

    till Super Moderator

    You can remove messages from the mailqueue with the command:

    postsuper -d all
     
  5. Praude

    Praude New Member

    thanks, those msgs woudn't be received by netscape anyway.
    now I can concentrate on why postfix isn't receiveing any mail.
     
  6. falko

    falko Super Moderator

    Do the recipient domains' MX records point to your server?
     
  7. Praude

    Praude New Member

    after removing the messages to netscape.net (AOL) form the queue, I sent an email from ISPConfig webmail(uebimial) to my email at ig.com.br.
    It was received, bellow is the mail header:

    Received: (qmail 26613 invoked from network); 23 Feb 2006 15:21:52 -0000
    Received: from unknown ([10.20.1.86]) (envelope-sender <>) by mailserver-70.ig.com.br (qmail-ldap-1.03) with QMQP for <>; 23 Feb 2006 15:21:52 -0000
    Delivered-To: CLUSTERHOST email-86.ig.com.br praude@ig.com.br
    Received: (qmail 14370 invoked from network); 23 Feb 2006 15:21:51 -0000
    Received: from 200.175.156.250.static.gvt.net.br (HELO SERVIDOR.moretohelicopteros.com.br) (none@[200.175.156.250]) (envelope-sender <webmaster@praude.eti.br>) by email-86.ig.com.br (qmail-ldap-1.03) with SMTP for <praude@ig.com.br>; 23 Feb 2006 15:21:51 -0000
    Received-SPF: none (email-86.ig.com.br: domain at praude.eti.br does not designate permitted sender hosts)
    Received: from UebiMiau (localhost [127.0.0.1]) by SERVIDOR.moretohelicopteros.com.br (Postfix) with SMTP id 416F82CAA25 for <praude@ig.com.br>; Thu, 23 Feb 2006 12:15:20 -0300 (BRT)
    Received: from client 200.140.65.144 for UebiMiau2.7 (webmail client); Thu, 23 Feb 2006 12:15:19 +0100
    Date: Thu, 23 Feb 2006 12:15:19 +0100
    From: ''webmaster'' <webmaster@praude.eti.br>
    To: praude@ig.com.br
    Reply-to: ''webmaster'' <webmaster@praude.eti.br>
    Subject: teste
    X-Priority: 3
    X-Mailer: UebiMiau 2.7.2
    X-Original-IP: 200.140.65.144
    Content-Transfer-Encoding: 8bit
    X-MSMail-Priority: Medium
    Importance: Medium
    Content-Type: text/plain; charset=''iso-8859-1'';
    MIME-Version: 1.0
    Message-Id: <20060223151520.416F82CAA25@SERVIDOR.moretohelicopteros.com.br>
    X-iGspam-global: Yes, spamicity=0.929830 - pe=9.30e-01 - pf=0.929830 - pg=0.92983

    and i sent a reply from ig.com.br but i didn't receive it.

    here is mail log:
    Feb 23 11:42:39 SERVIDOR postfix/scache[28968]: statistics: start interval Feb 23 11:39:16
    Feb 23 11:42:39 SERVIDOR postfix/scache[28968]: statistics: domain lookup hits=0 miss=1 success=0%
    Feb 23 11:42:39 SERVIDOR postfix/scache[28968]: statistics: address lookup hits=0 miss=4 success=0%
    Feb 23 12:14:44 SERVIDOR pop3d: Connection, ip=[::ffff:127.0.0.1]
    Feb 23 12:14:44 SERVIDOR pop3d: LOGIN, user=web3_master, ip=[::ffff:127.0.0.1]
    Feb 23 12:14:44 SERVIDOR pop3d: LOGOUT, user=web3_master, ip=[::ffff:127.0.0.1], top=0, retr=0, time=0
    Feb 23 12:15:19 SERVIDOR postfix/smtpd[29619]: warning: connect to private/tlsmgr: No such file or directory
    Feb 23 12:15:20 SERVIDOR postfix/smtpd[29619]: warning: connect to private/tlsmgr: No such file or directory
    Feb 23 12:15:20 SERVIDOR postfix/smtpd[29619]: warning: problem talking to server private/tlsmgr: No such file or directory
    Feb 23 12:15:20 SERVIDOR postfix/smtpd[29619]: warning: no entropy for TLS key generation: disabling TLS support
    Feb 23 12:15:20 SERVIDOR postfix/smtpd[29619]: connect from localhost[127.0.0.1]
    Feb 23 12:15:20 SERVIDOR postfix/smtpd[29619]: 416F82CAA25: client=localhost[127.0.0.1]
    Feb 23 12:15:20 SERVIDOR postfix/cleanup[29622]: 416F82CAA25: message-id=<20060223151520.416F82CAA25@SERVIDOR.moretohelicopteros.com.br>
    Feb 23 12:15:20 SERVIDOR postfix/qmgr[16225]: 416F82CAA25: from=<webmaster@praude.eti.br>, size=771, nrcpt=1 (queue active)
    Feb 23 12:15:20 SERVIDOR postfix/smtpd[29619]: disconnect from localhost[127.0.0.1]
    Feb 23 12:15:20 SERVIDOR pop3d: Connection, ip=[::ffff:127.0.0.1]
    Feb 23 12:15:20 SERVIDOR pop3d: LOGIN, user=web3_master, ip=[::ffff:127.0.0.1]
    Feb 23 12:15:20 SERVIDOR pop3d: LOGOUT, user=web3_master, ip=[::ffff:127.0.0.1], top=0, retr=0, time=0
    Feb 23 12:15:20 SERVIDOR postfix/smtp[29623]: warning: connect to private/tlsmgr: No such file or directory
    Feb 23 12:15:21 SERVIDOR postfix/smtp[29623]: warning: connect to private/tlsmgr: No such file or directory
    Feb 23 12:15:21 SERVIDOR postfix/smtp[29623]: warning: problem talking to server private/tlsmgr: No such file or directory
    Feb 23 12:15:21 SERVIDOR postfix/smtp[29623]: warning: no entropy for TLS key generation: disabling TLS support
    Feb 23 12:15:22 SERVIDOR postfix/smtp[29623]: 416F82CAA25: to=<praude@ig.com.br>, relay=mx.ig.com.br[200.226.132.20], delay=2, status=sent (250 ok 1140708111 qp 14364 by email-86.ig.com.br)
    Feb 23 12:15:22 SERVIDOR postfix/qmgr[16225]: 416F82CAA25: removed
    Feb 23 12:23:03 SERVIDOR pop3d: Connection, ip=[::ffff:127.0.0.1]
    Feb 23 12:23:03 SERVIDOR pop3d: LOGIN, user=web3_master, ip=[::ffff:127.0.0.1]
    Feb 23 12:23:03 SERVIDOR pop3d: LOGOUT, user=web3_master, ip=[::ffff:127.0.0.1], top=0, retr=0, time=0
    Feb 23 12:23:09 SERVIDOR pop3d: Connection, ip=[::ffff:127.0.0.1]
    Feb 23 12:23:09 SERVIDOR pop3d: LOGIN, user=web3_master, ip=[::ffff:127.0.0.1]
    Feb 23 12:23:09 SERVIDOR pop3d: LOGOUT, user=web3_master, ip=[::ffff:127.0.0.1], top=0, retr=0, time=0
    Feb 23 12:29:10 SERVIDOR postfix/qmgr[16225]: 6050D2CAA1F: from=<webmaster@praude.eti.br>, size=806, nrcpt=2 (queue active)
    Feb 23 12:29:10 SERVIDOR postfix/smtp[29859]: warning: connect to private/tlsmgr: No such file or directory
    Feb 23 12:29:11 SERVIDOR postfix/smtp[29859]: warning: connect to private/tlsmgr: No such file or directory
    Feb 23 12:29:11 SERVIDOR postfix/smtp[29859]: warning: problem talking to server private/tlsmgr: No such file or directory
    Feb 23 12:29:11 SERVIDOR postfix/smtp[29859]: warning: no entropy for TLS key generation: disabling TLS support
    Feb 23 12:29:13 SERVIDOR postfix/smtp[29859]: connect to mailin-04.mx.netscape.net[205.188.158.57]: server refused to talk to me: 554- (RTR:DU) http://postmaster.info.aol.com/errors/554rtrdu.html (port 25)
    Feb 23 12:29:13 SERVIDOR postfix/smtp[29859]: connect to mailin-02.mx.netscape.net[205.188.158.57]: server refused to talk to me: 554- (RTR:DU) http://postmaster.info.aol.com/errors/554rtrdu.html (port 25)
    Feb 23 12:29:14 SERVIDOR postfix/smtp[29859]: connect to mailin-01.mx.netscape.net[205.188.158.25]: server refused to talk to me: 554- (RTR:DU) http://postmaster.info.aol.com/errors/554rtrdu.html (port 25)
    Feb 23 12:29:14 SERVIDOR postfix/smtp[29859]: connect to mailin-03.mx.netscape.net[205.188.158.25]: server refused to talk to me: 554- (RTR:DU) http://postmaster.info.aol.com/errors/554rtrdu.html (port 25)
    Feb 23 12:29:14 SERVIDOR postfix/smtp[29859]: 6050D2CAA1F: to=<andrepraude@netscape.net>, relay=none, delay=47010, status=deferred (connect to mailin-03.mx.netscape.net[205.188.158.25]: server refused to talk to me: 554- (RTR:DU) http://postmaster.info.aol.com/errors/554rtrdu.html )
     
  8. Praude

    Praude New Member

    How can check that ?

    SERVIDOR:~ # dig praude.eti.br

    ; <<>> DiG 9.3.1 <<>> praude.eti.br
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 26604
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;praude.eti.br. IN A

    ;; ANSWER SECTION:
    praude.eti.br. 86400 IN A 192.168.123.171

    ;; AUTHORITY SECTION:
    praude.eti.br. 86400 IN NS 201.3.19.109.
    praude.eti.br. 86400 IN NS 200.175.156.250.

    ;; Query time: 1068 msec
    ;; SERVER: 192.168.123.254#53(192.168.123.254)
    ;; WHEN: Thu Feb 23 12:39:59 2006
    ;; MSG SIZE rcvd: 102
     
  9. falko

    falko Super Moderator

    Code:
    dig praude.eti.br
    
    ; <<>> DiG 9.2.1 <<>> praude.eti.br
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 46167
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;praude.eti.br.                 IN      A
    
    ;; ANSWER SECTION:
    praude.eti.br.          86400   IN      A       [B][COLOR="Red"]192.168.123.171[/COLOR][/B]
    
    ;; Query time: 353 msec
    ;; SERVER: 81.169.163.104#53(81.169.163.104)
    ;; WHEN: Thu Feb 23 23:07:00 2006
    ;; MSG SIZE  rcvd: 47
    
    Your domain points to a private IP address that cannot be reached from the outside. That's why your emails don't arrive.
     
  10. Praude

    Praude New Member

    Hi Falko ! thanks for the help:
    I felt like there was something wrong in the DNS but since I'm not familiar with DNS I'm still clue less on how to configure it right since I want DNS to serve both my LAN and the web as well...
    I changed and its like this now:

    SERVIDOR:~ # dig praude.eti.br

    ; <<>> DiG 9.3.1 <<>> praude.eti.br
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 59438
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;praude.eti.br. IN A

    ;; ANSWER SECTION:
    praude.eti.br. 86400 IN A 200.175.156.250

    ;; AUTHORITY SECTION:
    praude.eti.br. 86400 IN NS 200.175.156.250.
    praude.eti.br. 86400 IN NS 201.3.19.109.

    ;; Query time: 72 msec
    ;; SERVER: 200.175.182.139#53(200.175.182.139)
    ;; WHEN: Fri Feb 24 17:25:34 2006
    ;; MSG SIZE rcvd: 102

    I'm still can't receive mail, but maybe I have to wait until dns changes propagates.
    I think there can be something else wrong in my configuration

    For now, Carnaval is already going on here in Brazil, I'lll get back to this on ash wednesday.
    Good carnival for everyone !
     
    Last edited: Feb 24, 2006
  11. falko

    falko Super Moderator

    Looks ok. Maybe you should consider creating an MX record also for praude.eti.br.

    Same to you! :)
     
  12. Praude

    Praude New Member

    In ISPConfig under DNS Manager dns entry records has a MX record:
    http://www.howtoforge.com/forums/attachment.php?attachmentid=87&stc=1&d=1141310512

    dig in localhost show a MX record:

    Code:
    SERVIDOR:~ # dig @localhost -t MX mail.praude.eti.br
    
    ; <<>> DiG 9.3.1 <<>> @localhost -t MX mail.praude.eti.br
    ; (2 servers found)
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 61169
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 2, ADDITIONAL: 1
    
    ;; QUESTION SECTION:
    ;mail.praude.eti.br.            IN      MX
    
    ;; ANSWER SECTION:
    mail.praude.eti.br.     86400   IN      MX      10 200.175.156.250.
    mail.praude.eti.br.     86400   IN      MX      10 praude.eti.br.
    
    ;; AUTHORITY SECTION:
    praude.eti.br.          86400   IN      NS      200.175.156.250.
    praude.eti.br.          86400   IN      NS      200.140.65.144.
    
    ;; ADDITIONAL SECTION:
    praude.eti.br.          86400   IN      A       200.175.156.250
    
    ;; Query time: 0 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Thu Mar  2 12:04:24 2006
    ;; MSG SIZE  rcvd: 141
    
     

    Attached Files:

    Last edited: Mar 2, 2006
  13. Praude

    Praude New Member

    Looks like mail configuration is really screwed up.
    Right now I'm having problems logging in to the mail account I was using to test mail. When I try webmail,a very long time after I clicked in login I get an error
    about user & password cannot login
    in Ms Outllook express: error :imap cannot allocate memory

    In pine running through ssh in localhost inbox was full with hundredes of messages like this :
    Code:
    Date: Fri, 24 Feb 2006 21:17:24 -0300 (BRT)
    From: Mail Delivery System <MAILER-DAEMON@SERVIDOR.moretohelicopteros.com.br>
    To:  <web3_master@SERVIDOR.moretohelicopteros.com.br>
    Subject: Undelivered Mail Returned to Sender
    Parts/Attachments:
       1   Shown     16 lines  Text, "Notification"
       2   Shown    531 bytes  Message, "Delivery report"
       3   Shown    427 bytes  Message, "Undelivered Message"
       3.1 Shown      2 lines  Text
    ----------------------------------------
    
    This is the Postfix program at host SERVIDOR.moretohelicopteros.com.br.
    
    I'm sorry to have to inform you that your message could not
    be delivered to one or more recipients. It's attached below.
    
    For further assistance, please send mail to <postmaster>
    
    If you do so, please include this problem report. You can
    delete your own text from the attached returned message.
    
                            The Postfix program
    
    <admispconfig@localhost.moretohelicopteros.com.br> (expanded from
        <admispconfig@localhost>): Host or domain name not found. Name service
        error for name=localhost.moretohelicopteros.com.br type=AAAA: Host not
        found
    
    
        [ Part 2: "Delivery report" ]
    
    Reporting-MTA: dns; SERVIDOR.moretohelicopteros.com.br
    X-Postfix-Queue-ID: E6AD22CAA27
    X-Postfix-Sender: rfc822; web3_master@SERVIDOR.moretohelicopteros.com.br
    Arrival-Date: Fri, 24 Feb 2006 21:17:23 -0300 (BRT)
    
    Final-Recipient: rfc822; admispconfig@localhost.moretohelicopteros.com.br
    Original-Recipient: rfc822; admispconfig@localhost
    Action: failed
    Status: 5.0.0
    Diagnostic-Code: X-Postfix; Host or domain name not found. Name service error
        for name=localhost.moretohelicopteros.com.br type=AAAA: Host not found
    
    
        [ Part 3: "Undelivered Message" ]
    
    Date: Fri, 24 Feb 2006 21:17:23 -0300 (BRT)
    From: andrepraude <web3_master@SERVIDOR.moretohelicopteros.com.br>
    To: undisclosed-recipients:  ;
    Subject: Mailsize: web3_master
    
    note that the domain moretohelicopteros.com.br hve dns pointing to another server ( a paid host that I use to host some sites that I plan to move to the server runninig ISPconfig). where do I fix this ? I want to get it running b4 I move the sites to ISPConfig and Postfix Helo is SERVIDOR.moretohelicopteros.com.br.
    I'M cleaning the in box now to see if I can get in throgh webmail or OE.
     
    Last edited: Mar 2, 2006
  14. falko

    falko Super Moderator

    An MX record must point to an FQDN, not to an IP address!
     
  15. Praude

    Praude New Member

    Thaks for the tip falko !

    dns looks like this now :
    Code:
    SERVIDOR:~ # dig @localhost -t MX mail.praude.eti.br
    
    ; <<>> DiG 9.3.1 <<>> @localhost -t MX mail.praude.eti.br
    ; (2 servers found)
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 8929
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 1
    
    ;; QUESTION SECTION:
    ;mail.praude.eti.br.            IN      MX
    
    ;; ANSWER SECTION:
    mail.praude.eti.br.     86400   IN      MX      10 praude.eti.br.
    
    ;; AUTHORITY SECTION:
    praude.eti.br.          86400   IN      NS      200.140.65.144.
    praude.eti.br.          86400   IN      NS      200.175.156.250.
    
    ;; ADDITIONAL SECTION:
    praude.eti.br.          86400   IN      A       200.175.156.250
    
    ;; Query time: 108 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Thu Mar  2 13:49:04 2006
    ;; MSG SIZE  rcvd: 125
    
    
    after checking mail using pine i found that the inbox is really full it has hundreds of thousands of messages probably some infinit loop of messages.
    how do I clean up this mail box?
     
  16. falko

    falko Super Moderator

    Do you use Maildir or mbox format for your mailboxes?
     
  17. Praude

    Praude New Member

    Maildir is enabled.
     
  18. Praude

    Praude New Member

    Postfix is going crazy here....
    I still have an infinite loop of messages, yesterday i cleaned up the inbox and this morning I have thousands of messages from the mail delivery system in the inbox(85.684). They are all like this:
    Code:
    Date: Thu,  2 Mar 2006 18:28:01 -0300 (BRT)
    From: Mail Delivery System
        <MAILER-DAEMON@SERVIDOR.moretohelicopteros.com.br>
    To:  <web3_hostmaster@SERVIDOR.moretohelicopteros.com.br>
    Subject: Undelivered Mail Returned to Sender
    Parts/Attachments:
       1   Shown     16 lines  Text, "Notification"
       2   Shown    535 bytes  Message, "Delivery report"
       3   Shown    439 bytes  Message, "Undelivered Message"
       3.1 Shown      2 lines  Text
    ----------------------------------------
    
    This is the Postfix program at host SERVIDOR.moretohelicopteros.com.br.
    
    I'm sorry to have to inform you that your message could not
    be delivered to one or more recipients. It's attached below.
    
    For further assistance, please send mail to <postmaster>
    
    If you do so, please include this problem report. You can
    delete your own text from the attached returned message.
    
                            The Postfix program
    
    <admispconfig@localhost.moretohelicopteros.com.br> (expanded from
        <admispconfig@localhost>): Host or domain name not found. Name service
        error for name=localhost.moretohelicopteros.com.br type=AAAA: Host not
        found
    
    
        [ Part 2: "Delivery report" ]
    
    Reporting-MTA: dns; SERVIDOR.moretohelicopteros.com.br
    X-Postfix-Queue-ID: A33E22CAA0C
    X-Postfix-Sender: rfc822; web3_hostmaster@SERVIDOR.moretohelicopteros.com.br
    Arrival-Date: Thu,  2 Mar 2006 18:28:01 -0300 (BRT)
    
    Final-Recipient: rfc822; admispconfig@localhost.moretohelicopteros.com.br
    Original-Recipient: rfc822; admispconfig@localhost
    Action: failed
    Status: 5.0.0
    Diagnostic-Code: X-Postfix; Host or domain name not found. Name service
    error
        for name=localhost.moretohelicopteros.com.br type=AAAA: Host not found
    
    
        [ Part 3: "Undelivered Message" ]
    
    Date: Thu,  2 Mar 2006 18:28:01 -0300 (BRT)
    From: andrepraude <web3_hostmaster@SERVIDOR.moretohelicopteros.com.br>
    To: undisclosed-recipients:  ;
    Subject: Mailsize: web3_hostmaster
    
    2815
    
    I will stop postfix until I get this fixed.
     
  19. till

    till Super Moderator

    This looks as if you forwarded mail from the user admispconfig to another account. You will have to remove that forward or alias to fix this.
     
  20. Praude

    Praude New Member

    Thanks for the reply Till!

    I don't remember doing anything like this but anyway, Where should I check for the foward or alias ?
     

Share This Page