Mail problems after updating to 3.0.5.3

Discussion in 'Installation/Configuration' started by rdan, Aug 13, 2013.

  1. rdan

    rdan Member HowtoForge Supporter

    Yesterday I upgraded to version 3.0.5.3. The upgrade went fine, but this morning I was unable to login to the mail server. The message in the mail.log was as follows:

    Aug 13 08:20:01 www postfix/smtpd[6033]: connect from localhost[127.0.0.1]
    Aug 13 08:20:01 www postfix/smtpd[6033]: lost connection after CONNECT from localhost[127.0.0.1]
    Aug 13 08:20:01 www postfix/smtpd[6033]: disconnect from localhost[127.0.0.1]
    Aug 13 08:20:01 www imapd: Connection, ip=[::ffff:127.0.0.1]
    Aug 13 08:20:01 www imapd: Disconnected, ip=[::ffff:127.0.0.1], time=0
    Aug 13 08:20:01 www pop3d: Connection, ip=[::ffff:127.0.0.1]
    Aug 13 08:20:01 www pop3d: Disconnected, ip=[::ffff:127.0.0.1]
    Aug 13 08:23:02 www postfix/smtpd[5005]: timeout after END-OF-MESSAGE from localhost[127.0.0.1]
    Aug 13 08:23:02 www postfix/smtpd[5005]: disconnect from localhost[127.0.0.1]
    Aug 13 08:25:01 www imapd: Connection, ip=[::ffff:127.0.0.1]
    Aug 13 08:25:01 www imapd: Disconnected, ip=[::ffff:127.0.0.1], time=0
    Aug 13 08:25:01 www pop3d: Connection, ip=[::ffff:127.0.0.1]
    Aug 13 08:25:01 www pop3d: Disconnected, ip=[::ffff:127.0.0.1]

    The message from Ispconfig server log was the same:
    Aug 13 08:35:01 www /USR/SBIN/CRON[6452]: (getmail) CMD (/usr/local/bin/run-getmail.sh > /dev/null 2>> /dev/null)
    Aug 13 08:35:01 www pure-ftpd: ([email protected]) [INFO] New connection from 127.0.0.1
    Aug 13 08:35:01 www pure-ftpd: ([email protected]) [INFO] Logout.
    Aug 13 08:35:01 www imapd: Connection, ip=[::ffff:127.0.0.1]
    Aug 13 08:35:01 www imapd: Disconnected, ip=[::ffff:127.0.0.1], time=0
    Aug 13 08:35:01 www pop3d: Connection, ip=[::ffff:127.0.0.1]
    Aug 13 08:35:01 www pop3d: Disconnected, ip=[::ffff:127.0.0.1]
    Aug 13 08:35:01 www postfix/smtpd[6480]: connect from localhost[127.0.0.1]
    Aug 13 08:35:01 www postfix/smtpd[6480]: lost connection after CONNECT from localhost[127.0.0.1]
    Aug 13 08:35:01 www postfix/smtpd[6480]: disconnect from localhost[127.0.0.1]

    Any advice on how I can get mail running again? Thanks.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The messages you posted are from ispconfig system monitor, none of them belongs to a login attempt.
     
  3. rdan

    rdan Member HowtoForge Supporter

    This is the ispconfig message I get when attempting to connect to mail:
    ************************************
    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, [email protected] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.
    **************************************
    I have done several warm boots and will attempt a cold boot this morning. The error might be connected with my firewall, but beyond that I am at a loss as to the source of the problem. It only showed up after the upgrade. Thanks.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats not a email error message, its a apache error. So your peoblem is not a mail roblem, its a apache problem, Take a look at the apache error.log for details.
     
  5. rdan

    rdan Member HowtoForge Supporter

    OK, I checked the apache error log after doing a cold boot and a restart. Both during the shutdown and the restart, the system reported that there were no virtual hosts on port 80 and 443. In addition, the most recent apache error log when attempting to connect to roundcube mail is this:

    SoftException in Application.cpp:221: File "/usr/share/roundcube/index.php" is not in document root of Vhost "/var/www/ispconfig/"

    It looks like something went wrong in the upgrade process. I haven't done anything with apache before or after the upgrade.
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    The apache warnings are ok and not an error. Which url, especially which port, do you use to access oundcube.
     
  7. rdan

    rdan Member HowtoForge Supporter

    It runs on port 50443.
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    is this the ispconfig vhost? You can not access other software over the ispconfig vhost. If you want to access roundcube, use port 80.
     
  9. rdan

    rdan Member HowtoForge Supporter

  10. till

    till Super Moderator Staff Member ISPConfig Developer

    You can not use any other software over the ispconfig vhost.
     
  11. rdan

    rdan Member HowtoForge Supporter

    Are you suggesting that the tutorial I followed was a mistake? I followed it specifically because it was posted in the Howtoforge tutorial list.

    If Thomas' tutorial was not supported by the Ispconfig3 developers, why was it allowed to be posted on the Howtoforge list? The roundcube over ssl feature survived the last upgrade of Ispconfig3. Why didn't it survive this one?

    Finally, if I need to lose a very attractive feature (i.e. webmail over ssl), how do I fix my broken system? Thanks.
     
  12. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    The apache error you mentioned can be caused by suphp.

    Open /etc/apache2/mods-available/suphp.conf

    And comment out these lines so they look like this.
    # <FilesMatch "\.ph(p3?|tml)$">
    # SetHandler application/x-httpd-suphp
    # </FilesMatch>
    # suPHP_AddHandler application/x-httpd-suphp
     
  13. rdan

    rdan Member HowtoForge Supporter

    Thanks Marius,
    Unfortunately, I don't have the lines you refer to in my suphp.conf file. Here are the contents of the entire file:

    <IfModule mod_suphp.c>
    AddType application/x-httpd-suphp .php .php3 .php4 .php5 .phtml
    suPHP_AddHandler application/x-httpd-suphp

    <Directory />
    suPHP_Engine on
    </Directory>

    # By default, disable suPHP for debian packaged web applications as files
    # are owned by root and cannot be executed by suPHP because of min_uid.
    <Directory /usr/share>
    suPHP_Engine off
    </Directory>

    # # Use a specific php config file (a dir which contains a php.ini file)
    # suPHP_ConfigPath /etc/php4/cgi/suphp/
    # # Tells mod_suphp NOT to handle requests with the type <mime-type>.
    # suPHP_RemoveHandler <mime-type>
    </IfModule>

    Rick
     
  14. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    Try making # in front of the

    AddType application/x-httpd-suphp .php .php3 .php4 .php5 .phtml
    suPHP_AddHandler application/x-httpd-suphp

    and restart apache.
     
  15. rdan

    rdan Member HowtoForge Supporter

    That did it. Mail is back. Thanks very much!
    Rick
     
    Last edited: Aug 16, 2013
  16. triple5

    triple5 New Member

    Mail Config changes on upgrade

    I found that the mail configuration for my amavisd-new was changed through the upgrade, unsure what exactly happened but there started to be a mismatch between the settings in
    /etc/postfix/main.cf
    where it was set to
    content_filter = amavis:[127.0.0.1]:10024

    I had to disable amavis by uncommenting this line and the following until I found out that there was a line in the /etc/postfix/master.cf where it says:
    smtp-amavis unix - - - - 2 smtp

    these two lines have to correspond, so in main.cf it has to say:
    content_filter = smtp-amavis:[127.0.0.1]:10024

    with this the mail gets delivered again.
     

Share This Page