Mail problems after update to Jessy / ISPConfig 3.1.3

Discussion in 'Installation/Configuration' started by axelcon, Jun 8, 2017.

  1. axelcon

    axelcon New Member

    Hi,

    I updated my server to Jessy yesterday and updated ISPConfig to 3.1.3 afterwards. Everything was ok as it seemed. Today I noticed that only server messages (monit, mail delivery system) came in. Basically I cannot send or receive Mails.

    Code:
    host 127.0.0.1[127.0.0.1] said: 554 5.7.1 id=13798-18
      - Rejected by next-hop MTA on relaying, from MTA(smtp:[127.0.0.1]:10027):
      554 5.7.1 <recipient@outside.com>: Relay access denied (in reply to end of
      DATA command)
    I guessed it was a hostname problem and checked hostname, hostname -f, which both gave the same srv1.example.com. Remembering the Perfect Server HowTo I once used, I edited /etc/hostname to srv1 and rebooted. Things got worse...
    All webs showed 403, which I was able to fix by just opening the settings in ISPConfig, setting PHP to Default and saving (probably it was just the saving and had nothing to do with the PHP version).

    Mail doesn't work still. I found in the mail.err:
    Code:
    Jun  8 20:51:57 srv1 dovecot: auth-worker(2398): Error: mysql(localhost): Connect failed to database (dbispconfig): Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2) - waiting for 5 seconds before retry
    So it seems it was an auth problem in the first place. I skipped reconfiguring the services during ISPConfig update, so I gave that a try and re-ran update.php from a fresh 3.1.3 download. Now mail.err only shows:
    Code:
    Jun  8 21:50:06 srv1 dovecot: pop3-login: Error: read(anvil) failed: EOF

    Any ideas where to start?


    Regards,
    Axel
     
    Last edited: Jun 8, 2017
  2. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    check, that postfix, dovecot and mysql are running (service xxx staus) and maybe restart the services.
     
  3. axelcon

    axelcon New Member

    Checked, all three running, but restarted anyway. But no change to the problem

    Code:
    Jun  9 07:58:07 srv1 dovecot: pop3-login: Error: read(anvil) failed: EOF

    Axel
     
  4. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    ps -ef|grep dovecot
    ls -al /var/vmail

    Did you let ispconfig reconfigure the services?
     
  5. axelcon

    axelcon New Member

    Will do the above as soon as I get back from work. Yes, this was my last action, just before the 'Error: read(anvil) failed: EOF' errors appeared.

    Axel
     
  6. axelcon

    axelcon New Member

    Weekend at last :)

    here's the results of the above...

    Code:
    dovenull  1275 18613  0 19:05 ?        00:00:00 dovecot/imap-login
    vmail     1278 18613  0 19:05 ?        00:00:00 dovecot/imap
    dovenull  5588 18613  0 19:34 ?        00:00:00 dovecot/pop3-login
    dovenull  5599 18613  0 19:34 ?        00:00:00 dovecot/pop3-login
    dovenull  6232 18613  0 19:35 ?        00:00:00 dovecot/pop3-login
    dovenull  6233 18613  0 19:35 ?        00:00:00 dovecot/pop3-login
    dovenull  6263 18613  0 19:36 ?        00:00:00 dovecot/pop3-login
    root      6278 18613  0 19:36 ?        00:00:00 dovecot/auth -w
    root      6280 18613  0 19:36 ?        00:00:00 dovecot/auth -w
    dovenull  6296 18613  0 19:36 ?        00:00:00 dovecot/pop3-login
    root      6329 17459  0 19:37 pts/0    00:00:00 grep dovecot
    root     18613     1  0 07:58 ?        00:00:02 /usr/sbin/dovecot -F
    dovecot  18639 18613  0 07:58 ?        00:00:00 dovecot/anvil
    root     18640 18613  0 07:58 ?        00:00:01 dovecot/log
    root     18642 18613  0 07:58 ?        00:00:02 dovecot/config
    root     18652 18613  0 07:58 ?        00:00:01 dovecot/auth
    root     18660 18613  0 07:58 ?        00:00:00 dovecot/ssl-params
    dovenull 29676 18613  0 18:41 ?        00:00:00 dovecot/imap-login
    vmail    29695 18613  0 18:41 ?        00:00:00 dovecot/imap
    dovenull 29700 18613  0 18:41 ?        00:00:00 dovecot/imap-login
    vmail    29701 18613  0 18:41 ?        00:00:00 dovecot/imap
    
    and
    Code:
    drwxr-xr-x  8 vmail vmail 4096 Jan  6  2016 .
    drwxr-xr-x 15 root  root  4096 Okt 21  2016 ..
    -rw-r--r--  1 vmail vmail  220 Dez 30  2012 .bash_logout
    -rw-r--r--  1 vmail vmail 3392 Dez 30  2012 .bashrc
    drwx------  7 vmail vmail 4096 Aug 16  2013 a_domain.de
    -rw-------  1 vmail vmail 1454 Jun  8 21:49 .mailfilter
    -rw-r--r--  1 root  root  1454 Jun  8 21:49 .mailfilter~
    drwxr-xr-x  2 root  root  4096 Aug  5  2013 mailfilters
    drwx------  3 vmail vmail 4096 Okt 15  2013 another_domain.de
    drwx------ 18 vmail vmail 4096 Nov 20  2016 yetanother_domain.de
    -rw-r--r--  1 vmail vmail  675 Dez 30  2012 .profile
    drwx------  4 vmail vmail 4096 Aug  5  2013 domains_everywhere.de
    drwx------  5 vmail vmail 4096 Feb  8 18:30 you_guessed_it.de
    

    BR,
    Axel
     
  7. axelcon

    axelcon New Member

    Update:
    The last EOF error caught in mail.err was this morning at 7:58, no more since then.
    What persists ist the unability to send/receive mails:
    Send myself:
    Code:
                       The mail system
    
    
    <me@mydomain.de>: host 127.0.0.1[127.0.0.1] said: 554 5.7.1 id=31201-01
    
      - Rejected by next-hop MTA on relaying, from MTA(smtp:[127.0.0.1]:10027):
    
      554 5.7.1 <me@mydomain.de>: Relay access denied (in reply to end of
    
      DATA command)
    I activated dovecot debug logging, that seems to show that user authentication goes wrong
    Code:
    Jun  9 22:33:42 srv1 dovecot: auth-worker(3134): sql(email@domain.de,xx.xxx.xxx.xxx): unknown user (given password: yyyyyy)
    Jun  9 22:41:29 srv1 dovecot: auth-worker(4684): sql(email@domain.de,xx.xxx.xxx.xxx): unknown user (given password: yyyyyy)
    Jun  9 22:42:54 srv1 dovecot: auth-worker(4743): sql(email@domain.de,xx.xxx.xxx.xxx): unknown user (given password: yyyyyy)
    Jun  9 22:47:55 srv1 dovecot: auth-worker(5552): sql(email@domain.de,xx.xxx.xxx.xxx): unknown user (given password: yyyyyy)
    Jun  9 23:01:43 srv1 dovecot: auth-worker(7958): sql(email@domain.de,xx.xxx.xxx.xxx): unknown user (given password: yyyyyy)
    Jun  9 23:05:02 srv1 dovecot: auth-worker(8322): sql(email@domain.de,xx.xxx.xxx.xxx): unknown user (given password: yyyyyy)
    Jun  9 23:12:23 srv1 dovecot: auth-worker(9938): sql(email@domain.de,xx.xxx.xxx.xxx): unknown user (given password: yyyyyy)
    Jun  9 23:14:43 srv1 dovecot: auth-worker(10108): sql(email@domain.de,xx.xxx.xxx.xxx): unknown user (given password: yyyyyy)
    Jun  9 23:20:35 srv1 dovecot: auth-worker(11830): sql(email@domain.de,xx.xxx.xxx.xxx): unknown user (given password: yyyyyy)
    Jun  9 23:27:01 srv1 dovecot: auth-worker(13033): sql(email@domain.de,xx.xxx.xxx.xxx): unknown user (given password: yyyyyy)
    Jun  9 23:29:22 srv1 dovecot: auth-worker(13149): sql(email@domain.de,xx.xxx.xxx.xxx): unknown user (given password: yyyyyy)
    
    Sending mail to the server, the error is
    Code:
    The mail system
    
    
    <me@mydomain.de>: host 127.0.0.1[127.0.0.1] said: 504 5.5.2 id=11911-01
    
      - Rejected by next-hop MTA on relaying, from MTA(smtp:[127.0.0.1]:10025):
    
      504 5.5.2 <localhost>: Helo command rejected: need fully-qualified hostname
    
      (in reply to end of DATA command)
    
    BR,
    Axel
     
    Last edited: Jun 9, 2017
  8. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    need fully-qualified hostname - check your servername with hostname -f
     
  9. axelcon

    axelcon New Member

    Done that
    hostname: srv1
    hostname -f: srv1.server.de

    I created new certificates (did that because I have problems accessing roundcube, too) and mails do come in now. Purely accidental.
    Trying to install a new roundcube now and will see what else I broke ;)

    Thanks for your help!
     

Share This Page