mail problems after server migration

Discussion in 'ISPConfig 3 Priority Support' started by wems, Jan 30, 2018.

  1. wems

    wems New Member HowtoForge Supporter

    hi!
    ispconfig says: smtp server offline.
    I also think i don't receive mails on the new server........

    history:
    i tried to move my complete ispconfig installation with all webs/user/mails from SERVER_A to SERVER_B. both are debian 9. both actual ispconfig version.
    i followed the topics here in the forums.

    together with the ispconfig installation on SERVER_B a new db password for the user ispconfig was set. later - when i restore my databases from SERVER_A - i overwrite the password in the db with the one from SERVER_A.
    So - i changed the passwort in several files and the ispconfig access was possible.
    the websites are fine.

    in mail.err i have (some not so actual) lines:
    dovecot: auth-worker(22187): Error: mysql(localhost): Connect failed to database (dbispconfig): Access denied for user 'ispconfig'@'localhost' (using password: YES)
    I changed the password in the dovecot-sql.conf to the "old" ispconfig password from SERVER_A.

    I think i need a hint or something. i know there is something small but relvant that i dont see......
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    ensure that you have the correct ispconfig password in the fule /usr/local/ispconfig/server/lib/config.inc.php, then make an ispconfig update with reconfigure services = yes to refresh the config files of all services.
     
  3. wems

    wems New Member HowtoForge Supporter

    the password in /usr/local/ispconfig/server/lib/config.inc.php is correct. i can connect with it using mysql command line.
    as my ispconfig is up to date i cannot use ispconfig_update.sh - so i use these lines:

    Code:
    cd /tmp
    wget http://www.ispconfig.org/downloads/ISPConfig-3-stable.tar.gz
    tar xvfz ISPConfig-3-stable.tar.gz
    cd ispconfig3_install/install
    php -q update.php
    Restarted all services (dovecot / postfix) - they are up and running/active.
    but no mails inbound/outbound (smtp error when use roundcube / smtp status in ispconfig is offline)
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Take a look at the mail.log file to find out why postfix does not start.
     
  5. wems

    wems New Member HowtoForge Supporter

    1) postfix isn't really in the log - only when i try to send a mail it says:
    postfix/postqueue[3757]: warning: Mail system is down -- accessing queue directly

    2) dovecot entry when stop & start the service
    dovecot: master: Warning: Killed with signal 15 (by pid=2925 uid=0 code=kill)
    dovecot: master: Dovecot v2.2.27 (c0f36b0) starting up for imap, pop3 (core dumps disabled)


    on the old server "netstat -tap | grep smtp" brings 2 entrys - smtp is listen.
    on the new server the command returns nothing.
     
    Last edited: Jan 30, 2018
  6. wems

    wems New Member HowtoForge Supporter

    i got it - i got it
    in the /etc/postfix/main.cf i have a type error (missing space in front of "-o").
    as i manually reconfig postfix with "sudo dpkg-reconfigure postfix" it printed an error.

    @till: should i reconfigure the services with the resync tool or is it ok to use "sudo dpkg-reconfigure postfix"?
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Hmm, -o lines are normally in master.cf, not main.cf. Fix the mentioned line and restart postfix. I wont use dpkg-reconfigure as it will remove your mail server config and the resync tool in ispconfig has different purpose, it does not alter the postfix main.cf and master.cf files.
     

Share This Page