Mail Problem

Discussion in 'Installation/Configuration' started by BlueStream, Dec 13, 2006.

  1. till

    till Super Moderator Staff Member ISPConfig Developer

    Which messages do you get in the mail log now when you send and receive email.
     
  2. BlueStream

    BlueStream New Member

    Code:
    Dec 18 19:54:11 s6 postfix/smtpd[31512]: connect from localhost.localdomain[127.0.0.1]
    Dec 18 19:54:11 s6 postfix/smtpd[31512]: warning: Illegal address syntax from localhost.localdomain[127.0.0.1] in MAIL c$
    Dec 18 19:54:11 s6 postfix/smtpd[31512]: lost connection after RCPT from localhost.localdomain[127.0.0.1]
    Dec 18 19:54:11 s6 postfix/smtpd[31512]: disconnect from localhost.localdomain[127.0.0.1]
    
    I may see the problem.. lol.. How do I change it eh?
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, please change the hostname to a valid unique hostname that exists in dns.

    1) Change it in /etc/mailname, if this file exists on your server.
    2) Change it in /etc/postfix/main.cf, if you find it there.
    3) Change it in /etc/hostname and run the command:

    hostname -F /etc/hostname

    4) Restartart postfix.
     
  4. BlueStream

    BlueStream New Member

    1) No file
    2) I'm not too sure so I change myhostname. Should I also change mydomain?
    3) I change /etc/hosts to 127.0.0.1 fusionstream.org localhost.
    Previously hostname was s6.fusionstream.org

    How? Getting more and more complicated..
     
    Last edited: Dec 18, 2006
  5. BlueStream

    BlueStream New Member

    While trying to send a message to myself:
    Code:
    Dec 22 11:40:05 s6 postfix/smtpd[10668]: warning: Illegal address syntax from fusionstream.org[127.0.0.1] in MAIL command: [email protected]
    
    Dec 22 11:40:05 s6 postfix/smtpd[10668]: lost connection after RCPT from fusionstream.org[127.0.0.1]
    Any ideas?

    Turns out I can receive mail... I added fusionstream.org to mydomain yesterday and i received some mail. But it took about ten minutes to be received.

    Is it really a good idea to add my domain to mydomain? what about those other FQDNs that I host?
     
  6. BlueStream

    BlueStream New Member

    squirellmail displays no errors but when sending to gmail it does not appear in my gmail inbox..


    however, when sending to myself(this mail server's email), it appears in my inbox immediately and it say from [email protected]

    what is up with that?
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post your main.cf file, comments stripped.
     
  8. BlueStream

    BlueStream New Member

    Code:
    queue_directory = /var/spool/postfix
    command_directory = /usr/sbin
    daemon_directory = /usr/libexec/postfix
    mail_owner = postfix
    myhostname = fusionstream.org
    mydomain = fusionstream.org
    inet_interfaces = all
    unknown_local_recipient_reject_code = 550
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    debug_peer_level = 2
    debugger_command =
    	 PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
    	 xxgdb $daemon_directory/$process_name $process_id & sleep 5
    sendmail_path = /usr/sbin/sendmail.postfix
    newaliases_path = /usr/bin/newaliases.postfix
    mailq_path = /usr/bin/mailq.postfix
    setgid_group = postdrop
    html_directory = no
    manpage_directory = /usr/share/man
    sample_directory = /usr/share/doc/postfix-2.2.8/samples
    readme_directory = /usr/share/doc/postfix-2.2.8/README_FILES
    smtpd_sasl_local_domain = 
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    smtpd_tls_auth_only = no
    smtp_use_tls = yes
    smtpd_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom
    virtual_maps = hash:/etc/postfix/virtusertable
    mydestination = /etc/postfix/local-host-names
    mynetworks = 127.0.0.0/8
    
     
  9. falko

    falko Super Moderator ISPConfig Developer

    You must set the correct sender address in your email client (e.g. Thunderbird, Outlook, webmail, etc.).
     
  10. BlueStream

    BlueStream New Member

    squirrelmail does not have this option... The mentioned occurences, I believe, are not the cause but are the symptoms.
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    Squirrelmail has this option for every account, please check under settings.

    You can try to set:

    myorigin = fusionstream.org
     
  12. BlueStream

    BlueStream New Member

    There is no such option via squirrelmail's webpage.

    I tried editing via the main.cf and it still does not work..
     
  13. till

    till Super Moderator Staff Member ISPConfig Developer

    My squirrelmail has this setting. Its under options -> personal settings. (I run squirrelmail in german translation, so the name of the menus may differ a bit).
     
  14. BlueStream

    BlueStream New Member

    Ok. It works now in the sense that I can now send messages to myself. or rather, to emails within my domain.

    I get no errors when sending elsewhere but the mail never arrives.

    Is there any fix to the "FROM" issue with squirrelmail? Because it looks like I have to manually edit this item for each email account I create.
     
  15. falko

    falko Super Moderator ISPConfig Developer

    What's in your mail log when this happens?
    Are the domains you try to send to listed in /etc/postfix/local-host-names?
     
  16. BlueStream

    BlueStream New Member

    It is not in the said file. It is an "external domain".. i.e. yahoo mail, etc..
    Code:
    Dec 25 04:34:34 s6 postfix/smtpd[3361]: connect from fusionstream.org[127.0.0.1]
    Dec 25 04:34:34 s6 postfix/smtpd[3361]: 53884A8DCD: client=fusionstream.org[127.0.0.1]
    Dec 25 04:34:34 s6 postfix/cleanup[3362]: 53884A8DCD: message-id=<[email protected]$
    Dec 25 04:34:34 s6 postfix/qmgr[29813]: 53884A8DCD: from=<[email protected]>, size=711, nrcpt=1 (queue active)
    Dec 25 04:34:34 s6 postfix/smtpd[3361]: disconnect from fusionstream.org[127.0.0.1]
    Dec 25 04:34:34 s6 dovecot: imap-login: Login: user=<fusionstream>, method=PLAIN, rip=::ffff:127.0.0.1, lip=::ffff:127.0.0.$
    Dec 25 04:34:34 s6 dovecot: IMAP(fusionstream): Disconnected: Logged out
    Dec 25 04:34:34 s6 dovecot: imap-login: Login: user=<fusionstream>, method=PLAIN, rip=::ffff:127.0.0.1, lip=::ffff:127.0.0.$
    Dec 25 04:34:35 s6 dovecot: IMAP(fusionstream): Disconnected: Logged out
    
    No mention of my external mail server here. There seems to be some usage of the user name though..
     
    Last edited: Dec 24, 2006
  17. falko

    falko Super Moderator ISPConfig Developer

    Please check the spam folder in your Yahoo account. If you send from a dynamic IP address or are blacklisted, Yahoo will tag your emails as spam.
     
  18. BlueStream

    BlueStream New Member

    i have already checked at the start.. emails are totally not received..
     
  19. till

    till Super Moderator Staff Member ISPConfig Developer

    Please check with:

    postqueue -p

    If the message is still in your local mailqueue.
     
  20. BlueStream

    BlueStream New Member

    Woohoo! Progress! lol...

    The messages are in the queue!

    Code:
    __somenumbers__     3199 Sat Dec 23 16:22:27  MAILER-DAEMON
                       (connect to gmail.com[64.233.161.83]: Connection timed out)
                                             [email protected]
    What do I do now?
     

Share This Page