Mail Problem.

Discussion in 'Installation/Configuration' started by baicunko, Jul 14, 2011.

  1. baicunko

    baicunko New Member

    I've managed to install ISPConfig 3 and all servers are Up and running!
    My problem comes when i try to connect to the mail server.
    Using my blackberry I can't seem to connect to the mailboxs I've created, I don't know why.
    Also as I haven't got SquirrelMail I can't see if my mailboxs are being correctly created.
    My domain is ganganadores.com and I think everything is working correctly.
    Any suggestion on how to make mails works?
    This is my mail Log
    Code:
    Jul 12 23:23:49 server dovecot: imap-login: Disconnected: user=, method=PLAIN, rip=178.239.83.1, lip=192.168.1.136, TLS
    Jul 12 23:23:49 server dovecot: imap-login: Disconnected: user=, method=PLAIN, rip=178.239.83.1, lip=192.168.1.136, TLS
    Jul 12 23:23:49 server dovecot: pop3-login: Disconnected: user=, method=PLAIN, rip=178.239.83.1, lip=192.168.1.136
    Jul 12 23:23:49 server dovecot: imap-login: Disconnected: user=, method=PLAIN, rip=178.239.83.1, lip=192.168.1.136
    Jul 12 23:23:51 server dovecot: imap-login: Disconnected: user=, method=PLAIN, rip=178.239.83.1, lip=192.168.1.136, TLS
    Jul 12 23:23:51 server dovecot: imap-login: Disconnected: user=, method=PLAIN, rip=178.239.83.1, lip=192.168.1.136, TLS
    Jul 12 23:23:58 server postfix/qmgr[4584]: fatal: unsupported dictionary type: mysql
    Jul 12 23:23:59 server postfix/master[3146]: warning: process /usr/libexec/postfix/qmgr pid 4584 exit status 1
    Jul 12 23:23:59 server postfix/master[3146]: warning: /usr/libexec/postfix/qmgr: bad command startup -- throttling
    Jul 12 23:24:06 server postfix/smtpd[4624]: fatal: unsupported dictionary type: mysql
    Jul 12 23:24:07 server postfix/master[3146]: warning: process /usr/libexec/postfix/smtpd pid 4624 exit status 1
    Jul 12 23:24:07 server postfix/master[3146]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling
    Jul 12 23:24:59 server postfix/qmgr[4681]: fatal: unsupported dictionary type: mysql
    Jul 12 23:25:00 server postfix/master[3146]: warning: process /usr/libexec/postfix/qmgr pid 4681 exit status 1
    Jul 12 23:25:00 server postfix/master[3146]: warning: /usr/libexec/postfix/qmgr: bad command startup -- throttling
     
  2. CSsab

    CSsab New Member

    You might need to give a little more information :)

    What how-to did you follow to set up your server?

    Why did you decide not to install squirrelmail?

    :confused:
     
  3. baicunko

    baicunko New Member

    I followed the guide for The perfect Server Centos 5.6 ISpConfig 3
    I'm unable to install squirrelmail thorugh yum because there seems to be some problem with the dependencies I installed.
    I've installed php 5.3.6 and when i try to install squirrelmail I get the following error.
    Code:
    [[email protected] ~]# yum install squirrelmail
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
     * base: centos.mirror.mendoza-conicet.gob.ar
     * extras: centos.mirror.mendoza-conicet.gob.ar
     * rpmforge: fr2.rpmfind.net
     * updates: centos.mirror.mendoza-conicet.gob.ar
    Excluding Packages from Red Hat Enterprise Linux 5 - x86_64 - ATrpms
    Finished
    Reducing Red Hat Enterprise Linux 5 - x86_64 - ATrpms to included packages only
    Finished
    Excluding Packages from Red Hat Enterprise Linux 5 - x86_64 - ATrpms testing
    Finished
    Reducing Red Hat Enterprise Linux 5 - x86_64 - ATrpms testing to included packages only
    Finished
    Setting up Install Process
    Resolving Dependencies
    --> Running transaction check
    ---> Package squirrelmail.noarch 0:1.4.8-5.el5.centos.10 set to be updated
    --> Processing Dependency: php-mbstring for package: squirrelmail
    --> Running transaction check
    ---> Package php-mbstring.i386 0:5.1.6-27.el5_5.3 set to be updated
    --> Processing Dependency: php-common = 5.1.6-27.el5_5.3 for package: php-mbstring
    --> Finished Dependency Resolution
    php-mbstring-5.1.6-27.el5_5.3.i386 from base has depsolving problems
      --> Missing Dependency: php-common = 5.1.6-27.el5_5.3 is needed by package php-mbstring-5.1.6-27.el5_5.3.i386 (base)
    Error: Missing Dependency: php-common = 5.1.6-27.el5_5.3 is needed by package php-mbstring-5.1.6-27.el5_5.3.i386 (base)
     You could try using --skip-broken to work around the problem
     You could try running: package-cleanup --problems
                            package-cleanup --dupes
                            rpm -Va --nofiles --nodigest
    The program package-cleanup is found in the yum-utils package
    Any sugestion?
     
  4. CSsab

    CSsab New Member

    I don't use your distro but ..

    try:

    yum install php-common

    and let us know how you go.
     
  5. baicunko

    baicunko New Member

    Already installed, but I've got installed the Php 5.3.4 version installed, looks like SquirrelMail needs Php 5.2.X, and I can't seem to know any other way around.
    What about installing the Package from squirrelmail.com? The problem is I don't know how to install it!
    Thanks
     
  6. CSsab

    CSsab New Member

    What I normally do when stuck like that is backup my sources and step up to the "testing" repository .. that would likely have the squirrelmail you need.

    Otherwise if you want to try installing from source have a look http://squirrelmail.org/docs/admin/admin-3.html#ss3.2 <--- starting from about half way down where it says "Prepare SquirrelMail directories".
     
  7. falko

    falko Super Moderator ISPConfig Developer

    The problem is that your Postfix doesn't have MySQL support. Did you install Postfix from the CentOS Plus repository, as shown in the tutorial?
     

Share This Page