mail problem

Discussion in 'Installation/Configuration' started by kaliszakpl, Mar 20, 2008.

  1. kaliszakpl

    kaliszakpl New Member

    hi i dont know why i dont see mail in my mailbot
    i have ubuntu 7.10 + psotfix + UebiMiau Webmail

    main.cf

    smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
    biff = no

    append_dot_mydomain = no


    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_use_tls = yes
    smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
    smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache

    myhostname = server.rudowicz.pl
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    myorigin = /etc/mailname
    relayhost =
    mynetworks = 127.0.0.0/8
    mydestination = /etc/postfix/local-host-names
    mailbox_command = procmail -a "$EXTENSION"
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    inet_protocols = all
    smtpd_sasl_local_domain =
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_recipient_restrictions = permit_sasl_authenticated, permit_mynetworks, reject_unauth_destination
    smtpd_tls_auth_only = no
    smtp_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom

    local-host-names
    localhost
    server.rudowicz.pl
    localhost.server.rudowicz.pl
    localhost.rudowicz.pl
    localhost.localdomain
    www.rudowicz.pl
    rudowicz.pl
    #### MAKE MANUAL ENTRIES BELOW THIS LINE! ####
    mail.rudowicz.pl

    When somone sen mail in mail.log i have

    ar 20 17:42:28 server courierpop3login: Connection, ip=[::ffff:127.0.0.1]
    Mar 20 17:42:28 server courierpop3login: LOGIN, user=martin, ip=[::ffff:127.0.0.1]
    Mar 20 17:42:28 server courierpop3login: LOGOUT, user=martin, ip=[::ffff:127.0.0.1], top=0, retr=0, rcvd=12, sent=88, time=0
    Mar 20 17:42:31 server courierpop3login: Connection, ip=[::ffff:127.0.0.1]
    Mar 20 17:42:31 server courierpop3login: LOGIN, user=martin, ip=[::ffff:127.0.0.1]
    Mar 20 17:42:31 server courierpop3login: LOGOUT, user=martin, ip=[::ffff:127.0.0.1], top=0, retr=0, rcvd=12, sent=88, time=0
    Mar 20 17:42:55 server postfix/smtpd[8406]: connect from smtp4.poczta.onet.pl[213.180.130.28]
    Mar 20 17:42:55 server postfix/smtpd[8406]: C66B4197284: client=smtp4.poczta.onet.pl[213.180.130.28]
    Mar 20 17:42:55 server postfix/cleanup[8410]: C66B4197284: message-id=<[email protected]>
    Mar 20 17:42:56 server postfix/qmgr[7796]: C66B4197284: from=<[email protected]>, size=1531, nrcpt=1 (queue active)
    Mar 20 17:42:56 server postfix/smtpd[8406]: disconnect from smtp4.poczta.onet.pl[213.180.130.28]
    Mar 20 17:42:56 server procmail[8412]: Suspicious rcfile "/var/www/web1/.procmailrc"
    Mar 20 17:42:56 server postfix/local[8411]: C66B4197284: to=<[email protected]>, relay=local, delay=0.82, delays=0.25/0.01/0/0.56, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)
    Mar 20 17:42:56 server postfix/qmgr[7796]: C66B4197284: removed
    Mar 20 17:43:04 server courierpop3login: Connection, ip=[::ffff:127.0.0.1]
    Mar 20 17:43:04 server courierpop3login: LOGIN, user=martin, ip=[::ffff:127.0.0.1]
    Mar 20 17:43:04 server courierpop3login: LOGOUT, user=martin, ip=[::ffff:127.0.0.1], top=0, retr=0, rcvd=12, sent=88, time=0


    Why i dont see mail in my webmail?
    What I should mark in ISPConfig
    Management -->Settings --> EMail --> Maildir:
    Maildir i must mark or not ??
    at the monet i dont have mark Maildir in ISPConfig
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    If you use courier or dovecot as pop3 daemon, you will have to enable maildir. otherwise not
     
  3. kaliszakpl

    kaliszakpl New Member

    Hm

    i install my ISPConfig doing this
    ISP Server Setup with Ubuntu 7.10 (Gutsy Gibbon)

    http://www.howtoforge.com/perfect_server_ubuntu7.10


    but why if someone send my i see in
    mail.log
    Mar 20 21:45:06 server postfix/anvil[6873]: statistics: max connection rate 1/60s for (smtp:72.21.11.42) at Mar 20 21:41:43
    Mar 20 21:45:06 server postfix/anvil[6873]: statistics: max connection count 1 for (smtp:72.21.11.42) at Mar 20 21:41:43
    Mar 20 21:45:06 server postfix/anvil[6873]: statistics: max cache size 1 at Mar 20 21:41:43

    in mail.info
    Mar 20 21:45:06 server postfix/anvil[6873]: statistics: max connection rate 1/60s for (smtp:72.21.11.42) at Mar 20 21:41:43
    Mar 20 21:45:06 server postfix/anvil[6873]: statistics: max connection count 1 for (smtp:72.21.11.42) at Mar 20 21:41:43
    Mar 20 21:45:06 server postfix/anvil[6873]: statistics: max cache size 1 at Mar 20 21:41:43

    On ISPConfig i put dns
    ns1.atomdns.net
    ns2.atomdns.net

    No Record Name Type TTL IP/Host Actions X
    1 rudowicz.pl A 43200 89.228.192.50

    2 www.rudowicz.pl A 43200 89.228.192.50

    3 ftp.rudowicz.pl A 43200 89.228.192.50

    4 mail.rudowicz.pl A 43200 89.228.192.50

    5 rudowicz.pl MX 43200 10:mail.rudowicz.pl


    mayby ther is somethin wrong???
    i someone sent mail i see them on
    var/mail/ user

    but when I login in www.rudowicz.pl:81/webmail
    my Inbox is empty ? :(

    Can you helpmy plz
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Please go to Management > Server > Settings > Email and enable Maildir.
     
  5. kaliszakpl

    kaliszakpl New Member

    Thanks but

    It was difrent problem
    problem is premission to________________________________
    /var/mail/ user
    sometimes if i add user he dont how inof premission
    what should be there premission i
    can add something to cron and always check premission do files user ?
     
  6. falko

    falko Super Moderator ISPConfig Developer

    The permissions of /var/mail/user don't matter if you use Maildir because in this case /var/mail/user isn't used at all.
     

Share This Page