Mail problem when www in site name.

Discussion in 'Installation/Configuration' started by shanta, Feb 17, 2008.

  1. shanta

    shanta New Member


    I set up a mail server with ISPConfig on Debian 4 etch.

    As I have all web services on a different server I did not want to have in the configuration.

    Unfortunately ISPConfig wants to put it in the subdomain by defalut.

    If you go to add an email address and forget to remove the www It get saved to the configuration file and mail to that domain no longer works until it is removed.

    How can I fix this problem?

  2. falko

    falko Super Moderator ISPConfig Developer

    Select "External Mailserver" for that Co-Domain (it's on the Options tab).
  3. shanta

    shanta New Member

    mail problem

    would this not disable the mailserver all togethe? This is the mailserver I want accepting and delivering mail. External mailserver means to me that mail is controlled by another server.

    I am attempting to configer a mail only server.
    Thanks Shanta
  4. falko

    falko Super Moderator ISPConfig Developer

    No, it would only remove that domain from the Postfix configuration, but Postfix keeps running.
  5. shanta

    shanta New Member

    Which means Postfix on the mail server will not accept mail for the domain?
    I what the server with ISPconfig to accept mail and only mail for the domain. If I do that who will accept mail for the domain? I guess I am missing what ISPconfig means by remote mail server.

    The web applications, DNS etc run on another server not configured with ISPconfig. The DNS points mail to the ISPconfigured system.
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    It looks as you mix things up here. and are two absolutely different things. If you want to not receive emails for but for, set mailserver to external on the options tab of the website As long as you did not set the co-domain to external mailserver too on the options tab of this co-domain record, you will receive emails for
  7. shanta

    shanta New Member

    In truth I don't care if the postfix accepts mail for www or not. The problem is; if ISPconfig has www set it the domain box in the main configuration screen for the domain NO mail is accepted by the server for that server. Erase the www and the system acceptes mail to This seems to me to be a problem with the ISPConfig defalut setup. I also don't want reselers to have to deal with comfigureing the server to remote or to remove the www each time they add a new email address or edit anything in their mail server.

    There also are no codomains set up for most of the severs. I also don't quite get the diffrence between ISPConfigs definition of a co-domain, subdomain, server alias.

    Doc are not clear on these. I am more used to Apache definitions and WebMin/virtualmin definitions and setup. I am guessing that co-domain and server alias are equivelent and ISPconfig deals with sub-domain as a new server. So is a defalut co-domain of and points to the same directory as dose an apache server alias. points to a different web root, an apache virtual server.
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Please read my post again. You still mix up things! Do what I posted above to solve the problem. Set the website to external mailserver and the co-domain (with empty hostname) must be set to local mailserver. If such a co-domain does not exits (e.g. because you set the domain limit to 1 and ispconfig was not allowed to create this for you automatically), then create the co-domain.
  9. TomC

    TomC New Member

    Let me once again raise the issue of the "external mailserver" option.

    When I set my main site (www.domain.tld) to "external mailserver" while my co-domain (domain.tld) uses "local mailserver" I get a behavior with which I am not too happy:

    If I send an email to [email protected] I get the response "mail for www.domain.tld loops back to myself", which is not surprising after all.

    So what I'd love to see is that ISPConfig removes the entries from the virtusertable, but leaves www.domain.tld in the local-host-names. Then postfix knows it's responsible for the domain, yet bounces mail because there are no mail addresses for that domain.

    ...or is there a better way of achieving what I want?!

  10. falko

    falko Super Moderator ISPConfig Developer

    But then Postfix won't send out emails for www.domain.tld because it thinks it is responsible for www.domain.tld...
  11. TomC

    TomC New Member

    Well, I know, my suggestion wasn't that good. It didn't work anyway when I tried to add the domain manually to local-host-names: Postfix then accepted mails for [email protected] and delivered it to the correct user.

    But lets get back to my problem:

    I want my server to receive mail for [email protected], but NOT for [email protected]. And IF someone sends mail to [email protected] I want him/her to receive an error message like "forget about sending mails to this domain"... What ISPconfig produces with the setting "external mailserver" seems to me like an ugly mail loop.

    So do you have any idea how this can be solved?!

Share This Page