mail problem - authentication (postfix,ISPconfig)

Discussion in 'General' started by marclar, Jun 9, 2006.

  1. marclar

    marclar New Member

    I have successfully installed ISPConfig on my debian system.. So postfix is running, and i can telnet to my server through 25 and 110 ports succesfully. But, when i set up the mail account in outlook, it allways returns error, like username or password is wrong. I have added that user through ISPconfig -> Site -> User &E-mail -> NEW.

    But apparently, this user still doesnt exist, or ain't allowed to acces my mail server.

    Im guessing, if there might be a problem with DNS's? :confused:
    If i type "dig MX mydomain.com" i get an mx record to mail.mydomain.com

    Should I do something with this domain (mail.mydomain.com) in ISPConfig ?
    I'm kind of confused here, please help.
    Tnx to everyone :D
     
    Last edited: Jun 9, 2006
  2. fobicodam

    fobicodam ISPConfig Developer ISPConfig Developer

    Not to test it, but yes if you want to receive email from internet. Go to co-domains inside your domain to add mail.yourdomain.com.

    If you send an email from OE to your server to your email is it delivered?
     
  3. falko

    falko Super Moderator ISPConfig Developer

    Do you use the correct user name (something like web1_user) and password?
    Any errors in your mail log?
    Which distribution do you use?
     
  4. marclar

    marclar New Member

    I get this error, if I try to send e-mail to the account that I created:
    Technical details of permanent failure:
    PERM_FAILURE: SMTP Error (state 9): 550 <[email protected]>: Recipient address rejected: User unknown in local recipient table


    this debian I use:
    Kernel Version 2.4.27-2-386
    Distro Name Debian 3.1


    Where can I see postfix error log?

    Tnx guys ;)
     
    Last edited: Jun 10, 2006
  5. marclar

    marclar New Member

    Now, suddenly, outlook stopped rejecting username and password (i think it's somehow connected with the dns server refreshing time).

    But now i get this error when i try to send an email via outlook:


    The message could not be sent because one of the recipients was rejected by the server. The rejected e-mail address was '[email protected]'. Subject 'test', Account: 'mail.mydomain.com', Server: 'mail.mydomain.com', Protocol: SMTP, Server Response: '554 <[email protected]>: Relay access denied', Port: 25, Secure(SSL): No, Server Error: 554, Error Number: 0x800CCC79


    [email protected] is some working mail adress.

    and also, if I try to send a mail from somewhere else to my [email protected], i get this err:

    Technical details of permanent failure:
    PERM_FAILURE: SMTP Error (state 9): 550 <[email protected]>: Recipient address rejected: User unknown in local recipient table


    any ideas?
     
    Last edited: Jun 10, 2006
  6. marclar

    marclar New Member

    Ok, changes again :)

    I removed reject_unauth_destination from my main.cf in Postfix

    now things changed a bit..

    If i send a mail to [email protected], i don't get an error anymore, and it looks like the mail has been sent successfully. But never cames...

    If i send a mail from mail.mydomain.com account in Outlook, it just waits and waits, and then returnes the usual outlook err msg: SMTP server did not respond in 60s...blabla..

    It looks im getting closer, but I'm still not there yet...

    I found an mail.log, and has lots of entries like this:
    Any help'll do!
    Tnx:D
     
    Last edited: Jun 10, 2006
  7. falko

    falko Super Moderator ISPConfig Developer

    Please run
    Code:
    postmap /etc/postfix/virtusertable
    What'S in /etc/postfix/main.cf? (Please strip out the comments.)
     
  8. marclar

    marclar New Member

    this is the /etc/postfix/main.cf


    I did run "postmap /etc/postfix/virtusertable" and nothing special happended. I guess it's ok.

    Tnx Falko for your time ;)
     
  9. falko

    falko Super Moderator ISPConfig Developer

    Please run
    Code:
    postconf -e 'smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination'
    and restart Postfix.
     
  10. marclar

    marclar New Member

    this string 'reject_unauth_destination', was there before, but i removed it manualy... now with that code u suggested, that came back ofcourse. But this makes things even worse. Now i'm exactly there where i was 5 posts above..
    Now if i try to send an e-mail to my account, I get an error right back:

    Technical details of permanent failure:
    PERM_FAILURE: SMTP Error (state 9): 550 <[email protected]>: Recipient address rejected: User unknown in local recipient table


    if I remove 'reject_unauth_destination', then e-mail is sen't succesfully, but it never cames, though I can see it, in my Maildir folder...

    I hope, you understand, what I'm trying to say, couse my english is a little poor :)

    Tnx again, falko

    :confused:
     
    Last edited: Jun 11, 2006
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    You men you see the email in the maildir folder but cant fetch it with pop3 / IMAP?

    Then you must either switch from maildir to mbox in ISPConfig or install an maildir capacle pop3 and imap client like courier or dovecot on your server.
     
  12. falko

    falko Super Moderator ISPConfig Developer

    Can you post your real domain name here?
    Don't remove reject_unauth_destination.
     
  13. marclar

    marclar New Member

    my real domain is "emanuel.si"
    i'll put reject_unauth_destination back!

    @till:
    I have courier installed!

    thanks guys, you're being really helpful here.
    ps: if you visit slovenia, I'll buy you a couple of beers ;)
     
    Last edited: Jun 13, 2006
  14. falko

    falko Super Moderator ISPConfig Developer

  15. marclar

    marclar New Member

    yes, it is.
    there was an mistake here, yes, ([email protected]), but i corrected it with [email protected], but i still get that error message:

     
  16. fobicodam

    fobicodam ISPConfig Developer ISPConfig Developer

    did you do the postalias /etc/... command?
     
  17. marclar

    marclar New Member

    hm... no.. I don't even know what that is :p
    but i did now, and still the same error :\
     
    Last edited: Jun 14, 2006
  18. till

    till Super Moderator Staff Member ISPConfig Developer

    Do not correct anything in the virtusertable file manually! It's useless as ISPConfig removes your changes.

    Does the website username.mydomain.com has a co-domain mydomain.com with empty host field? If not, create that co-domain.
     
  19. marclar

    marclar New Member

    heh, great, finally some progres!

    I found out, that the e-mail is sent successfully, if I send it to [email protected], and not to the "[email protected]"
    why is that so?

    not a big problem, just wondering...

    E-mail, cames in Outlook to!
    But if I make reply, it says:

    any ideas on that one?
     
  20. fobicodam

    fobicodam ISPConfig Developer ISPConfig Developer


    The relay problem is because the "SMTP server requires autentication" checkbox in outlook.

    The account problem is because postfix isnt reading your aliases config file, did you change something on postfix.conf?
     

Share This Page