mail only delivers to [email protected]

Discussion in 'Installation/Configuration' started by thesquib, Mar 22, 2006.

  1. thesquib

    thesquib New Member

    Hi all,
    I followed the Debian Perfect Setup for Sarge, and then installed ISPConfig.
    Everything seems to be working fine - i setup a test domain to point to the server. When I send emails to the box it will only recieve them when I send them to [email protected] not [email protected].
    I can also send to [email protected]

    Initially i had an error in the mail logs saying:

    However now when I send an email to [email protected], it isn't mentioned in the logs at all...
    There is something which I have noticed in the entry.. i'm pretty sure the [email protected] should be [email protected].

    My /etc/postfix/main.cf is:
    I'm not sure where I have messed up! Please tell me if I should post any other information.. Also note that I have changed all references to server to servername.domain.com or domain.com, etc. :D

    Thanks for any help
     
  2. thesquib

    thesquib New Member

    Oh by the way -
    is ispconfig setup maildir is enabled, and there is a co domain setup with MX records for domain.com. I setup a User for email in the admin panel.
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Please make shure that a co-domain domain.com (with empty host) is added to the website www.domain.com.
     
  4. thesquib

    thesquib New Member

    I have - and I also ticked Create DNS and MX records for it.
    This didn't work either, so I deleted the whole site setup in ISPConfig, emptied the recycle bin and started again.
    Still no go..
     
  5. falko

    falko Super Moderator ISPConfig Developer

    Please add domain.com at the end of /etc/postfix/local-host-names and restart Postfix.

    Can you post the real domain name here?
     
  6. thesquib

    thesquib New Member

  7. thesquib

    thesquib New Member

    to clarify a little.
    torpedo is the server name. thinkdata.co.nz is the domain. squib.co.nz is a domain that is pointing to this server, and which I have setup in ispconfig.

    my full main.cf is:
    # See /usr/share/postfix/main.cf.dist for a commented, more complete version

    smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
    biff = no

    # appending .domain is the MUA's job.
    append_dot_mydomain = no

    # Uncomment the next line to generate "delayed mail" warnings
    #delay_warning_time = 4h

    myhostname = torpedo.thinkdata.co.nz
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    myorigin = /etc/mailname
    #mydestination = torpedo.thinkdata.co.nz, thinkdata.co.nz, torpedo, localhost
    relayhost =
    mynetworks = 127.0.0.0/8
    mailbox_command =
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    smtpd_sasl_local_domain =
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    smtpd_tls_auth_only = no
    smtp_use_tls = yes
    smtpd_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom
    virtual_maps = hash:/etc/postfix/virtusertable
    mydestination = /etc/postfix/local-host-names
    home_mailbox = Maildir/
    mydomain = thinkdata.co.nz
     
  8. falko

    falko Super Moderator ISPConfig Developer

    Code:
     dig mx squib.co.nz
    
    ; <<>> DiG 9.2.1 <<>> mx squib.co.nz
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 11943
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;squib.co.nz.                   IN      MX
    
    ;; ANSWER SECTION:
    squib.co.nz.            3600    IN      MX      10 [B][COLOR="Red"]auckland.thinkhive.co.nz[/COLOR][/B].
    
    ;; Query time: 623 msec
    ;; SERVER: 81.169.163.104#53(81.169.163.104)
    ;; WHEN: Thu Mar 23 09:21:08 2006
    ;; MSG SIZE  rcvd: 64
    
    The mail server for squib.co.nz is auckland.thinkhive.co.nz - that's where your emails go.
     
  9. thesquib

    thesquib New Member

    Uhg, sorry - i changed the MX record to another mail server, when I had finished up.
     
  10. thesquib

    thesquib New Member

    MX Record is now pointing to the correct server again.
    I apologise for the confusion there.
     
  11. thesquib

    thesquib New Member

    I have sorted it out -

    it seems that my host file was not correct. I didn't think this would cause problems.. oh well.
    Thanks :)
     

Share This Page