Mail not working

Discussion in 'Installation/Configuration' started by Roadracer, Dec 27, 2005.

  1. Roadracer

    Roadracer New Member

    Not sure what is happening. Any help would be appriciated. I have installed phpBB2 on my site and just to test the email system, I tried to send something via the website. I didn't get any mail. Here is some of the maillog.

    Not sure if its the server or my error in setting up phpBB. Sorry if this turns out to my my error in setting up phpBB.

    Just added the webmail pkg. to test that, install worked, but can't log into it.
     
    Last edited: Dec 27, 2005
  2. ZyanKLee

    ZyanKLee New Member

    has it been this message:
    there seems to be a problem with the domain of your server, maybe the dns-settings were recently changed. perhaps the mailserver where your email went to could not look up the domain and therefore didn't accept the mail ?

    but I am only a little noob, falko or till might know more about this case
     
  3. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    I gues server.roadracers.org is the hostname of your ISPConfig server? ZyanKLee is right, the domain server.roadracers.org does not exits in DNS. Please create an A or CName record for server.roadracers.org in the authoritive nameserver for the domain roadracers.org pointing to your server.
     
  4. Roadracer

    Roadracer New Member

    Is there a way to change the mail to point to another server? I haven't moved roadracers.org onto the server until I know everything works. I do have defendersguild.org running on the server and all the DNS is pointing to the right spot.

    Otherwise I will rebuild the server again with the right information.
     
  5. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    You dont have to rebuild the server. Just set the hostname of the server to the other domain. Which linux distribution do you use?
     
  6. Roadracer

    Roadracer New Member

    Fedora Core 4
     
  7. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    I suggest that you either create an A record for server.roadracers.org pointing to your server or replace server.roadracers.org with server.defendersguild.org (and create an A record for it). You 'd then have to replace server.roadracers.org in /etc/hosts, /etc/hostname (
    Code:
    echo server.defendersguild.org > /etc/hostname
    /bin/hostname -F /etc/hostname
    ), /etc/postfix/main.cf (restart Postfix afterwards), maybe your Apache configuration (restart Apache afterwards), etc.
     
  8. Roadracer

    Roadracer New Member

    Thanks Till and Falko for helping me with this. It looks like somethings are working now but I have not gotten any emails. The first email looks like it got bounced for a IP on a banned list, the second I am not sure why I didn't get the mail. Here is the log now, it will make more sense to you.

     
  9. Roadracer

    Roadracer New Member

    I also noted this in the /etc/postfix/virtusertable

    .org is missing on some of the entries, is this correct or a mistake?
     
  10. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

  11. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    The mail log looks ok apart from this:

    which means your IP is on a black list. Is it a dynamic IP address? Many email servers block emails that originate from dynamic IP addresses.
     
  12. Roadracer

    Roadracer New Member

    yes it is dynamic until I move in January.

    I changed my email on the one account to a local account. I am able to receive email locally, but email sent out to webmaster@roadracers.org say they are sent, but I never recieve them. Here is a line that shows it was accepted:

     
    Last edited: Dec 29, 2005
  13. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    That mail has been sent to root. I guess roadracers.org is still in /etc/postfix/local-host-names? Maybe there's also an alias for webmaster which delivers emails to root in /etc/alises?
     
  14. Roadracer

    Roadracer New Member

    Thank you so much for your help, looks like everything is working great now. There was an old entry in the /etc/postfix/local-host-names, once I removed it, everything is being sent to the right spots.

    Just one last question, I noticed this when I restarted httpd :
    Since I removed roadracers.org from the server, will this error cause any problems? I will be moving roadracers.org to the site now that I know everything is working correctly.

    I just noticed that msn.com emails are routed to mx1.hotmail.com servers and they time out. From what I have read, I need to create a SPF file. Where does this file go, I am lost when it says to place it in my zone file?
     
    Last edited: Dec 29, 2005
  15. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    That's just a warning, nothing serious.



    For which domain?
     
  16. Roadracer

    Roadracer New Member

    For starters I want to add it to defendersguild.org
     
  17. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    The authoritative name servers for that domain are ns19a.nameservers.net and ns19b.nameservers.net so you have to create the SPF record on these servers (or have someone do it).

    Here's a good wizard for creating SPF records: http://www.openspf.org/wizard.html?mydomain=&x=34&y=4
     

Share This Page