Mail not reaching my local Server! Queued in system....

Discussion in 'Installation/Configuration' started by Dimitriy, Jun 20, 2006.

  1. Dimitriy

    Dimitriy New Member

    Paypal Bonus...Mail not reaching my local Server! Queued in system....

    Setup:
    Ubuntu 6.06 (using perfect installation guide)
    Network: Single server single IP single site for the moment (IP Dedicated)
    ISPConfig 2.23
    -------------------------------
    Ok I can:

    > Send mail through both webmail (Roundcube/UM) and client (Mozilla Thunderbird using TLS).

    I CANT:

    > Retrieve mail using client (Thunderbird)
    > Recieve mail to my inbox (but it goes into the queue...see below)

    When I run the "postqueue -p" command I get the following printout...
    Code:
    -Queue ID- --Size-- ----Arrival Time---- -Sender/Recipient-------
    BFF2D1AD87BD     2957 Fri Jun 16 17:33:19  MAILER-DAEMON
    (Host or domain name not found. Name service error for name=antec.qualitysiding.net type=MX: Host not found, try again)
                                             [email protected]
    
    593B81AD87C0     1593 Fri Jun 16 17:57:39  [email protected]
    (Host or domain name not found. Name service error for name=antec.qualitysiding.net type=MX: Host not found, try again)
                                             [email protected]
    
    040511AD87C9     2351 Mon Jun 19 15:11:34  [email protected]
    (Host or domain name not found. Name service error for name=antec.qualitysiding.net type=MX: Host not found, try again)
                                             [email protected]
    
    -- 7 Kbytes in 3 Requests.
    
    My local server is called "antec.qualitysiding.net" and my public domain is qualitysiding.net. My DNS is managed through www.poweryourname.com (A service similar to Godaddy) and it looks picture attached.

    So what am I doing wrong here? I can send mail through Thunderbird and webmail using my public name ([email protected]) and it works completely fine.

    ALSO, I use Gmail to test and whenever I respond to a message it doesnt give me an error. I assume this is because the mail is recieved at my end (qualitysiding.net -->> antec.qualitysiding.net) and stores it in a temporary location since it cant resolve the name?

    Anybody got a hint on how to make say people who got mail.qualitysiding.net will take them to my webmail form (mail.qualitysiding.net -->> https://qualitysiding.net:81/roundcube)?

    Thanks,
    Dimitriy

    DNS config if you cant get it:
    [​IMG]
     
    Last edited: Jun 22, 2006
  2. Dimitriy

    Dimitriy New Member

    Also results of hostname and "hostname -f" gives me the following:

    antec -- just simple hostname

    localhost.localdomain -- thats for "hostname -f"
     
  3. Dimitriy

    Dimitriy New Member

    Should be simple enough.... No takers?
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Code:
    dig antec.qualitysiding.net
    
    ; <<>> DiG 9.2.1 <<>> antec.qualitysiding.net
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 63817
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;antec.qualitysiding.net.       IN      A
    
    ;; AUTHORITY SECTION:
    qualitysiding.net.      3600    IN      SOA     dns01.gpn.register.com. partnersupport.register.com. 2002050701 10001 1801 604801 181
    
    ;; Query time: 138 msec
    ;; SERVER: 81.169.163.104#53(81.169.163.104)
    ;; WHEN: Wed Jun 21 00:48:14 2006
    ;; MSG SIZE  rcvd: 114
    antec.qualitysiding.net doesn't exist. Please create an A record for it.
     
  5. Dimitriy

    Dimitriy New Member

  6. Dimitriy

    Dimitriy New Member

    Ok got something here I think. The only place that postfix references the host name is in /etc/postfix/main.cf.

    /etc/postfix/main.cf
    Code:
    ...
    myhostname = antec.qualitysiding.net
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    myorigin = /etc/mailname
    #mydestination = antec.qualitysiding.net, localhost.qualitysiding.net, , localhost
    relayhost =
    mynetworks = 127.0.0.0/8
    mailbox_command = procmail -a "$EXTENSION"
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    inet_protocols = all
    smtpd_sasl_local_domain =
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    smtpd_tls_auth_only = no
    smtp_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom
    
    virtual_maps = hash:/etc/postfix/virtusertable
    
    mydestination = /etc/postfix/local-host-names
    
    So what should change?
     
    Last edited: Jun 21, 2006
  7. falko

    falko Super Moderator ISPConfig Developer

    Just create an A record for antec.qualitysiding.net, that should work. I didn't see it in the dig output yet, but it might take some time until it appears.
     
  8. Dimitriy

    Dimitriy New Member

    This was done 24 hours ago. Should be working....
     

    Attached Files:

  9. Dimitriy

    Dimitriy New Member

    Results of "postqueue -p"

    Does this make this a internal error then??


    Code:
    [email protected]:~# postqueue -p                                                     -Queue ID- --Size-- ----Arrival Time---- -Sender/Recipient-------
    BFF2D1AD87BD     2957 Fri Jun 16 17:33:19  MAILER-DAEMON
    (Host or domain name not found. Name service error for name=antec.qualitysiding.net type=MX: Host not found, try again)
                                             [email protected]
    
    593B81AD87C0     1593 Fri Jun 16 17:57:39  [email protected]
    (Host or domain name not found. Name service error for name=antec.qualitysiding.net type=MX: Host not found, try again)
                                             [email protected]
    
    040511AD87C9     2351 Mon Jun 19 15:11:34  [email protected]
    (Host or domain name not found. Name service error for name=antec.qualitysiding.net type=MX: Host not found, try again)
                                             [email protected]
    
    3B00B1AD87CD     1634 Tue Jun 20 16:24:34  [email protected]
    (Host or domain name not found. Name service error for name=antec.qualitysiding.net type=MX: Host not found, try again)
                                             [email protected]
    
    8F0181AD87CE     2204 Tue Jun 20 16:39:46  [email protected]
    (Host or domain name not found. Name service error for name=antec.qualitysiding.net type=MX: Host not found, try again)
                                             [email protected]
    
    -- 12 Kbytes in 5 Requests.
    
     
  10. Dimitriy

    Dimitriy New Member

    Get me a right answer and it works and you get 15 bucks in your paypal.

    The ?/Problem: Make mail system work normally (eg. recieve and send mail.). Must be able to login as through POP and use a simple client aka Mozilla Thunderbird.

    Its pretty simple but I am not a networking pro or even a novice.....
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    You must create an MX record for "antec" in the domain qualitysiding.net.

    If you want to get commercial support, please contact us at info [at] projektfarm [dot] de
     
  12. falko

    falko Super Moderator ISPConfig Developer

    It's working now:

    Code:
    dig antec.qualitysiding.net
    
    ; <<>> DiG 9.2.1 <<>> antec.qualitysiding.net
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 29794
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;antec.qualitysiding.net.       IN      A
    
    ;; ANSWER SECTION:
    [B][COLOR="Red"]antec.qualitysiding.net. 3600   IN      A       71.231.173.173[/COLOR][/B]
    
    ;; Query time: 102 msec
    ;; SERVER: 81.169.163.104#53(81.169.163.104)
    ;; WHEN: Thu Jun 22 15:35:00 2006
    ;; MSG SIZE  rcvd: 57
    BTW, you should have put just antec instead of antec.qualitysiding.net in the host column of your DNS panel.
     
  13. Dimitriy

    Dimitriy New Member

    Same scenario. Except now postfix doesnt report a queue item whenever something is sent to: "[email protected]" and it doesnt appear in the inbox. It does however whenever I send mail to "[email protected]"

    The Thunderbird (client software) issue still remains. However I believe its more of a authentication problem rather than a server configuration problem.

    I have done as "till" said and now it represents antec A record to my IP.

    Note that the /etc/postfix/virtusertable shows both addresses ([email protected]*.net and X@*.net)

    So what next?

    PS: There is no bounceback for failed delivery.
     
    Last edited: Jun 23, 2006
  14. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    netstat -tap
    ?
    Which distribution do you use?
     
  15. Dimitriy

    Dimitriy New Member

    Netstat -tap
    Code:
    [email protected]:~# netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
    tcp        0      0 *:mysql                 *:*                     LISTEN     5144/mysqld
    tcp        0      0 *:netbios-ssn           *:*                     LISTEN     13316/smbd
    tcp        0      0 *:5900                  *:*                     LISTEN     6150/vino-server
    tcp        0      0 *:81                    *:*                     LISTEN     5697/ispconfig_http
    tcp        0      0 *:ftp                   *:*                     LISTEN     7361/proftpd: (acce
    tcp        0      0 antec.qualitysid:domain *:*                     LISTEN     7343/named
    tcp        0      0 c-71-231-173-173:domain *:*                     LISTEN     7343/named
    tcp        0      0 localhost.locald:domain *:*                     LISTEN     7343/named
    tcp        0      0 localhost.localdoma:ipp *:*                     LISTEN     20523/cupsd
    tcp        0      0 localhost.localdo:46264 *:*                     LISTEN     4748/hpiod
    tcp        0      0 localhost.localdoma:953 *:*                     LISTEN     7343/named
    tcp        0      0 *:smtp                  *:*                     LISTEN     7297/master
    tcp        0      0 *:microsoft-ds          *:*                     LISTEN     13316/smbd
    tcp        0      0 localhost.localdo:38239 *:*                     LISTEN     4751/python
    tcp        0      0 localhost.localdo:41085 localhost.localdo:46264 ESTABLISHED4751/python
    tcp        0      0 localhost.localdo:46264 localhost.localdo:41085 ESTABLISHED4748/hpiod
    tcp        0      0 antec.qual:microsoft-ds 192.168.1.100:1043      ESTABLISHED13878/smbd
    tcp6       0      0 *:imaps                 *:*                     LISTEN     4891/couriertcpd
    tcp6       0      0 *:pop3s                 *:*                     LISTEN     4932/couriertcpd
    tcp6       0      0 *:pop3                  *:*                     LISTEN     4909/couriertcpd
    tcp6       0      0 *:imap2                 *:*                     LISTEN     4868/couriertcpd
    tcp6       0      0 *:www                   *:*                     LISTEN     7201/apache2
    tcp6       0      0 *:ssh                   *:*                     LISTEN     5357/sshd
    tcp6       0      0 ip6-localhost:953       *:*                     LISTEN     7343/named
    tcp6       0      0 *:smtp                  *:*                     LISTEN     7297/master
    tcp6       0      0 *:https                 *:*                     LISTEN     7201/apache2
    tcp6       0      0 c-71-231-173-173.hs:www ::ffff:192.168.1.1:1054 TIME_WAIT  -
    tcp6       0      0 c-71-231-173-173.hs:www ::ffff:192.168.1.1:1055 TIME_WAIT  -
    tcp6       0      0 c-71-231-173-173.hs:www ::ffff:192.168.1.1:1052 TIME_WAIT  -
    tcp6       0      0 c-71-231-173-173.hs:www ::ffff:192.168.1.1:1053 TIME_WAIT  -
    tcp6       0    148 c-71-231-173-173.hs:ssh ::ffff:192.168.1.1:1052 ESTABLISHED11472/0
    tcp6       0      0 c-71-231-173-173.hs:www ::ffff:192.168.1.1:1050 TIME_WAIT  -
    tcp6       0      0 c-71-231-173-173.hs:www ::ffff:192.168.1.1:1051 TIME_WAIT  -
    tcp6       0      0 c-71-231-173-173.hs:www ::ffff:192.168.1.1:1048 TIME_WAIT  -
    tcp6       0      0 c-71-231-173-173.hs:www ::ffff:192.168.1.1:1049 TIME_WAIT  -
    tcp6       0      0 c-71-231-173-173.hs:www ::ffff:192.168.1.1:1046 TIME_WAIT  -
    tcp6       0      0 c-71-231-173-173.hs:www ::ffff:192.168.1.1:1047 TIME_WAIT  -
    tcp6       0      0 c-71-231-173-173.hs:www ::ffff:192.168.1.1:1045 TIME_WAIT  -
    tcp6       0      0 c-71-231-173-173.hs:www ::ffff:192.168.1.1:1056 TIME_WAIT  -
    tcp6       0      0 c-71-231-173-173.hs:www ::ffff:192.168.1.1:1057 TIME_WAIT  -
    
    I use Ubuntu 6.06.
     
  16. falko

    falko Super Moderator ISPConfig Developer

  17. Dimitriy

    Dimitriy New Member

    Virtuser table:
    Code:
    ###################################
    #
    # ISPConfig virtusertable Configuration File
    #         Version 1.0
    #
    ###################################
    [email protected]    web1_qes
    [email protected]    web1_qes
    [email protected]    web1_qes
    [email protected]    web1_qes
    [email protected]    bensemenyuk
    [email protected]    bensemenyuk
    [email protected]    bensemenyuk
    [email protected]    bensemenyuk
    [email protected]    itsupport
    [email protected]    itsupport
    #### MAKE MANUAL ENTRIES BELOW THIS LINE! ####
    
    The mail log is in ZIP format because I couldnt get the filesize down to 19.5kb.
     

    Attached Files:

  18. till

    till Super Moderator Staff Member ISPConfig Developer

    Please make sure that an A and MX record for antec.qualitysiding.net exists that points to your server.
     
  19. Dimitriy

    Dimitriy New Member

    Am I doing something wrong with my DNS config?

    I cant get the MX records to set as the picture shows whether I only do one or all of them. It keeps on returning me an error of "There was an Error updating the host records."

    BTW, the address is cut off but its "antec.qualitysiding.net"
     

    Attached Files:

    • dns.JPG
      dns.JPG
      File size:
      88.7 KB
      Views:
      148
  20. falko

    falko Super Moderator ISPConfig Developer

    Try
    Hostname: antec
    Record Type: MX
    Address: mail.qualitysiding.net
    Pref: 10
     

Share This Page