Mail not delivered to local domain

Discussion in 'Installation/Configuration' started by PerudoIS, Jul 13, 2010.

  1. PerudoIS

    PerudoIS New Member

    Since an update of the server I have a problem. My mailqueue is growing and mail isn't delivered to <username>@<mydomain>. I can see incoming mail is queued for delivery to the local user but in the mailqueue I only see the count of mails waiting growing. I can't find any suggestions on the internet how to solve and the log files don't give a clear problem.

    postconf -n

    alias_database = hash:/etc/aliases
    alias_maps = hash:/etc/aliases
    append_dot_mydomain = no
    biff = no
    broken_sasl_auth_clients = yes
    config_directory = /etc/postfix
    inet_interfaces = all
    inet_protocols = all
    mailbox_command = procmail -a "$EXTENSION"
    mailbox_size_limit = 0
    mydestination = /etc/postfix/local-host-names
    myhostname =
    mynetworks = [::ffff:]/104 [::1]/128
    myorigin = /etc/mailname
    readme_directory = no
    recipient_delimiter = +
    relayhost = 
    smtp_tls_note_starttls_offer = yes
    smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
    smtp_use_tls = yes
    smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_authenticated_header = yes
    smtpd_sasl_local_domain = 
    smtpd_sasl_security_options = noanonymous
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_auth_only = no
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
    smtpd_tls_session_cache_timeout = 3600s
    smtpd_use_tls = yes
    tls_random_source = dev:/dev/urandom
    Can anybody please help me ?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post the error messages that you get in the mail.log.
  3. PerudoIS

    PerudoIS New Member

    The problem was the load of the server, that problem is solved. But I now have a little other problem. When I send an email to it is delivered to VIRTUALDOMAIN@<server>

    Jul 15 08:39:18 www1 postfix/local[20800]: 84CB9270803: to=<VIRTUALDOMAIN@**servername****, orig_to=<info@*******>, relay=local, delay=0.29, delays=0.28/0/0/0.01, dsn=5.1.1, status=bounced (unknown user: "virtualdomain")
  4. falko

    falko Super Moderator ISPConfig Developer

    Is info listed in /etc/aliases?
  5. PerudoIS

    PerudoIS New Member

    No, info is not listed in /etc/aliases
  6. falko

    falko Super Moderator ISPConfig Developer

    IS the domain part of info@******* listed in /etc/postfix/local-host-names? Is info@******* listed in /etc/postfix/virtusertable? What's in /etc/postfix/
  7. PerudoIS

    PerudoIS New Member

    Problem solved!

    The problem was that I had a few e-mailaddresses on the server mapping to a user with the same name as de domain. In virtusertable the domainname was mapping to VIRTUALDOMAIN so the e-mailwas mapped to VIRTUALDOMAIN@<servername>

    Thank you anyway for your time!

Share This Page