Mail not being delivered (postfix)

Discussion in 'Installation/Configuration' started by adamluz, Jun 5, 2006.

  1. adamluz

    adamluz New Member

    I didn't do any changes, came in to the office this morning andf no e-mails are being delivered. However, no e-mails are being bounced nither. I don't know what to do now.... doesn't seem like there are errors and yet nothing is being delivered, please help postfix mbox and I followed the perfect setup guide to a T for fedora core 4 so thats how my system is setup.
     
  2. davekeogh

    davekeogh New Member

    Postfix config

    Can you copy some of your log files in here, preferably your postfix, and from restart of postfix to up and running...
    Can you also so a netstat -ant and copy in the contents?
     
  3. adamluz

    adamluz New Member

    Okay it looks like its not just my mail. Mail gets delivered just a few hours later. For some reason, the entire machine has started to slow down today. I attempted to login via ssh and the username & password came up pretty quick but then it took a few seconds to get the command line to appear. So I decided to logon to the machine its self and same thing. Websites on the server are running slow remotly, just everything has kinda crapped out. Any help would be great... customers are about to kill me ehhh

    Heres the command top output
    PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
    6069 web43_ad 16 0 23432 20m 2552 S 33.6 1.4 0:01.01 spamassassin
    4631 postfix 16 0 21688 17m 1432 D 1.0 1.1 0:11.36 qmgr
    463 root 15 0 0 0 0 D 0.7 0.0 0:06.46 kjournald
    4624 root 16 0 5660 1636 1352 S 0.7 0.1 0:05.25 master
    5970 postfix 16 0 5796 2060 1724 D 0.7 0.1 0:00.10 local
    5995 postfix 15 0 5796 2048 1724 S 0.7 0.1 0:00.07 local
     
  4. adamluz

    adamluz New Member

    This message appears 20-100 times per second in my mail log

    Jun 5 13:37:30 fc4 postfix/qmgr[3161]: B399A67A221: from=<web43_catch@absz.com>, size=588, nrcpt=1 (queue active)
    Jun 5 13:37:30 fc4 postfix/qmgr[3161]: C6E13A5EDC3: from=<web43_catch@absz.com>, size=588, nrcpt=1 (queue active)
    Jun 5 13:37:30 fc4 postfix/qmgr[3161]: 02AB685955F: from=<web43_catch@absz.com>, size=588, nrcpt=1 (queue active)


    I don't know whats going on. All are the same size... mail bomb maybe? I need to do something asap to speed up the e-mail
     
  5. adamluz

    adamluz New Member

    a bunch of this too

    Jun 5 14:26:30 fc4 postfix/qmgr[4631]: EE22E759E9F: to=<web43_catch@absz.com>, relay=none, delay=588, status=deferred (delivery temporarily suspended: conn$
    Jun 5 14:26:30 fc4 postfix/qmgr[4631]: 9220F85A829: to=<web43_catch@absz.com>, relay=none, delay=656, status=deferred (delivery temporarily suspended: conn$
    Jun 5 14:26:30 fc4 postfix/qmgr[4631]: 0DAA985CF8A: to=<web43_catch@absz.com>, relay=none, delay=611, status=deferred (delivery temporarily suspended: conn$
    Jun 5 14:26:30 fc4 postfix/qmgr[4631]: F183E85AE9F: to=<web43_catch@absz.com>, relay=none, delay=581, status=deferred (delivery temporarily suspended: conn$
    Jun 5 14:26:30 fc4 postfix/qmgr[4631]: 95CD375FCBA: to=<web43_catch@absz.com>, relay=none, delay=670, status=deferred (delivery temporarily suspended: conn$
    Jun 5 14:26:30 fc4 postfix/qmgr[4631]: B8E4285DAC2: to=<web43_catch@absz.com>, relay=none, delay=588, status=deferred (delivery temporarily suspended: conn$
    Jun 5 14:26:30 fc4 postfix/qmgr[4631]: 7F57E85B7F8: to=<web43_catch@absz.com>, relay=none, delay=637, status=deferred (delivery temporarily suspended: conn$
    Jun 5 14:26:30 fc4 postfix/qmgr[4631]: B89FEDFCA50: to=<web43_catch@absz.com>, relay=none, delay=605, status=deferred (delivery temporarily suspended: conn$
    Jun 5 14:26:30 fc4 postfix/qmgr[4631]: 0F56FDF9C83: to=<web43_catch@absz.com>, relay=none, delay=583, status=deferred (delivery temporarily suspended: conn$
    Jun 5 14:26:30 fc4 postfix/qmgr[4631]: 6F98885D6CE: to=<web43_catch@absz.com>, relay=none, delay=600, status=deferred (delivery temporarily suspended: conn$
    J
     
  6. adamluz

    adamluz New Member

    I deleted the account the mail was going to and the log looks like this

    Jun 5 15:05:49 fc4 postfix/qmgr[4631]: D9447E029E1: from=<web43_catch@absz.com>, size=589, nrcpt=1 (queue active)
    Jun 5 15:05:49 fc4 postfix/local[8114]: DA79FDFC949: to=<web43_catch@66-214-254-21.static.lsan.ca.charter.com>, orig_to=<admispconfig@absz.com>, relay=loca$
    Jun 5 15:05:49 fc4 postfix/cleanup[8103]: 6FF1E759BF9: message-id=<20060605220549.6FF1E759BF9@66-214-254-21.static.lsan.ca.charter.com>
    Jun 5 15:05:49 fc4 postfix/local[8159]: DDDC4DFD178: to=<web43_catch@66-214-254-21.static.lsan.ca.charter.com>, orig_to=<web43_catch@absz.com>, relay=local$
    Jun 5 15:05:49 fc4 postfix/qmgr[4631]: DDDC4DFD178: removed
    Jun 5 15:05:49 fc4 postfix/qmgr[4631]: 7FCF785188B: from=<web43_catch@absz.com>, size=588, nrcpt=1 (queue active)
    Jun 5 15:05:49 fc4 postfix/local[8161]: 0236885F935: to=<web43_catch@66-214-254-21.static.lsan.ca.charter.com>, orig_to=<admispconfig@absz.com>, relay=loca$
    Jun 5 15:05:49 fc4 postfix/qmgr[4631]: DA79FDFC949: removed
    Jun 5 15:05:49 fc4 postfix/cleanup[8095]: A270DDFA478: message-id=<20060605220549.A270DDFA478@66-214-254-21.static.lsan.ca.charter.com>
    Jun 5 15:05:49 fc4 postfix/qmgr[4631]: 09B73855EAD: from=<web43_catch@absz.com>, size=588, nrcpt=1 (queue active)
    Jun 5 15:05:49 fc4 postfix/local[8114]: 31F2A75F307: to=<web43_catch@66-214-254-21.static.lsan.ca.charter.com>, orig_to=<admispconfig@absz.com>, relay=loca$
    Jun 5 15:05:49 fc4 postfix/cleanup[8096]: D88AEDFBC7E: message-id=<20060605220549.D88AEDFBC7E@66-214-254-21.static.lsan.ca.charter.com>
    Jun 5 15:05:49 fc4 postfix/local[8159]: 9CA26854E3B: to=<web43_catch@66-214-254-21.static.lsan.ca.charter.com>, orig_to=<admispconfig@absz.com>, relay=loca$
    Jun 5 15:05:49 fc4 postfix/qmgr[4631]: 0236885F935: removed

    still have no clue whats going on
     
  7. adamluz

    adamluz New Member

    Here is a netstat -tap

    [root@fc4 incoming]# netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 *:20000 *:* LISTEN 3157/perl
    tcp 0 0 *:imaps *:* LISTEN 4642/xinetd
    tcp 0 0 *:32769 *:* LISTEN 1983/rpc.statd
    tcp 0 0 *:pop3s *:* LISTEN 4642/xinetd
    tcp 0 0 *:617 *:* LISTEN 2403/arkeiad
    tcp 0 0 *:mysql *:* LISTEN 5033/mysqld
    tcp 0 0 *:pop3 *:* LISTEN 4642/xinetd
    tcp 0 0 *:imap *:* LISTEN 4642/xinetd
    tcp 0 0 *:sunrpc *:* LISTEN 1966/portmap
    tcp 0 0 *:10000 *:* LISTEN 3162/perl
    tcp 0 0 66-214-254-19.static.l:http *:* LISTEN 2884/httpd
    tcp 0 0 66-214-254-20.static.l:http *:* LISTEN 2884/httpd
    tcp 0 0 66-214-254-21.static.l:http *:* LISTEN 2884/httpd
    tcp 0 0 66-214-254-22.static.l:http *:* LISTEN 2884/httpd
    tcp 0 0 *:ftp *:* LISTEN 3107/proftpd: (acce
    tcp 0 0 66-214-254-22.static:domain *:* LISTEN 3078/named
    tcp 0 0 66-214-254-21.static:domain *:* LISTEN 3078/named
    tcp 0 0 66-214-254-19.static:domain *:* LISTEN 3078/named
    tcp 0 0 66-214-254-20.static:domain *:* LISTEN 3078/named
    tcp 0 0 localhost:domain *:* LISTEN 3078/named
    tcp 0 0 localhost:ipp *:* LISTEN 2301/cupsd
    tcp 0 0 localhost:5335 *:* LISTEN 2278/mDNSResponder
    tcp 0 0 localhost:smtp *:* LISTEN 4624/master
    tcp 0 0 localhost:rndc *:* LISTEN 3078/named
    tcp 0 0 localhost:39718 localhost:imap TIME_WAIT -
    tcp 0 0 localhost:39719 localhost:imap TIME_WAIT -
    tcp 0 0 localhost:imap localhost:39714 TIME_WAIT -
    tcp 0 0 localhost:imap localhost:39715 TIME_WAIT -
    tcp 0 0 localhost:51858 localhost:imap TIME_WAIT -
    tcp 0 0 66-214-254-21.static.l:imap ont-cust-208.57.226.19:2911 ESTABLISHED 4683/imapd
    tcp 0 0 localhost:imap localhost:51854 TIME_WAIT -
    tcp 0 0 localhost:imap localhost:51856 TIME_WAIT -
    tcp 0 0 localhost:imap localhost:51857 TIME_WAIT -
    tcp 0 0 localhost:imap localhost:51860 TIME_WAIT -
    tcp 0 0 localhost:smtp localhost:34039 TIME_WAIT -
    tcp 0 0 localhost:smtp localhost:48635 TIME_WAIT -
    tcp 0 0 66-214-254-19.static.l:http 66-214-140-206.dhcp.gl:1747 TIME_WAIT -
    tcp 0 0 66-214-254-19.static.l:http 66-214-140-206.dhcp.gl:1748 TIME_WAIT -
    tcp 0 0 ::1:rndc *:* LISTEN 3078/named
    tcp 0 0 *:https *:* LISTEN 2884/httpd
    tcp 0 0 *:8445 *:* LISTEN 2383/sshd
    tcp 0 0 66-214-254-20.static.l:8445 66-214-254-18.static.l:4422 ESTABLISHED 3644/sshd: adluz [p
     
  8. adamluz

    adamluz New Member

    [root@fc4 incoming]# postsuper -r ALL

    postsuper: Requeued: 170751 messages


    ??? Is that high of a number normal when you host about 20 sites with only a few e-mail accounts? Doesn't seem right to me... ahhh where is everyone... need help. Need to figure out how to make the server move these messages faster
     
  9. adamluz

    adamluz New Member

    tried to reinstall ispconfig thinking it might reconfigure something and then it crashed through install. Now when I start I get

    Executing /etc/rc.d/init.d/ispconfig_server start ..


    Starting ISPConfig system...
    /etc/rc.d/init.d/ispconfig_server: line 45: /root/ispconfig/httpd/bin/apachectl: No such file or directory
    /etc/rc.d/init.d/ispconfig_server: line 47: /root/ispconfig/php/php: No such file or directory
    FreshClam is already running!
    ISPConfig system is now up and running!

    though its not really running. When I go to reinstall its acting like a fresh install rather than an upgrade now.... is there a way to get this to install as a upgrade again and get my system back online... . ahhh everything is a mess
     
  10. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    It seems as if your system is abused by spammers. Make sure you're not an open relay.

    Your problem has nothing to do with ISPConfig...
    Please check the /tmp directory. There should be backups of your last working ISPConfig installation (a tar.gz of /root/ispconfig, a tar.gz of /home/admispconfig, and an SQL dump of the ISPConfig database).
     
  11. adamluz

    adamluz New Member

    Thank you so much for helping me get the ispconfig control panel back up and running. It also started my httpd which wouldn't start. Thats GREAT! :) However, I am looking in to the e-mail problem, I followed the guide to a perfect setup but when I attempt to telnet in I run the ehlo localhost command and I get:

    500 Error: bad syntax

    Any ideas? Also is there a command to make the e-mails process at a faster rate?

    Thank you so much for your help
     
  12. adamluz

    adamluz New Member

    Here's some of mail.cf I think you might need

    readme_directory = /usr/share/doc/postfix-2.2.2/README_FILES
    smtpd_sasl_local_domain =
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    smtpd_tls_auth_only = no
    smtp_use_tls = yes
    smtpd_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom

    Does this look open?
     
  13. adamluz

    adamluz New Member

    Is there anyone willing to login to my server and see if they can get postfix running correctly? I would appriciate it sooo much.. I don't think I can handle these customers much longer. I see nothing in queue yet mail won't deliver for hours later... when i went in to the directory I see loss of files in the queue folders. and today mail started bouncing again and I think smtp stopped.... ehhh

    I reinstalled postfix and still bouncing but I got a ehlo reply thats good

    Trying 127.0.0.1...
    Connected to localhost (127.0.0.1).
    Escape character is '^]'.
    220 66-214-254-21.static.lsan.ca.charter.com ESMTP Postfix
    ehlo localhost
    250-66-214-254-21.static.lsan.ca.charter.com
    250-PIPELINING
    250-SIZE 10240000
    250-VRFY
    250-ETRN
    250-STARTTLS
    250-AUTH LOGIN PLAIN
    250-AUTH=LOGIN PLAIN
    250 8BITMIME

    All domains are in the domain files, all users are configured in the user files, all mapping looks correct... anyone willing to login?

    AIM: litemonkey
    MSN: msn@adamluz.com

    Thanks
    PS. I am extremly deperate right now for any help...
     
    Last edited: Jun 6, 2006
  14. adamluz

    adamluz New Member

    pop3 and imap are running fine... here's the bounce message:

    Technical details of permanent failure:
    PERM_FAILURE: SMTP Error (state 9): 554 <HIDDEN@stricklerins.net>: Relay access denied

    when sending from gmail to my server
     
  15. adamluz

    adamluz New Member

    Okay here is what my mail log looks like. Something about NOQUEUE

    Jun 6 14:41:39 fc4 postfix/smtpd[6179]: NOQUEUE: reject: RCPT from ns1.dipolhosting.com[207.44.130.116]: 554 <hostmaster@absz.com>: Relay access denied; from=<> to=<hostmaster@absz.com> proto=ESMTP helo=<server1.dipolhosting.com>
    Jun 6 14:41:39 fc4 postfix/smtpd[6179]: disconnect from ns1.dipolhosting.com[207.44.130.116]
    Jun 6 14:41:59 fc4 postfix/smtpd[6092]: connect from mta5b.dm-4.com[64.40.98.33]
    Jun 6 14:41:59 fc4 postfix/smtpd[6092]: NOQUEUE: reject: RCPT from mta5b.dm-4.com[64.40.98.33]: 554 <manuel@bgpdesign.com>: Relay access denied; from=<mgm_grand_nightlife@mgmgrand.lasvegas.dm-4.com> to=<manuel@bgpdesign.com> proto=ESMTP helo=<mta5b.dm-4.com>
    Jun 6 14:41:59 fc4 postfix/smtpd[6092]: disconnect from mta5b.dm-4.com[64.40.98.33]
    Jun 6 14:42:43 fc4 postfix/smtpd[6179]: connect from mail26a.sbc-webhosting.com[216.173.237.164]
    Jun 6 14:42:44 fc4 postfix/smtpd[6179]: NOQUEUE: reject: RCPT from mail26a.sbc-webhosting.com[216.173.237.164]: 554 <samantha@stricklerins.net>: Relay access denied; from=<kellyp@monarchexcess.com> to=<samantha@stricklerins.net> proto=SMTP helo=<mail26a.sbc-webhosting.com>
    Jun 6 14:42:44 fc4 postfix/smtpd[6179]: disconnect from mail26a.sbc-webhosting.com[216.173.237.164]


    Here is the mail.cf one more time:


    [root@fc4 ~]# postconf -n
    alias_database = hash:/etc/aliases
    alias_maps = hash:/etc/aliases
    broken_sasl_auth_clients = yes
    command_directory = /usr/sbin
    config_directory = /etc/postfix
    daemon_directory = /usr/libexec/postfix
    debug_peer_level = 2
    html_directory = no
    inet_interfaces = all
    mail_owner = postfix
    mailq_path = /usr/bin/mailq.postfix
    manpage_directory = /usr/share/man
    mydestination = $myhostname, localhost.$mydomain, localhost
    newaliases_path = /usr/bin/newaliases.postfix
    queue_directory = /var/spool/postfix
    readme_directory = /usr/share/doc/postfix-2.2.2/README_FILES
    sample_directory = /usr/share/doc/postfix-2.2.2/samples
    sendmail_path = /usr/sbin/sendmail.postfix
    setgid_group = postdrop
    smtp_tls_note_starttls_offer = yes
    smtp_use_tls = yes
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_local_domain =
    smtpd_sasl_security_options = noanonymous
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_auth_only = no
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    smtpd_use_tls = yes
    tls_random_source = dev:/dev/urandom
    unknown_local_recipient_reject_code = 550
     
    Last edited: Jun 6, 2006
  16. adamluz

    adamluz New Member

    Problem Fixed: After look through this server one other person had the same error as I did but different issue. I was able to look at his config and notied I a missing a lot of things. I added

    virtual_maps = hash:/etc/postfix/virtusertable
    mydestination = /etc/postfix/local-host-names
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases

    To my config which started accepting mail. But I think I am still missing things. I know things are working now but I don't want to get errors in the future. Can someone please look at my config file and let me know what I need to add?

    http://www.absz.com/mail_conf.txt

    The forum which helped me:
    http://www.howtoforge.com/forums/showthread.php?t=3023&page=2
     
  17. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    That link is very slow.
    What's the output of
    Code:
    postconf -d|grep mynetworks
    and
    Code:
    postconf -n|grep mynetworks
    ?
     
  18. adamluz

    adamluz New Member

    [root@fc4 ~]# postconf -d|grep mynetworks
    mynetworks = 127.0.0.0/8 66.214.254.16/29
    mynetworks_style = subnet
    parent_domain_matches_subdomains = debug_peer_list,fast_flush_domains,mynetworks,permit_mx_backup_networks,qmqpd_authorized_clients,relay_domains,smtpd_access_maps
    proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks
    smtpd_client_event_limit_exceptions = ${smtpd_client_connection_limit_exceptions:$mynetworks}
    smtpd_recipient_restrictions = permit_mynetworks, reject_unauth_destination




    [root@fc4 ~]# postconf -n|grep mynetworks
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
     
  19. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    This setting allows the 66.214.254.16/29 subnet to send emails without authentication. Most probably your server is abused by spammers from this subnet.
    Please run
    Code:
    postconf -e 'mynetworks = 127.0.0.0/8'
    and restart Postfix. Then only localhost can send without authentication.
     

Share This Page