Mail Issue - Server name issues

Discussion in 'Installation/Configuration' started by yohon, Jan 13, 2007.

  1. yohon

    yohon New Member

    I am having issues changing my hostname/domain so it is a DNS name that other mail servers can resolve as messages are being bounced.

    Background - E-mail does work if I send to the domains hosted. As well, e-mail can be replied to in round cube webmail just fine. I am using a PHP script on a domain and this is where the problem is occurring. I am trying to send a confirmation to the user that has filled out the form. This is ISPConifg on a Fedora Core 6 Box.

    I know that this is a hostname issue and that is should be an actual domain name appended onto the hostname but right now it is firestorm.localdomain

    hostname -f
    firestorm.localdomain

    cat /etc/hosts
    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1 localhost.localdomain localhost
    10.1.250.5 firestorm.localdomain firestorm

    [root@firestorm postfix]# cat local-host-names
    ###################################
    #
    # ISPConfig local-host-names Configuration File
    # Version 1.0
    #
    ###################################
    localhost
    firestorm.localdomain
    localhost.firestorm.compassit.ca
    localhost.compassit.ca
    localhost.localdomain
    www.compassit.ca
    compassit.ca
    #### MAKE MANUAL ENTRIES BELOW THIS LINE! ####

    If I change the hostname to firestorm.compassit.ca (which is my actual local domain) in etc/hosts and in /etc/postfix/local-host-names then my e-mail doesn't work at all. It says that the type A record could not be found.

    Ok, so here is the mail error before I make the changes to the hostname
    Jan 13 08:13:26 firestorm postfix/smtp[20274]: D784DB016F: to=<rschuet@telus.net>, relay=mx.svc.telus.net[199.185.220.200]:25, delay=0.45, delays=0.11/0.02/0.22/0.1, dsn=4.0.0, status=deferred (host mx.svc.telus.net[199.185.220.200] said: 450 <apache@firestorm.localdomain>: Sender address rejected: Domain not found (in reply to RCPT TO command))


    And here is the error once I change the hostname around to firestorm.compassit.ca and restart postfix:
    Jan 13 08:31:38 firestorm postfix/smtp[20693]: 7EE4AB0170: to=<root@firestorm.localdomain>, orig_to=<apache@firestorm.compassit.ca>, relay=none, delay=0.05, delays=0.01/0/0.04/0, dsn=5.4.4, status=bounced (Host or domain name not found. Name service error for name=firestorm.localdomain type=A: Host not found)

    It seems that something is still looking for firestorm.localdomain but I am not sure where or what other files to configure. (The mail can now be delivered to the ISP's mail system but internal e-mail going to the domain no longer works - same error as above)

    Am I missing some other settings for this or is my thinking off?

    Thanks in advance
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    1) Undo the changes you made in /etc/hosts. There must be a line:

    To solve the isuue, run these commands:

    replace server1.example.com with your full hostname in the above commands.

    Then edit the file /etc/hosts and append the your full domainname to the line:

    10.1.250.5 firestorm.localdomain firestorm

    Then edit postfix main.cf and replace localhost.localdomain with your full hostname. Then restart postfix.
     
  3. yohon

    yohon New Member

    Thanks for the info Till, however, after making the changes you suggested I know get a different error. This is when sending an e-mail outside of the server into a hosted domain.

    Jan 13 13:57:43 firestorm postfix/smtp[25808]: E1B25B0174: to=<rschuett@firestorm.compassit.ca>, orig_to=<rschuett@compassit.ca>, relay=none, delay=0.24, delays=0.16/0/0.08/0, dsn=5.4.6, status=bounced (mail for firestorm.compassit.ca loops back to myself)

    As well Till, I did not have a localhost.localdomain in the postfix main.cf file (output below - nothing shows up for localhost.localdomain)

    [root@firestorm postfix]# cat main.cf | grep localhost
    #inet_interfaces = $myhostname, localhost
    # The default is $myhostname + localhost.$mydomain. On a mail domain
    #mydestination = $myhostname, localhost.$mydomain, localhost
    ##mydestination = $myhostname, localhost.$mydomain, localhost, $mydomain
    ##mydestination = $myhostname, localhost.$mydomain, localhost, $mydomain,


    Any thoughts now?

    Thanks,
     
    Last edited: Jan 13, 2007
  4. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Please add:

    firestorm.compassit.ca

    at the end of the file

    /etc/postfix/local-host-names

    and restart postfix.
     

Share This Page