mail howto+login: imapd: test@<mydoma.in>: No such file or directory

Discussion in 'HOWTO-Related Questions' started by tobo, Nov 17, 2010.

  1. tobo

    tobo New Member

    Hi everyone!

    Yesterday I set up a mail server on a server running Ubuntu 10.04 Server.

    I followed this how to: Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail (Ubuntu 10.04)
    As I dont want a web interface i skipped the last part with SquirrelMail.

    When I try to connect to the mail server using thunderbird i get the message that username or password is wrong and in /var/log/mail.err I can see this:
    Code:
    Nov 17 19:49:59 ks363811 imapd: test@<mydoma.in>: No such file or directory
    Nov 17 19:50:00 ks363811 imapd: test@<mydoma.in>: No such file or directory
    
    (real domain was replaced by <mydoma.in> so thats not the problem ;) )

    As i use virtual users and mysql there is an entry in the domain table with the domain i replaced and there is a user test@<mydoma.in> in the user table.

    I double checked the mysql settings in all that postfix / courier files and tried to find solutions or similar problems on google and the board search but i still cant figure out what i am doing wrong. dont see any mysql error in the mysql logs and dont get why i dont have access to the mail server.

    Any idea?

    Cheers,
    tobo
     
  2. tobo

    tobo New Member

    Hi,

    I finally got a working solution. :)

    After going over and over all the steps described in this HOWTO, I created a dir named "mydoma.in" in /home/vmail/ and a maildir for every user at this domain listed in the mysql user table with maildirmake <username> (without the "@mydoma.in" part as in the user table).
    That allowed me to login and sent mails with thunderbird to foreign mail servers but I wasn't able to receive any mails.

    In mail.info I discovered
    Code:
    postfix/trivial-rewrite[4228]: warning: do not list domain mydoma.in in BOTH mydestination and virtual_mailbox_domains
    Google finally told me the answer: The entry for the domain in the mysql domain table can't be the same as set for mydestination. So i changed mydestination to mail.mydoma.in with
    Code:
    postconf -e 'mydestination = mail.mydoma.in, localhost, localhost.localdomain'
    and
    Code:
    postfix reload
    solved my problem.

    :confused: Can anyone tell me if this is the way it's done or am I just using some kind of workaround? :confused:

    Cheers,
    tobo
     
  3. falko

    falko Super Moderator ISPConfig Developer

    That's the correct solution. :)
     

Share This Page