Mail going to /var/mail

Discussion in 'Installation/Configuration' started by CyberCowboy, Dec 1, 2009.

  1. CyberCowboy

    CyberCowboy New Member

    I followed the perfect server install for Ubuntu 9.04 a while back, everything was working fine until last night when I made a change while on ambien (don't administer servers while on sleep meds) and don't recall the change I made. Now my e-mail appears to be going to /var/mail/<user> and I can't get at it via either IMAP or POP3 (the mail is all there, and if I have to lose that to restore POP and IMAP access I'm ok with that I can print it out for the users)

    I'm fairly new to ISPCONFIG so if you want logs or something please tell me where they are located and I'll get them.
  2. CyberCowboy

    CyberCowboy New Member

    Further information, when I try to send to another user from thunderbird I get the following error message:

    "An error occurred while sending mail. The mail server responded: 5.1.1 <[email protected]>: Recipient address rejected: User unknown in local recipient table. Please check the message recipients and try again."

    the user IS listed in ISPConfig so I'm guessing I somehow switched the thing over to using the internal unix mail system.
  3. falko

    falko Super Moderator ISPConfig Developer

    Any errors in /var/log/mail.log?
    What's in /etc/postfix/
  4. CyberCowboy

    CyberCowboy New Member

    Sorry should have closed this out, I figured out the problem was that I had deleted my co-domain and that's what killed it.... recreated and away I went.
  5. sjau

    sjau Local Meanie Moderator

    paste your postfix config please
  6. MUD

    MUD New Member

    I am having the same issue, using CentOS 5.4 x86, I noticed my
    /var/www/ was not created after i've setup a user/admin account within a domain.

    here is my main.conf
    tailed /var/log/mail.log and got
  7. falko

    falko Super Moderator ISPConfig Developer

    What's in /etc/aliases? I guess info is an alias for root?
  8. MUD

    MUD New Member

    Yes thanks I removed them and now I get

    local-host-names has:
    virtusertable has: [email protected] vdomain.ca_info

    but my mail is getting delivered to: /var/mail/vdomain.ca_info
    Last edited: Feb 16, 2010
  9. MUD

    MUD New Member


    Just went into the panel of ISPConfig and Management -> Server -> Settings -> E-Mail tab -> Maildir and checked the box, she'll all good now!

Share This Page