mail from server not sending because main domain is not hosted by ispconfig

Discussion in 'Installation/Configuration' started by plathw, Oct 11, 2007.

  1. plathw

    plathw New Member

    We have several different websites. Our main website (www.site.com) is hosted on another box but several other sub domains (site1.site.com, site2.site.com, etc) are hosted on an ispconfig box.

    We noticed that we were not getting mail sent by forms on the sub domain sites hosted on our ispconfig box. We checked the error log and saw that it was looking for the main domain, and since it is not hosted on that box, it would just give an error and not send.

    To fix this we removed "site.com" from etc/postfix/local-host-names and then mail was being sent fine. But, every time you interact with the admin panel, it adds "site.com" back into the local-host-names file. Any ideas how to stop this?
     
  2. dysolve

    dysolve New Member

    I had a similar problem, so I changed the smtp server to my ISP's one and it was all good..
     
  3. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    The solution is to set "site.com" to external mailserver under options in the co-domian settings in ISPConfig.
     
  4. bigbeat

    bigbeat New Member

    ispconfig box with remotely hosted MX... not able to receive mail

    Hello,

    I'm having the same problem mentioned above. I took the action described and set both the domain and sub-domain to "external mailserver." Still not receiving mail.

    Any help would be greatly appreciated.
     
  5. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Is the domain/hostname in question still listed in /etc/postfix/local-host-names?
     
  6. bigbeat

    bigbeat New Member

    falko,

    Thank you very much for your reply. No, I removed the domain in question from the local-host-names file right from the beginning. I have a couple of other servers and whenever I point MX records for a domain to a remote location, I always remove the domain entry in the local-host-names file, and the server ceases trying to deliver mail locally. But it doesn't appear to work the same way with the ispconfig server.

    Any other suggestions?

    In ISP Manager > sites > domainname, I have the "Create DNS-MX" unchecked. Is that the way it should be?

    There are no MX records setup for the domain in "DNS Manager." Is that the way it should be?

    Thank you again for your willingness to help. This forum is a great resource and very appreciated.
     
  7. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    This is useless, as ISPConfig will add it again.

    What you missed is to to set the domain and co-domain to external mailserver in ispconfig. If you enable o diable MX has no influence on this. MX is for DNS only.
     
  8. bigbeat

    bigbeat New Member

    till, in my first post above, I mentioned that I have already done this...

    I took the action described and set both the domain and sub-domain to "external mailserver." Still not receiving mail.

    Any other ideas?

    Thanks
     
  9. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Ok, you set the domain and co-domain to external mailserver and the domain is still listed in the file /etc/postfix/local-host-names ?
     
  10. bigbeat

    bigbeat New Member

    The domain has been set to external mail server, but the domain name is no longer listed in the local-host-names file. I removed it from there. Should I not have removed it?

    Thank you
     
  11. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    If it was still there after you set the domain to external mailsverer, then you set the wrong domain to external mailserver and ispconfig will add the domain again. Please check again that you have set the co-domains all to external mailsver too. E.g. maybe you added a co-domain to another website.
     
  12. bigbeat

    bigbeat New Member

    till, I'm confident that the drop down menu is set to "external mailserver" on both the "domain options" and the "co-domain options."

    Any idea where I go from here?

    Thank you!
     
  13. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    What's the output of
    Code:
    ls -la /root/ispconfig
    ? Are there any warnings in /home/admispconfig/ispconfig/ispconfig.log?
     

Share This Page