Mail forwarding to gmail inconsistent

Discussion in 'Installation/Configuration' started by vincentthe, Jan 2, 2007.

  1. vincentthe

    vincentthe New Member

    Hi,

    I have quite a strange problem on my hands. Several mail addresses are setup to forward to ...@gmail.com (and keep a copy).

    Somehow some messages are being forwarded but the majority is not. All mail does arrive in the mailbox, so I think the problem should reside on our server.

    Any pointers at all on how to trace the problem?

    Thanks in advance
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Mail is forwarded by a procmail recipe which is in the user home folder, I guess there is the best point to start debugging. Any errors in your mail log?
     
  3. vincentthe

    vincentthe New Member

    I can't find any errors in /var/log/mail.err relating to procmail.

    Is there a specific procmail recipe for forwards?

    I see the following files in /var/www/<...>/user/<username> (ls -al)
    .antivirus.rc
    .autoresponder.rc
    .html-trap.rc
    .local-rules.rc
    .mailsize.rc
    .quota.rc
    .spamassassin.rc
    .user_prefs
    .vacation.msg
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Which ISPConfig version do you have installed?
     
  5. vincentthe

    vincentthe New Member

    ISPConfig
    Version: 2.2.7
    (c) ISPConfig 2007
     
  6. falko

    falko Super Moderator ISPConfig Developer

    The forwarding is done by the .forward file in the user's homedir, so procmail isn't even called.

    What's in your mail log when you send a mail to a user that has his mails forwarded to Gmail?
    Also, please check if your server got blacklisted: http://www.mxtoolbox.com/blacklists.aspx
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Falko is right for your version. The latest dev versions are using procmail instead.
     
  8. vincentthe

    vincentthe New Member

    contents of the .forward
    "|/usr/bin/procmail -f-", [email protected]

    settings in the webpanel
    keep copy
    forward to [email protected]

    Mail log contents
    Jan 5 10:33:55 ds2 postfix/local[22703]: D1CCE27583EC: to=<[email protected]>, orig_to=<[email protected]>, relay=local, delay=5, status=sent (delivered to command: /usr/bin/procmail -f-)
    Jan 5 10:33:55 ds2 postfix/cleanup[22702]: 73DB227583ED: message-id=<[email protected]>
    Jan 5 10:33:55 ds2 postfix/qmgr[10026]: 73DB227583ED: from=<[email protected]>, size=6746, nrcpt=1 (queue active)
    Jan 5 10:33:55 ds2 postfix/local[22703]: D1CCE27583EC: to=<[email protected]>, orig_to=<[email protected]>, relay=local, delay=5, status=sent (forwarded as 73DB227583ED)
    Jan 5 10:33:55 ds2 postfix/qmgr[10026]: D1CCE27583EC: removed
    Jan 5 10:33:55 ds2 postfix/smtp[22673]: 73DB227583ED: to=<[email protected]>, orig_to=<[email protected]>, relay=gmail-smtp-in.l.google.com[66.249.93.114], delay=0, status=sent (250 2.0.0 OK 1167989623 39si29433033ugb)
    Jan 5 10:33:55 ds2 postfix/qmgr[10026]: 73DB227583ED: removed
     
  9. falko

    falko Super Moderator ISPConfig Developer

    These settings are fine.

    I don't see a problem in this log excerpt.
     
  10. vincentthe

    vincentthe New Member

    I couldn't find anything either, it seems though that the problems are disappearing and that more and more (old) messages are getting through. Maybe it's a gmail filter that's in the way.
     

Share This Page