Mail filter setup - epic fail

Discussion in 'Installation/Configuration' started by jbryner, Jul 23, 2009.

  1. jbryner

    jbryner New Member

    ok, so I have been trying to get mail moved to a folder called SPAM for an email account hosted on my ISPConfig 3 server.

    I created the mail folder SPAM in the Squirrelmail login, and it shows up no worries.

    I created a filter for mymail@mydomain.com and named it Move SPAM

    for the source line I have set up

    Subject Contains ***SPAM***

    for action, it is set to Move to SPAM (I have also tried .SPAM, and Inbox.SPAM)

    and had no luck.

    So I found an article about esc characters with the * character, so I tried filtering for \*\*\*SPAM\*\*\* as it was specified, with all the same settings as above.

    again, no luck at all. All mail with ***SPAM*** in subject line goes straight into the inbox.

    Any suggestions? Help? Laughter? Anything at this point would be great.

    Thanks in advance, and other than frustration caused mostly by my newness to linux, I have to say that ISPConfig 3 is pretty darn cool.

    Jeff

    ok, so things have been solved.

    1. Dont create the folder, let ISPConfig create it, name it in the filter, and it will show up next time you connect via imap.

    2. Add the filter as "Subject" "Contains" and enter ***SPAM*** without the "\"s. (as you check this in the custom rule tab, they will be there.

    3. The key is to give it enough time to take effect. My installation took about 15 minutes to finally come around and start filtering. I'm not sure why, but I'd be willing to bet there's a good reason for it.

    That's all there is to it, it works, and can be set up that way on any individual mail account.

    Hope this helps someone, and again, thank you all that have helped me stumble through this liearning process.
     
    Last edited: Jul 23, 2009
  2. till

    till Super Moderator

    The settings are applied after about 60 seconds. You can check in the queue of the monitor if a change has been applied already.
     

Share This Page