Mail filter not working right (at least begins rule)

Discussion in 'Installation/Configuration' started by simonit, Mar 24, 2015.

  1. simonit

    simonit New Member

    Hi, if I add mail filter to move emails to specific folder based on senders address it will create incorrect rules.
    if header :regex ["from"] [" fail2ban"] {
    fileinto "Ilmot";
    ### END FILTER_ID:8

    There is empty space before fail2ban, and it will not work right because of that. (work around is remove space manually from custom rule code -tab)
    Is this a bug?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    I dont get that whitespace here. Which ISPConfig version do you use and which exact rule settings?
  3. simonit

    simonit New Member


    See the attachments and there is empty space. Second image is how it appears in GUI in mail filter rule. I think because of this empty space in rule it wont work.

    I like to filter emails from starting with "root" to Ilmot-folder. Is there reason why ISPconfig adds empty spaces before rules? Because after removing empty spaces manually the rules started working.

    My version is: ISPConfig (Ubuntu 14.04.2 LTS (Trusty Tahr))

    Attached Files:

    Last edited: Mar 25, 2015

Share This Page