Mail errors "can't recieve"

Discussion in 'Installation/Configuration' started by uthemang, Dec 21, 2009.

  1. uthemang

    uthemang New Member

    Hi I am getting these mail error messages:

    I can send mail but not recieve mail. I think it may be a relay problem.

    Here is my main.cf

    Here is my master.cf

    Thanks for any input.
     
  2. falko

    falko Super Moderator ISPConfig Developer

    What's in /etc/mailname and /etc/hosts?
     
  3. uthemang

    uthemang New Member

    Here is /etc/hosts:

    Here is /etc/mailname;

    I've changed the mailname from cm1.solutionnet.ca
    Neither worked.

    Thanks for the reply.
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Is 142.165.61.9 your server's public IP, or is that a different server?
     
  5. uthemang

    uthemang New Member

    Yes, that's my IP.
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Can you change /etc/hosts to
    Code:
    127.0.0.1 localhost.localdomain localhost
    [B][COLOR="Red"]142.165.61.9 cm1.solutionnet.ca cm1[/COLOR][/B]
    192.168.1.2 webmail.solutionnet.ca localhost
    
    # The following lines are desirable for IPv6 capable hosts
    ::1 ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts 
    ?
     
  7. uthemang

    uthemang New Member

    Hi, I changed the hosts record and am still not recieving.
    The logs are not showing the errors messages anymore??

    My /etc/postfix directory seems odd to me though, should there be copies of the files? ex. main.cf, main.cf~, main.cf~2 ?

    This has happened in other directories too ex. /etc/mydns.conf, /etc/mydns.conf~

    I am not getting an undeliverable message from the account I send it from either. Seems like the mail is being delivered somewhere.
     
  8. falko

    falko Super Moderator ISPConfig Developer

    Please check if the MX record is pointing to the correct server:
    Code:
    dig mx yourdomain.com
     
  9. uthemang

    uthemang New Member

    Code:
    ; <<>> DiG 9.4.2-P2 <<>> mx solutionnet.ca
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 5191
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 3, AUTHORITY: 3, ADDITIONAL: 4
    
    ;; QUESTION SECTION:
    ;solutionnet.ca.                        IN      MX
    
    ;; ANSWER SECTION:
    solutionnet.ca.         300     IN      MX      1 mail.solutionnet.ca.
    solutionnet.ca.         300     IN      MX      1 webmail.solutionnet.ca.
    solutionnet.ca.         300     IN      MX      1 142.165.61.9.
    
    ;; AUTHORITY SECTION:
    solutionnet.ca.         74252   IN      NS      ns3.mdnsservice.com.
    solutionnet.ca.         74252   IN      NS      ns2.mdnsservice.com.
    solutionnet.ca.         74252   IN      NS      ns1.mdnsservice.com.
    
    ;; ADDITIONAL SECTION:
    mail.solutionnet.ca.    300     IN      A       142.165.61.9
    webmail.solutionnet.ca. 300     IN      A       142.165.61.9
    ns1.mdnsservice.com.    500     IN      A       216.40.47.18
    ns2.mdnsservice.com.    925     IN      A       64.98.148.11
    
    ;; Query time: 95 msec
    ;; SERVER: 142.165.200.5#53(142.165.200.5)
    ;; WHEN: Mon Dec 28 12:42:09 2009
    ;; MSG SIZE  rcvd: 238
    
    I received e-mails for 1 week after settup then they stopped?

    Thanks for your replys.
     
  10. falko

    falko Super Moderator ISPConfig Developer

    An MX record must always point to an A record, not to an IP address. Please delete that record.
     

Share This Page