mail.domain.de showing appache standard install site

Discussion in 'Installation/Configuration' started by conny2540, Sep 11, 2018.

  1. conny2540

    conny2540 Member

    Seems I have made a wrong mail configuration on my ispconfig 3.1.13.
    First of all it is possible to call my site by mail.domain.de.
    Second when I type the URL named before, than the apache standard configuraton site is showing, What is wrong ? I don't want the it is possible to call mail.domain.com for my site, furthermore how to remove the apache standard configuration site, by forbid to call this URL ? I'm using imap.domain.de for to receive mails.

    My domains are reversed directly on DNS server to the IP of my ispconfig server. Is there an error ? This was the same I was using before with Plesk. Is there any configuration step I missed for ispconfig ? Mailboxes are working. I discovered that now it is possible to call mail.domain.de today after checking suspected serverlogs.
     
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Create a new website with name 0000aaaa.domain.com. Make index.html in that website, write in it something about it being new default website.
    Does your server now work better?
     
  3. conny2540

    conny2540 Member

    Unfortunately this does not solve the problem.

    I have two domains working on this server with ispconfig. For both I have the same problem. Any user on the net is able to open the sites with subdomain prefix "mail" or "imap" as subdomain (mail.domain.de). On no place I have created a subdomain "mail" or "imap" for both domains.

    My troubleshoot was to rename the index.html at /var/www/html on my server and create an new index.html with own content (service not availabe). Now when I call the domains mail.domain(1 or 2).de or imap.domain(1 or 2).de I see my index.html with own content.
    Server is ubuntu 16.04.

    My preference to solve this problem is rather to disable or forbid the call of URL's with mail/imap.domain.de for domain 1 and 2, but I don't know how I can manage this with ispconfig. My solution will also affect clients sites when I decide to host customer sites.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    You must have created dns record for these subdomains or a wildcard DNS record when someone is able to reach your server by entering that domain name. Remove these dns records from DNS if you don't want to use them and if you have a wildcard record, then remove the wildcard and just add the subdomains you really use for the domains like www.

    But be aware that dns records are used by all services, so when you want to have imap.domain.tld to use it in your mail client, then you can not remove that record, instead, you use a default vhost either in the way that @Taleman explained or in the alternative way you used now.
     
  5. conny2540

    conny2540 Member

    Hi Till,
    sorry but it is not really clear what you mean. Some entries on DNS Panel where made from provider, I only added my server IP there. So what is wrong there ? I cannot see any wildcard with mail or imap there. Before I installed ispconfig I was using Plesk and hadn't this problem. Perhaps there is one wrong setting I've done on ispconfig. Please can you tell me where I can check and give me an advise for how to change.

    vhost - well I now understand that with the actual configuration I will not be able to host customers sites. Actually I'm not using vhost. As both domains are my own sites, I simply added domains and mailboxes to ispconfig.
    upload_2018-9-12_10-36-59.png
     
  6. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Since you do not reveal what your domain name is, it is not possible to check what settings it has. So the following is just guessing and trying to show you how you can check yourself. This would be much easier if you told what the actual domain name is.
    If writing mail.domain.de takes you to your webserver, then either there is that name in DNS name service, or your workstation has that name in its hosts file. https://en.wikipedia.org/wiki/Hosts_(file)
    Check the first with
    Code:
    host mail.domain.de
    Check the latter by reading or grepping what is inside the hosts file.
     
  7. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Besides, like @till suspected, looks like you have a wildcard record. The Mail Server Eintr├Ąge shows * in the hostname field.
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    You have a wildcard record as I suspected and @Taleman pointed out. A wildcard is the * record, which means that you point any subdomain to your server and that's what causes the issue. Delete that record in DNS and add only these records, that you want to use.

    That's completely wrong. Your current configuration is ready to host any kind of websites, no matter if you own them yourself or one of your customers own it. And when you point a domain in DNS to a server, then any network application can use the IP from DNS record to contact your server and when you enter a subdomain that you configured in DNS, in your case by adding a wildcard record, in the browser, then it will contact your server and ask apache for a matching website and if there is no matching website (as you did not add it), apache shows its default page. So your server behaves exactly as it should behave with the configuration you made.
     

Share This Page