Mail does not send mail

Discussion in 'Installation/Configuration' started by WI88, Jun 22, 2018.

  1. WI88

    WI88 New Member

    Hi & sorry for my English.
    I have pppoe conection. white ip.
    I have a few questions:
    1. I installed webserver - howtoforge_com/tutorial/perfect-server-ubuntu-16.04-with-apache-php-myqsl-pureftpd-bind-postfix-doveot-and-ispconfig/, I Installed wordress and found that I can not recover the password by the form of recovery (the letter does not come to mail)
    2. I think the web server is working, but the mail does not send mail. (maybe postfix...I'm new to Linux and ISP Config)
    Mail-log (isp config monitor): Screenshot_1
    Mail Queue (isp config monitor): Screenshot_2
    System Log: Screenshot_3
    Help please...
     

    Attached Files:

  2. maudam

    maudam New Member

    Connectivity or dns or firewall problem ?
    Test these commands from shell:
    ping gmail-smtp-in.l.google.com
    ping 64.233.167.26
    telnet gmail-smtp-in.l.google.com 25
    telnet 64.233.167.26 25
    and post results
     
  3. WI88

    WI88 New Member

    hi,

    [email protected]:~$ ping gmail-smtp-in.l.google.com
    PING gmail-smtp-in.l.google.com (74.125.71.26) 56(84) bytes of data.
    64 bytes from wn-in-f26.1e100.net (74.125.71.26): icmp_seq=1 ttl=48 time=48.8 ms
    64 bytes from wn-in-f26.1e100.net (74.125.71.26): icmp_seq=2 ttl=48 time=48.7 ms
    64 bytes from wn-in-f26.1e100.net (74.125.71.26): icmp_seq=3 ttl=48 time=48.7 ms
    64 bytes from wn-in-f26.1e100.net (74.125.71.26): icmp_seq=4 ttl=48 time=48.8 ms
    64 bytes from wn-in-f26.1e100.net (74.125.71.26): icmp_seq=5 ttl=48 time=48.8 ms
    64 bytes from wn-in-f26.1e100.net (74.125.71.26): icmp_seq=6 ttl=48 time=48.8 ms
    ^C
    --- gmail-smtp-in.l.google.com ping statistics ---
    6 packets transmitted, 6 received, 0% packet loss, time 5009ms
    rtt min/avg/max/mdev = 48.760/48.799/48.847/0.256 ms
    [email protected]:~$ ping 64.233.167.26
    PING 64.233.167.26 (64.233.167.26) 56(84) bytes of data.
    64 bytes from 64.233.167.26: icmp_seq=1 ttl=46 time=46.4 ms
    64 bytes from 64.233.167.26: icmp_seq=2 ttl=46 time=46.5 ms
    64 bytes from 64.233.167.26: icmp_seq=3 ttl=46 time=46.3 ms
    64 bytes from 64.233.167.26: icmp_seq=4 ttl=46 time=46.3 ms
    64 bytes from 64.233.167.26: icmp_seq=5 ttl=46 time=46.5 ms
    ^C
    --- 64.233.167.26 ping statistics ---
    5 packets transmitted, 5 received, 0% packet loss, time 4006ms
    rtt min/avg/max/mdev = 46.312/46.440/46.585/0.255 ms
    [email protected]:~$ telnet gmail-smtp-in.l.google.com 25
    Trying 74.125.71.26...
    Trying 2a00:1450:400c:c02::1a...
    telnet: Unable to connect to remote host: Network is unreachable
    [email protected]:~$ telnet 64.233.167.26 25
    Trying 64.233.167.26...
    telnet: Unable to connect to remote host: Connection timed out

    Do you mean the port of 25 calls?
    Firewall on my ubuntu server 16.04. I set up the instructions. - "perfect-server..."
    The local network has a DNS server that is configured by a network administrator. But I'm not a network administrator, should I contact your ISP?
    Also, I tried to specify a dns server 8.8.8.8 instead of a local one...
     
  4. maudam

    maudam New Member

    Network and Dns are ok.
    You cannot reach port 25 (and probably ports 587 and 465)
    This can be a provider block or a locar router block or your firewall on the ubuntu box.
    Disable the firewall and test it again
     
  5. WI88

    WI88 New Member

    Thank you, I will contact the provider.
    ...Also in the logs:
    /var/log/mail.err
    Code:
    Jun 22 00:01:59 server2 postfix[2588]: error: to submit mail, use the Postfix sendmail command
    Jun 22 00:01:59 server2 postfix[2588]: fatal: the postfix command is reserved for the superuser
    Jun 22 00:02:11 server2 postfix[5470]: fatal: usage: postfix [-c config_dir] [-Dv] command
    Jun 22 13:22:06 server2 dovecot: imap-login: Error: SSL: Stacked error: error:1407609C:SSL routines:SSL23_GET_CLIENT_HELLO:http request
    Jun 22 13:22:06 server2 dovecot: imap-login: Error: SSL: Stacked error: error:1408A10B:SSL routines:ssl3_get_client_hello:wrong version number
    
    What it means?
     
  6. WI88

    WI88 New Member

    Ні,
    I Configure Postfix to Use Gmail SMTP on Ubuntu - https://easyengine.io/tutorials/linux/ubuntu-postfix-gmail-smtp/
    Mail is sent but The log (mail.err) contains :

    Code:
    Jun 25 02:54:04 server2 dovecot: pop3-login: Error: SSL: Stacked error: error:1408F10B:SSL routines:SSL3_GET_RECORD:wrong version number
    Jun 25 15:24:32 server2 dovecot: pop3-login: Error: SSL: Stacked error: error:140760FC:SSL routines:SSL23_GET_CLIENT_HELLO:unknown protocol
    Jun 25 15:24:33 server2 dovecot: pop3-login: Error: SSL: Stacked error: error:1408A10B:SSL routines:ssl3_get_client_hello:wrong version number
    Jun 26 18:41:16 server2 dovecot: imap-login: Error: SSL: Stacked error: error:140760FC:SSL routines:SSL23_GET_CLIENT_HELLO:unknown protocol
    Jun 26 18:41:17 server2 dovecot: imap-login: Error: SSL: Stacked error: error:1408A10B:SSL routines:ssl3_get_client_hello:wrong version number
    Jun 27 15:37:47 server2 postfix/smtp[28687]: error: open database /etc/postfix/sasl_passwd.db: No such file or directory
    Jun 27 15:39:27 server2 postfix[28814]: error: to submit mail, use the Postfix sendmail command
    Jun 27 15:39:27 server2 postfix[28814]: fatal: the postfix command is reserved for the superuser
    Jun 27 16:54:30 server2 postfix[10647]: error: to submit mail, use the Postfix sendmail command
    Jun 27 16:54:30 server2 postfix[10647]: fatal: the postfix command is reserved for the superuser
    Jun 27 16:58:50 server2 postfix[11010]: error: to submit mail, use the Postfix sendmail command
    Jun 27 16:58:50 server2 postfix[11010]: fatal: the postfix command is reserved for the superuser
    Are these old notes? What are the mistakes? fatal? error? Can І ignore?
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    A relay server is normally not configured in the way you did it with that tutorial on ISPConfig systems. In ISPConfig, you just login to the control panel, go to system > server config > mail and enter the relay server, user and password and press save. Your config should probably work nonetheless, it just might not be update safe and it#s unnecessarily complicated.

    In regard to your error, you might have missed this step:

    postmap /etc/postfix/sasl_passwd
     

Share This Page