Mail directory problem need help

Discussion in 'Installation/Configuration' started by tkp1969, Mar 17, 2009.

  1. tkp1969

    tkp1969 New Member

  2. falko

    falko Super Moderator ISPConfig Developer

    What's in your mail log when you send a welcome message?
     
  3. Flash

    Flash New Member

    You should send a message to the user which will create the home directory. If that does not work, indeed send mail log as said above.
     
  4. tkp1969

    tkp1969 New Member

    today I try install on ubuntu 8.04 and found problem too.

    mylog

    mypostfix config

    regards.
     
  5. falko

    falko Super Moderator ISPConfig Developer

    Please add mail.npru.ac.th to mydestination in your main.cf and restart Postfix.
     
  6. tkp1969

    tkp1969 New Member

    main.cf in postfix

     
  7. falko

    falko Super Moderator ISPConfig Developer

    Did you restart Postfix?
     
  8. tkp1969

    tkp1969 New Member

    Sure I restart postfix and restart the server. When I test mailx again the problem is same.
    I test implement the server with ubuntu 8.10, debian 4.0 and debian 5.0 again but, this same.
     
  9. falko

    falko Super Moderator ISPConfig Developer

    What are the outputs of
    Code:
    hostname
    and
    Code:
    hostname -f
    , and what's in /etc/hosts and /etc/mailname?

    BTW, does this look correct?

    Code:
    mh1:~# dig mail.npru.ac.th
    
    ; <<>> DiG 9.3.4 <<>> mail.npru.ac.th
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 5796
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;mail.npru.ac.th.               IN      A
    
    ;; ANSWER SECTION:
    mail.npru.ac.th.        38400   IN      CNAME   mail2.npru.ac.th.
    mail2.npru.ac.th.       38400   IN      A       202.29.9.47
    
    ;; Query time: 670 msec
    ;; SERVER: 145.253.2.75#53(145.253.2.75)
    ;; WHEN: Tue Mar 24 18:02:12 2009
    ;; MSG SIZE  rcvd: 69
    
    mh1:~#
     
  10. tkp1969

    tkp1969 New Member

    hostname and hostname -f
    in /etc/host
    in /etc/mailname
    This you see is correct, but when dig mail.npru.ac.th, I configure mail.npru.ac.th into my dns server, I remove old mail in my dns and reconfigure agian this show

    when I test again mail.log this show
    and I don't understand mail.log show
     
    Last edited: Mar 27, 2009
  11. falko

    falko Super Moderator ISPConfig Developer

    Code:
    mh1:~# dig mail.npru.ac.th
    
    ; <<>> DiG 9.3.4 <<>> mail.npru.ac.th
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 51856
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;mail.npru.ac.th.               IN      A
    
    ;; ANSWER SECTION:
    mail.npru.ac.th.        38400   IN      CNAME   mail2.npru.ac.th.
    mail2.npru.ac.th.       38400   IN      A       202.29.9.47
    
    ;; Query time: 534 msec
    ;; SERVER: 145.253.2.75#53(145.253.2.75)
    ;; WHEN: Fri Mar 27 15:15:08 2009
    ;; MSG SIZE  rcvd: 69
    
    mh1:~#
    I'm still seeing the wrong IP, so maybe something went wrong in your DNS configuration.

    BTW, MX records must point to A records, not to CNAME records:

    Code:
    mh1:~# dig mx mail.npru.ac.th
    
    ; <<>> DiG 9.3.4 <<>> mx mail.npru.ac.th
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 43883
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 3, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;mail.npru.ac.th.               IN      MX
    
    ;; ANSWER SECTION:
    mail.npru.ac.th.        38375   IN      [B][COLOR="Red"]CNAME[/COLOR][/B]   mail2.npru.ac.th.
    mail2.npru.ac.th.       38400   IN      MX      40 ppcatmast.cattelecom.com.
    mail2.npru.ac.th.       38400   IN      MX      50 ppcatagt.cattelecom.com.
    
    ;; Query time: 258 msec
    ;; SERVER: 145.253.2.75#53(145.253.2.75)
    ;; WHEN: Fri Mar 27 15:15:33 2009
    ;; MSG SIZE  rcvd: 118
    
    mh1:~#
    Please change that.

    You cannot use mail.npru.ac.th as a virtual domain in the databasse if this is the hostname of the server at the same time. Either rename the server or use a different domain in the database.
     
  12. tkp1969

    tkp1969 New Member

    This now I change dns record to correct

    when dig mx npru.ac.th this now show

    dig mx mail.npru.ac.th
    when I test mailx again mail.log show
     
  13. falko

    falko Super Moderator ISPConfig Developer

    You cannot use mail.npru.ac.th as a virtual domain in the databasse if this is the hostname of the server at the same time. Either rename the server or use a different domain in the database.
     

Share This Page