mail delivery failed

Discussion in 'Installation/Configuration' started by crypted, Nov 14, 2007.

  1. crypted

    crypted New Member

    Okay, I haven't tried adding a mail account in several months but now it seems broken...

    [email protected] should be working just fine. I can login to the account via POP3 and send email with the account login information via SMTP. However, any mail sent from other email accounts to that account isn't being delivered and is always returned.


    /var/log/maillog

    Nov 14 02:44:55 its pop3-login: Disconnected [::ffff:32.147.226.191]
    Nov 14 02:45:17 its pop3-login: Login: web3_mobile [::ffff:32.147.79.137]
    Nov 14 02:45:49 its postfix/smtpd[6753]: connect from mailhost.domain2.tld[130.184.5.66]
    $pient table; from=<[email protected]> to=<[email protected]> proto=ESMTP helo=<mailhost.domain2.tld>
    Nov 14 02:45:50 its postfix/smtpd[6753]: disconnect from mailhost.domain2.tld[130.184.5.66]
    Nov 14 02:46:06 its pop3-login: Login: web3_mobile [::ffff:32.147.175.207]
    Nov 14 02:46:37 its pop3-login: Login: web3_derek [::ffff:70.178.214.97]

    /var/mail/
    -rw------- 1 web3_mobile mail 0 Nov 14 02:41 web3_mobile
    -rw------- 1 web3_webmaster mail 14K May 9 2007 web3_webmaster

    The ISPConfig administration page shows it setup as:
    web3_mobile mobile mobile 0 0
    There is a 20MB web space and 20MB mail allocation. I had spam filtering on DENY but later turned all of those filters off just in case.

    Email sent from one of the POSTMAILER FAILURES:
    Hi. This is the qmail-send program at yahoo.com.
    I'm afraid I wasn't able to deliver your message to the following addresses.
    This is a permanent error; I've given up. Sorry it didn't work out.

    <[email protected]>:
    207.150.163.xxx does not like recipient.
    Remote host said: 550 <[email protected]>: Recipient address rejected: User unknown in local recipient table Giving up on 207.150.163.xxx.


    Any help would greatly be appreciated! I did reboot the box and all of the daemons many times... Thanks.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Do other email accounts that belong to the same domain work?
     
  3. brainz

    brainz Member

    Whats in /etc/postfix/local-host-names and whats in /etc/postfix/virtusertable ????

    or atleast [email protected] in virtusertable should look something like this...

    [email protected] web3_mobile
    [email protected] web3_mobile

    and in the local-host-names you should see this

    www.domain.tld and domain.tld for that domain...



    Regards
    brainz
     
    Last edited: Nov 14, 2007
  4. crypted

    crypted New Member

    Yes the one other email account for this particular domain function.

    local-host-names
    localhost
    its.inter5.org
    localhost.its.inter5.org
    localhost.inter5.org
    localhost.localdomain
    www.domain.tld
    domain.tld

    the virtual-table is screwed up...

    [email protected] web3_mobile
    [email protected] web3_mobile
    [email protected] web3_mobile
    [email protected] web3_mobile

    However, I added that email on the domain.tld area of the ISPConfig admin. it also assigned the correct web#. domain.tld = web3, domain5.tld = web49

    Do I just change the virtual-table from domain5.tld to domain.tld? But why would ISPConfig have set it up incorrectly?
     
  5. brainz

    brainz Member

    This is fine.....
    This is definatly wrong....

    My advice to you with regards to fixing the problem would be as follows...

    add this to the virtusertable...

    [email protected] web3_mobile
    [email protected] web3_mobile

    and see if works...

    if not

    Then i would delete email accounts [email protected] and [email protected] .. make sure you delete the email accounts out of the recycle bin...

    Then i would recreate the email account [email protected] only... see if this works...

    Do not touch or alter the virtusertable file at all....

    Make sure that the email address [email protected] is created for domain.tld only and not for domain5.tld if [email protected] exists remove and delete it out of the recycle bin..


    ISPconfig does not do this at all is works perfectly and the only time i can see ISPconfig doing such strange things would be if its configuration was changed or altered or ISPconfig was not setup correctly..

    regards
    brainz
     
  6. crypted

    crypted New Member

    Okay, I didn't get an immediate return failure daemon notice this time. However, the email has never arrived. It seems that there's a user issue isn't there? web3mobile shouldn't be used twice for two different domains... What do I do?

    [email protected] web3_mobile
    [email protected] web3_mobile
    [email protected] web3_mobile
    [email protected] web3_mobile
    [email protected] web3_mobile
    [email protected] web3_mobile
    [email protected] web3_mobile
    [email protected] web3_mobile
    #### MAKE MANUAL ENTRIES BELOW THIS LINE! ####

    Thanks!!!
     
  7. brainz

    brainz Member

    No it seems a little more complicated then just a user issue....

    See these two items above they really dont make sense...
    You know why.... This is because when a domain is created in ISPconfig it is assigned a webN or a web and then a number like web3 for example...

    What i see that is wrong above is both domains seem to be showing the same web3 which is wrong....

    Please check your domain setups for these 2 domains...... within ISPconfig and the email setup as well for these 2 domains....

    regards
    brainz
     
    Last edited: Nov 14, 2007
  8. crypted

    crypted New Member

    Okay I deleted the user, cleared the recycle bin, and tried to reinstate the email address. I get the following:

    The user with the name web3_mobile does already exist.
    Duplicate Email Address.

    There is nothing about this user in virtualusertable though... The domains are different. The actual domains are derekgordon.com (web3) and andovermeat.com (web49). Their /var/www/web# point correctly and the sites are loading okay.

    I'm not sure what to do about this.
     
  9. brainz

    brainz Member

    Why is says this is because the user is still created in mysql.

    Offcourse i will not take any respossiblity for anything if it goes wrong.
    Altering the mysql database for ISPconfig should not be done at all or is not required.


    However if you login to mysql as root....

    and look for db_ispconfig_domain <-- the domain means the main domain for ispconfig. This is the main mysql database for ispconfig.

    In here you look for isp_isp_user then click on browse tab, you will see a list of all the email address created in ispconfig....

    Here look for any email address which has web3_mobile.

    Offcourse please backup before altering this database....

    I would delete any entry that has a web3_mobile.. Then within ISPconfig admin try and recreate the email user.


    regards
    brainz

     
    Last edited: Nov 14, 2007
  10. crypted

    crypted New Member

    thanks for the help. unfortunately, phpmyadmin isn't letting me access anything even though the root user and password are correct. so i give up i guess. maybe when i get enough cash together to pay till i can get him to fix this as well...
     
  11. pablito

    pablito New Member

    I'm having a similar problem out of the blue.

    I'm suddenly seeing a similar problem. I'm on 2.2.18 and this is the first new user I've added since the upgrade. The user appears fine in the interface, the physical mailbox and IMAP login works fine. However the virtusertable has all the usual entries under the wrong domain, i.e. [email protected]_domain.com instead of [email protected]_domain.com. This causes inbound mail to fail as unknown user. The user also appears in the the ISP interface userlisting of other_domain.com but will give an error if I try to access. The user shows correctly under actual_domain.com interface listing.

    Inside the database I found table isp_fakt_record.web_id with other_domain's ID instead of actual_domain's ID. I changed that to the corect ID and manually changed virtusertable entries and everything works as expected. But if I try to change anything it goes back to the wrong domain ID and wrong virtusertable entries. I tried entering another new user and the same thing happens. The user is in the database only once but shows in the interface under two unrelated domains.

    The only changes have been the 2.2.18 upgrade and Centos updates that brought me from 4.5 to 4.6. I run a compiled from source Apache 1.3.39 and PHP 5.2.5 server (vs the OS binary RPMs) that I recompiled after the updates. Otherwise everything is functioning.
     
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    The table isp_fakt_record is only for invoices and has nothing to do with the actual websites in apache or the mail system.

    I guess that the problem is a duplicate record in the isp_dep table, which is the link between the isp_isp_web and the isp_isp_user table. The parent is the web table and the child is the user table.

    If you set

    isp_isp_web.doctype_id = isp_dep.parent_doctype_id
    isp_isp_web.doc_id = isp_dep.parent_doc_id
    isp_isp_user.doctype_id = isp_dep.child_doctype_id
    isp_isp_user.doc_id = isp_dep.child_doc_id

    you will get the relations.
     

Share This Page