mail bouncing error - 550-5.7.1

Discussion in 'ISPConfig 3 Priority Support' started by pawan, Feb 2, 2016.

  1. pawan

    pawan Member HowtoForge Supporter

    I have started getting this error suddenly. I don't what has changed during this time.
    MY PTR record for the IP 117.247.67.131 - is correctly pointing to mywebsolutions.co.in
    I have also created a txt record for SPF like - v=spf1 a mx ip4:117.247.67.131 ~all
    Code:
    <[email protected]>: host gmail-smtp-in.l.google.com[74.125.68.26] said:
    550-5.7.1 [117.247.67.131] The IP you're using to send mail is not
    authorized to 550-5.7.1 send email directly to our servers. Please use the
    SMTP relay at your 550-5.7.1 service provider instead. Learn more at 550
    5.7.1 https://support.google.com/mail/answer/10336 vr3si8008690pab.48 -
    gsmtp (in reply to end of DATA command)
    Code:
    Reporting-MTA: dns; server1.mywebsolutions.co.in
    X-Postfix-Queue-ID: 6AED7302B65
    X-Postfix-Sender: rfc822; [email protected]
    Arrival-Date: Sat, 30 Jan 2016 14:19:55 +0530 (IST)
    
    Final-Recipient: rfc822; [email protected]
    Original-Recipient: rfc822;[email protected]
    Action: failed
    Status: 5.7.1
    Remote-MTA: dns; gmail-smtp-in.l.google.com
    Diagnostic-Code: smtp; 550-5.7.1 [117.247.67.131] The IP you're using to send
        mail is not authorized to 550-5.7.1 send email directly to our servers.
        Please use the SMTP relay at your 550-5.7.1 service provider instead. Learn
        more at 550 5.7.1  https://support.google.com/mail/answer/10336
        vr3si8008690pab.48 - gsmtp
    
    Return-Path: <[email protected]>
    Received: from localhost (localhost.localdomain [127.0.0.1])
        by server1.mywebsolutions.co.in (Postfix) with ESMTP id 6AED7302B65
        for <[email protected]>; Sat, 30 Jan 2016 14:19:55 +0530 (IST)
    X-Virus-Scanned: Debian amavisd-new at server1.mywebsolutions.co.in
    Received: from server1.mywebsolutions.co.in ([127.0.0.1])
        by localhost (server1.mywebsolutions.co.in [127.0.0.1]) (amavisd-new, port 10024)
        with ESMTP id iGkpFnNENXK2 for <[email protected]>;
        Sat, 30 Jan 2016 14:19:51 +0530 (IST)
    Received: from mywebsolutions.co.in (mywebsolutions.co.in [117.247.67.131])
        (Authenticated sender: [email protected])
        by server1.mywebsolutions.co.in (Postfix) with ESMTPSA id CCCFC3013AF
        for <[email protected]>; Sat, 30 Jan 2016 14:19:50 +0530 (IST)
    MIME-Version: 1.0
    Content-Type: multipart/alternative;
    boundary="=_d44625aa69b708eb28341c9b65067e06"
    Date: Sat, 30 Jan 2016 14:19:50 +0530
    From: Pawan Joshi - Computer Books & Softwares <[email protected]>
    To: [email protected]
    Subject: checking mail
    Organization: Computer Books & Softwares
    Reply-To: [email protected]
    Mail-Reply-To: [email protected]
    Return-Receipt-To: Pawan Joshi - Computer Books & Softwares
    <[email protected]>
    Disposition-Notification-To: Pawan Joshi - Computer Books & Softwares
    <[email protected]>
    Message-ID: <[email protected]>
    X-Sender: [email protected]
    User-Agent: Roundcube Webmail/1.0.2
    
    Please guide me to correct this error.
     
  2. chico11mbit

    chico11mbit Member HowtoForge Supporter

    No reverse DNS entry?
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    I would recommend to set the reverse dns to the server hsotname (server1.mywebsolutions.co.in).

    And your server is in a adtacenter and not hosted at home or in office on a dsl line? The error message that chico11mbit quotes looks to me as if your IP is on a dialin / dynamic ip network blacklist at google.
     
  4. pawan

    pawan Member HowtoForge Supporter

    Hi Till,
    my reverse dns resolve to mywebsolutions.co.in. Is that not sufficient. As it was working with that setting until now.
    Again my IP is static & not dynamic. I am attaching the image for the IP I have queried.
    [​IMG]

    Do I still need to get it changed to server1.mywebsolutios.co.in
    As the same was working fine with reverse DNS - mywebsolutions.co.in
    While checking for the blacklist check, my IP is also not listed as blacklisted.
    Thanks.
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    The reverse dns shall point to the hostname of the server and not your domain.
     
  6. pawan

    pawan Member HowtoForge Supporter

    Hi Till,
    You mean I need to get it changed to - server1,mywebsolutions.co.in
    Thanks.
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes. The reverse record (PTR) shall match the server hostname, which is server1.mywebsolutions.co.in. But that's a general issue which is important that your emails dont get blocked as spam.

    A second issue is that Google blocks your domain. See link in the message for a explanation which explains you also which options you have: https://support.google.com/mail/answer/10336

    The "static" IP that you got assigned is from a dynamic IP range and not from a datacanetr and Google will not whitelist it, so you might have to use the outgoing SMTP server of your ISP to send out emails. See Relay host settings under System > Server Config > email, there oyu can configure the details for an external relay server.
     
  8. pawan

    pawan Member HowtoForge Supporter

    Hi Till,
    Thanks for the exhaustive explanation.
    Now two points
    1. is it possible that once I get the my present IP to resolve to Server1.mywebsolutions.co.in - it may be treated as the IP is authorized to send mail.
    2. Do I must get an IP which is not from dynamic IP Range.
    Also please note that the same IP was working fine till recently.
    Has google changed its policy for the dynamic IP range?
    what has changed during this time, as I am using the same IP for years, without this issue.
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    1) Unlikely.
    2) No. You can use as alternative a relay server. Ask your ISP that assigned you this IP if he provides and smtp server and then set that smtp server in ISPConfig as relay server.

    If your ISP assigned you this IP as static IP for mail server use, then you can try to contact him and ask him to get it delisted from dynamic IP ranges.

    I guess only Google can answer that :)
     
  10. pawan

    pawan Member HowtoForge Supporter

    Thanks Till
    1. is there way to ascertain that the specific IP is from STATIC Range or Dynamic Range?
    2. How do I ascertain that the IP allotted to me is actually de-listed from dynamic IP Ranges?
    3. As far as I know my ISP doesn't provide any service as relay server so do you know of any reliable relay server to which I can subscribe?

    Thanks again.
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    1) This depends on the lists that a mail provider uses. You may ask the Google support if you like to know if they list an IP as static or dynamic, but I doubt that they will answer that question. There are also some free rbl's that list dynamic IP addresses, google e.g. for "dynamic ip rbl".
    2) You will see it when you can send mail to google again without that message.
    3) No. I never needed that as all my servers are in a datacenter. You should consider if hosting your server in a datacenter might be a better option for you as well, virtual servers are really cheap these days
     

Share This Page