mail bounce & no webmail access

Discussion in 'Installation/Configuration' started by djriknet, May 20, 2007.

  1. djriknet

    djriknet New Member

    Dear all,


    First of all, thank you all for the great product ISPCONFIG and the great step by step guide...

    We had to install a linux webhosting server for our Bachelor Information Technology and System (BITS) and this helped us a lot.

    Our server is now up and running and within a week i will have a public static ip address on it.
    For now i was just testing locally, and got 2 problems:


    Problem number one:
    when i send an e-mail with outlook to myself, outgoing and incomming the fedora core 6 server with ispconfig.

    the e-mail is not coming into the mailbox, but when i send it to an e-mail address outside the server. it goes wel.

    In the log (/var/logs/maillog) i found this error:

    status=bounced (mail for heriso.com loops back to myself)

    I think now later on that it could be a error in the 'hosts' file, where the loopback is not good defined, but i'm now not able to contact the server, will check it monday. do anybody else know what this could be if it's not the hosts file?


    Question No. 2

    When i access my server (this case my test server running on vmware)
    (http://190.2.167.204:81) everything goes fine,
    i'm using a linksys router, with port forwarding, and when i try to connect to my webmail (http://190.2.167.204:81/webmail) it goes well insite the network but outside not.

    so when i connect with my pc insite this same network, great all works.
    wen i connect with a pc outsite on the internet the control pannel is coming up file (http://190.2.167.204:81 , you can try it, admin / admin, please do not mess up.....)
    but when i try to connect to the webmail, http://190.2.167.204:81/webmail it doesn't work, even the phpmyadmin not.....


    is this a security setting? and where can i find that?


    Kind regards,


    Hendrik Kroon
     
    Last edited: May 20, 2007
  2. falko

    falko Super Moderator ISPConfig Developer

    Please add heriso.com at the end of /etc/postfix/local-host-names and restart Postfix.

    Please try http://190.2.167.204:81/webmail/.
     
  3. djriknet

    djriknet New Member

    local domains.

    Dear falco,


    I tested your reply's the first one worked fine but the one of the bounce mail is already filled good i think.


    the file looks like this:

    ###################################
    #
    # ISPConfig local-host-names Configuration File
    # Version 1.0
    #
    ###################################
    localhost
    heriso.heriso.com
    localhost.heriso.heriso.com
    localhost.heriso.com
    localhost.localdomain
    www.niettestoppen.com
    www.heriso.com
    www.test.com
    www.noteblock.net
    niettestoppen.com
    heriso.com
    curacaophotos.com
    noteblock.net
    test.com
    #### MAKE MANUAL ENTRIES BELOW THIS LINE! ####



    what should i change?


    Kind regards.
     
  4. djriknet

    djriknet New Member

    Problem solved.

    Dear everybody.

    this problem is solved by now.
    Finaly we setup a other machine, and checked the difference.

    we saw a difference in the /etc/postfix/main.cf

    the line with the /etc/postfix/local-host-names file was not there.


    we replaced that line and it worked fine.

    I think i have to do a little explanation how this has happened.
    first we followed all the instructions to install a LAMP installation with Fedora Core 6.
    after that we installed ISP Config and had some problems with the DNS.

    We solved it by fixing a error in dependancy's what effected the postfix also.

    we "yum remove" the postfix and installed it again.

    That time the main.cf was cleared, we did all the config as described in the installation instructions. and came to the situation as hereabove.


    Thanks for all the support


    Hendrik Kroon
     

Share This Page