Mail being sent to /home/User/Maildir but its checking /var/spool/mail/User

Discussion in 'Installation/Configuration' started by phantomk, Jan 23, 2006.

  1. phantomk

    phantomk New Member

    The mail is being sent to the proper location, /home/User/Maildir/etc..., but I think when I try to check for new messages it is checking /var/spool/mail/User instead of where the mail is being delivered. I have been trying to figure out why, but have been struck at dead ends and finding I am doing the same thing over and over ... I am at a loss as to why it is doing this and as to where to find a solution.

    I am useing CentOS 3.X useing the Fedora Core 3 Perfect Setup guide as a reference.

    I do not recieve any error messages in the maillog so it must be a configuration error but I just don't know where to fix it.
     
  2. till

    till Super Moderator

    I guess you installed a pop3 and Imap daemon that is only capable of using mbox files instead of maildir. Install courier pop3 and imap instaed.
     
    Last edited: Jan 25, 2006
  3. falko

    falko Super Moderator

    You could also install Dovecot. It also uses Maildir.
     
  4. phantomk

    phantomk New Member

    I have courier installed, at least I think I do. I used the same install lines for the Fedora guide, just replaced apt-get with yum.
    Code:
    # yum install cyrus-sasl cyrus-sasl-devel cyrus-sasl-gssapi cyrus-sasl-md5 cyrus-sasl-plain postfix imap
    Gathering header information file(s) from server(s)
    Server: CentOS-3 - Addons
    Server: CentOS-3 - Base
    Server: CentOS-3 - Extras
    Server: CentOS-3 - Updates
    Finding updated packages
    Downloading needed headers
    cyrus-sasl is installed and is the latest version.
    cyrus-sasl-devel is installed and is the latest version.
    cyrus-sasl-gssapi is installed and is the latest version.
    cyrus-sasl-md5 is installed and is the latest version.
    cyrus-sasl-plain is installed and is the latest version.
    postfix is installed and is the latest version.
    imap is installed and is the latest version.
    No actions to take
    Could it be that I am just over looking something ?
     
  5. falko

    falko Super Moderator

    You've installed the imap package which uses mbox, not Maildir.
     

Share This Page