Mail being marked as spam

Discussion in 'ISPConfig 3 Priority Support' started by jon, Jan 14, 2015.

  1. jon

    jon Member HowtoForge Supporter

    I have a customer that is sending mail that is being marked as spam. It seems to mostly be marked as spam when they are sending to their own domain or another customer that is hosted on the same server.

    I had shut off spam scanning for both customers, however messages are still being blocked and quarantined.

    What are my options? I wouldn't mind if I had to shut off spam and virus scanning totally, I have a commercial solution that does that.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please take a look at the headers of the mail, the reason why the mail is marked as spam is mentioned there.
     
  3. jon

    jon Member HowtoForge Supporter

    I have but I'd like to either change the block score or turn it off completely for that customer.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    I cant really help you when you dont post them.

    You can change the block score in the spamfilter policy, see spam tag 2 level and spam kill level. Then select this policy for the custmer.
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

  6. jon

    jon Member HowtoForge Supporter

    I think that will help at least for now. I'll find the headers and post them too. Where do I find the levels to change them?
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    In the ISPConfig mail mdule, samfilter policys.
     
  8. jon

    jon Member HowtoForge Supporter

    X-Spam-Status: Yes, score=8.03 tag=3 tag2=6.9 kill=6.9
    tests=[DOS_OUTLOOK_TO_MX=2.845, FSL_HELO_NON_FQDN_1=0.001,
    HTML_MESSAGE=0.001, RCVD_IN_BRBL_LASTEXT=1.449,
    RCVD_IN_SORBS_WEB=0.77, RDNS_NONE=0.793, SPF_SOFTFAIL=0.665,
    SUBJ_ALL_CAPS=1.506] autolearn=no
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    The spf record for the domain seems to be wrong (the mail server that your customers used to send the mail is not allowed according to spf), then your customer used a subject which is completely capitalized, thats uncommon for normal mail but common for spam, the mail server is listed in the Realtime blacklist RCVD_IN_BRBL_LASTEXT, and in SORBS

    For the DOS_OUTLOOK_TO_MX test: add all your server IP's that are ttrused in the setting "trusted_networks" in /etc/spamassassin/local.cf and restart amavisd afterwards.

    https://spamassassin.apache.org/full/3.1.x/doc/Mail_SpamAssassin_Conf.html
     
    jon likes this.
  10. jon

    jon Member HowtoForge Supporter

    That gives me everything I need, thanks so much!
     

Share This Page