Mail Authentication fails in OSX on port 465

Discussion in 'Installation/Configuration' started by JeffryL, Apr 11, 2011.

  1. JeffryL

    JeffryL New Member

    I've been stumbling upon this for a few days now. I use OSX Mail and somehow I just can't configure it to work with my Debian Squeeze with ISPConfig 3.

    ISP blocks port 25
    So I try to connect through 465
    And yes I want a secure connection...

    What I've done:
    Decomment in /etc/postfix/
    smtps     inet  n       -       -       -       -       smtpd
    Restart postfix

    Enable firewall port 465

    Checked telnet, outcome on port 465:
    Escape character is '^]'.
    220 ESMTP Postfix (Debian/GNU)
    ehlo localhost
    250 DSN
    Seems okay right? But OSX mail keeps complaining it cannot reach the server. Mail retrieval is possible. In both cases I use (IMAP and SMTP.

    So different operating system then... Ubuntu 10.10 mail client (Evolution). It works but only if I use TLS.

    Back to OSX.. nope.. doesn't work. I've already specified to use port 465 on Advanced settings. But just can't figure it out. I've even done a full reboot of the server... enabled/disables ssh, but no luck so far. Pleeezz help :), how do I configure my server OSX Mail also works.
    Last edited: Apr 11, 2011
  2. falko

    falko Super Moderator ISPConfig Developer

    Are there any errors in your mail log (in the /var/log/ directory)?
  3. JeffryL

    JeffryL New Member

    Hi Falko, thank u for replying. I did find these messages today in mail.log:
    Apr 12 17:57:35 vps postfix/smtpd[32323]: connect from[]
    Apr 12 18:02:35 vps postfix/smtpd[32323]: lost connection after UNKNOWN from[]
    Apr 12 18:02:35 vps postfix/smtpd[32323]: disconnect from[]
    As follows from the timestamp the second and third message appear only after OSX Mail end because of a time-out. The telnet connect and ehlo localhost and quit appear normally.

    In the working Ubuntu the following appears:
    Apr 12 18:26:13 VPS postfix/smtpd[596]: connect from[]
    Apr 12 18:26:14 VPS postfix/smtpd[596]: 38A839C511:[], sasl_method=PLAIN, [email protected]
    Apr 12 18:26:14 VPS postfix/cleanup[599]: 38A839C511: message-id=<[email protected]>
    Apr 12 18:26:14 VPS postfix/qmgr[2023]: 38A839C511: from=<[email protected]>, size=928, nrcpt=1 (queue active)
    Apr 12 18:26:15 VPS postfix/smtpd[596]: disconnect from[]
    Apr 12 18:26:15 VPS postfix/smtp[601]: 38A839C511: to=<[email protected]>, relay=ASPMX.L.GOOGLE.COM[]:25, delay=1.6, delays=0.25/0.01/0.13/1.2, dsn=2.0.0, status=sent (250 2.0.0 OK 1302632774 p50si16587853eei.98)
    Apr 12 18:26:15 vps1042 postfix/qmgr[2023]: 38A839C511: removed
    And what I did was disable the virusscanner (before using mail) by editing and commenting:
    #content_filter = amavis:[]:10024
    #receive_override_options = no_address_mappings
    And in
    #amavis unix - - - - 2 smtp
    #        -o smtp_data_done_timeout=1200
    #        -o smtp_send_xforward_command=yes
    # inet n - - - - smtpd
    #        -o content_filter=
    #        -o local_recipient_maps=
    #        -o relay_recipient_maps=
    #        -o smtpd_restriction_classes=
    #        -o smtpd_client_restrictions=
    #        -o smtpd_helo_restrictions=
    #        -o smtpd_sender_restrictions=
    #        -o smtpd_recipient_restrictions=permit_mynetworks,reject
    #        -o mynetworks=
    #        -o strict_rfc821_envelopes=yes
    #        -o receive_override_options=no_unknown_recipient_checks,no_header_body_checks
    #        -o smtpd_bind_address=
    But I don´t think that´s the problem since everything works in Ubuntu right?

    And last but not least an error appeared while figuring this error out when connecting to the server for incoming mail (pop/imap), which was solved by installing gamin instead of fam.
    Last edited: Apr 12, 2011
  4. JeffryL

    JeffryL New Member

    Tried it with a ubuntu 10.04/ISP3 setup, but this results in the same problem. It's gotta be something with OSX Mail that is not working very well. But I just can't find out what the problem is.

    Isn't it strange a connection pops up, but nothing seems to happen while everything seems configured allright?

    Any thoughts on this are appreciated!
  5. falko

    falko Super Moderator ISPConfig Developer

    Hm, I have no idea... :( Unfortunately I don't have a Mac to test.
  6. JeffryL

    JeffryL New Member

    Ok the solution was not that hard... I also had to uncomment the following lines in for OSX Mail to work.

    smtps     inet  n       -       n       -       -       smtpd
      -o smtpd_tls_wrappermode=yes
      -o smtpd_sasl_auth_enable=yes
      -o smtpd_client_restrictions=permit_sasl_authenticated,reject
    Still, I haven't got a clue why it did work in Ubuntu and not in OSX Mail. So if someone has any ideas about this, share them :)
    Last edited: Apr 23, 2011

Share This Page