mail and web hostname questions (local-host-names etc..)

Discussion in 'Installation/Configuration' started by didan, May 18, 2006.

  1. didan

    didan New Member

    Hi all,

    I use ispconfig and i love ispconfig :)

    but i have some problems with panel.

    i create some sites ex: www.domain.com
    and i can't access with out "www"

    i browse my domain name with "www." and i see this banner "Welcome to www.domain.com!"

    but i browse my domain with out "www" and result is "Shared IP" on top.
    how result this prob?.
    "www" "A" host is exist in dns records.


    and another problem..

    i can't receiving mails
    in /etc/postfix/local-host-names

    ###################################
    #
    # ISPConfig local-host-names Configuration File
    # Version 1.0
    #
    ###################################
    localhost
    63079.myhost.com
    localhost.63079.myhost.com
    localhost.myhost.com
    www.domain.com
    #### MAKE MANUAL ENTRIES BELOW THIS LINE! ####

    ??? why my domain in local-host-names with "www" ??


    i sending test mail to myname@domain.com .. i can't receive .. but i send mail to myname@www.domain.com and all is OK. ?? why www.. and why forced hostname for websites in ispconfig ?.
    (yes i know manual changement for hostname in local-host-names .. removing www. but i wish all auto)

    oops.

    i added behind line
    #### MAKE MANUAL ENTRIES BELOW THIS LINE! ####
    domain.net

    but not worked :((...
    i can't receiving my emails ... my mail work only with "www" host name.

    my virtusertable config file ..
    ###################################
    #
    # ISPConfig virtusertable Configuration File
    # Version 1.0
    #
    ###################################
    user@www.domain.com web6_user
    web6_user@www.user.com web6_user
    user@www.domain.eu web6_user
    web6_user@www.user.eu web6_user
    #### MAKE MANUAL ENTRIES BELOW THIS LINE! ####




    thanks.
     
    Last edited: May 18, 2006
  2. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    You must add your domain without the www on the Co-Domains tab of that web site.
     
  3. didan

    didan New Member

    yes but i can't adding domains with out "www" or hostname
     
  4. didan

    didan New Member

    i remove hostname from config page but i refresh this page.. and hostname is already "www" :((( ..

    and i want reinstall ispconfig but uninstall command is not useful but this command not remove all..

    Thanks..


    IspConfig Rulaz!!!
     
  5. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    You must go to the Co-Domains tab. Then create a new Co-Domain, but leave the hostname empty.
     
  6. didan

    didan New Member

    ok .. but now www.domain.com is not working.. only domain.com site working (i add all A names in dns settings www etc..)
    with www.domain.com (shared ip)
    domain.com (good!)

    :((
     
  7. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Did you empty the host field in the website settings?

    The correct setup is:

    ----------------------
    Website
    ----------------------
    host: www
    domain: example.com

    ----------------------
    Co-Domain
    ----------------------
    host:
    domain: example.com

    To make sure everything is saved correctly, you can open the website afain and hit save.
     
  8. didan

    didan New Member

    thanks.
    (rec: why this feature is not auto ?)
     
  9. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    The Co-domains where created automatically, if there is no domain example.com in another website.
     

Share This Page